OL2002: Modifica del campo "Archivia come" per tutti i contatti

Questo articolo è stato precedentemente pubblicato con il codice di riferimento I291144
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sommario
In questo articolo viene descritto come utilizzare un modulo personalizzato di Outlook e Visual Basic Scripting Edition (VBScript) per modificare a livello di programmazione il campo Archivia come per un numero elevato di contatti esistenti.
Informazioni
IMPORTANTE: se si modifica il formato del campo Archivia come utilizzando il modulo per i contatti standard di Outlook, ci si assicura che il formato di questo campo non influirà su altre aree in cui venga visualizzato questo tipo di informazione, ad esempio nella parte superiore di un contatto visualizzato nella vista Schede indirizzi. Tuttavia nell'esempio riportato in questo articolo viene modificato solo il campo Archivia come e non il relativo formato, pertanto non viene eseguita la stessa funzione del modulo del contatto di Outlook. Microsoft raccomanda di eseguire una copia della cartella dei contatti e di utilizzare il codice riportato di seguito per la cartella copiata. In questo modo i vantaggi derivanti dall'utilizzo di questo codice di esempio supereranno i potenziali svantaggi impliciti in questo tipo di approccio.

NOTA: la modifica del campo Archivia come non influenza l'ordine in base a cui i contatti vengono visualizzati nella Rubrica di Outlook.

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia di qualsiasi tipo, sia espressa che implicita, ivi incluse, senza limitazioni, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presume che l'utente conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug delle procedure. Gli esperti Microsoft sono autorizzati a fornire spiegazioni in merito alla funzionalità di una particolare procedura, ma in nessun caso a modificare questi esempi per fornire funzionalità aggiuntive o a creare procedure atte a soddisfare specifiche esigenze. Se si dispone di esperienza di programmazione limitata, si consiglia di contattare un Microsoft Certified Partner o la filiale Microsoft locale per informazioni sulla consulenza tecnica. Per ulteriori informazioni in merito ai Microsoft Certified Partner, visitare la seguente pagina Web (informazioni in lingua inglese): Per ulteriori informazioni sulle opzioni di supporto disponibili da Microsoft, visitare la seguente pagina Web: Quando si crea un nuovo modulo personalizzato di Outlook, il campo Archivia come viene modificato per tutti i contatti in uno dei seguenti formati:
  • Nome Cognome
  • Cognome, Nome
  • Società
  • Cognome, Nome (Società)
  • Società (Cognome, Nome)

Creazione della struttura di un modulo personalizzato

  1. Scegliere Nuovo dal menu File, quindi fare clic su Messaggio per aprire un nuovo messaggio di posta elettronica.
  2. Nel nuovo messaggio di posta elettronica scegliere Moduli dal menu Strumenti, quindi fare clic su Crea la struttura del modulo.
  3. Inserire cinque pulsanti di comandi nel nuovo modulo. Per effettuare questa operazione:
    1. Fare clic sulla scheda (P.2) per passare a una pagina vuota del modulo.
    2. Scegliere Strumenti di controllo dal menu Modulo, quindi Pulsante di comando e infine trascinare il pulsante sulla pagina vuota del modulo.
    3. Fare clic con il pulsante destro del mouse sul nuovo pulsante, scegliere Proprietà, quindi digitarecmdLastFirstnella casella Nome.
    4. Nella casella Didascalia digitareCognome, Nome, quindi scegliere OK.
    5. Nella finestra di dialogo Casella degli strumenti fare clic su Pulsante di comando, quindi trascinare un secondo pulsante sulla pagina vuota del modulo.
    6. Fare clic con il pulsante destro del mouse sul nuovo pulsante, scegliere Proprietà, quindi digitarecmdFirstLastnella casella Nome.
    7. Nella casella Didascalia digitareNome Cognome, quindi scegliere OK.
    8. Nella finestra di dialogo Casella degli strumenti fare clic su Pulsante di comando, quindi trascinare un terzo pulsante sulla pagina vuota del modulo.
    9. Fare clic con il pulsante destro del mouse sul nuovo pulsante, scegliere Proprietà, quindi digitarecmdCompanynella casella Nome.
    10. Nella casella Didascalia digitareSocietà, quindi scegliere OK.
    11. Nella finestra di dialogo Casella degli strumenti fare clic su Pulsante di comando, quindi trascinare un quarto pulsante sulla pagina vuota del modulo.
    12. Fare clic con il pulsante destro del mouse sul nuovo pulsante, scegliere Proprietà, quindi digitarecmdLastFirstCompanynella casella Nome.
    13. Nella casella Didascalia digitareCognome, Nome (Società), quindi scegliere OK.
    14. Nella finestra di dialogo Casella degli strumenti fare clic su Pulsante di comando, quindi trascinare un quinto pulsante sulla pagina vuota del modulo.
    15. Fare clic con il pulsante destro del mouse sul nuovo pulsante, scegliere Proprietà, quindi digitarecmdCompanyLastFirstnella casella Nome.
    16. Nella casella Didascalia digitareSocietà (Cognome, Nome), quindi scegliere OK.
  4. Digitare il codice di Visual Basic Scripting Edition (VBScript) riportato di seguito. Per effettuare questa operazione:
    1. Scegliere Visualizza codice dal menu Modulo per aprire Microsoft Script Editor.
    2. In Script Editor digitare o copiare il codice riportato di seguito:
      Option ExplicitDim strSortBySub cmdLastFirst_Click()   strSortBy = "LastFirst"   UpdateContactsEnd SubSub cmdFirstLast_Click()   strSortBy = "FirstLast"   UpdateContactsEnd SubSub cmdCompany_Click()   strSortBy = "Company"   UpdateContactsEnd SubSub cmdLastFirstCompany_Click()   strSortBy = "Last, First (Company)"   UpdateContactsEnd SubSub cmdCompanyLastFirst_Click()   strSortBy = "Company (Last, First)"   UpdateContactsEnd SubSub UpdateContacts()   Dim CurFolder   Dim MyItems   Dim MyItem   Dim NumItems, i   ' Use whichever folder is currently selected   Set CurFolder = Application.ActiveExplorer.CurrentFolder   ' Make sure it's a contact folder   If CurFolder.DefaultItemType = 2 Then      MsgBox "This process may take some time. You will be " & _      "notified when complete.", , "Contact Tools Message"      Set MyItems = CurFolder.Items      NumItems = MyItems.Count      For i = 1 to NumItems         Set MyItem = MyItems.Item(i)         ' Make sure it's not a distribution list in the folder         ' (really only applies to OL98 and OL2000)         If TypeName(MyItem) = "ContactItem" Then            Select Case strSortBy               Case "LastFirst"                  If MyItem.LastNameandFirstName <> "" Then                     MyItem.FileAs = MyItem.LastNameandFirstName                  Else                     MyItem.FileAs = MyItem.CompanyName                  End IF               Case "FirstLast"                  If MyItem.Subject <> "" Then                     MyItem.FileAs = MyItem.Subject                  Else                     MyItem.FileAs = MyItem.CompanyName                  End IF               Case "Company"                  If MyItem.CompanyName <> "" Then                     MyItem.FileAs = MyItem.CompanyName                  Else                     MyItem.FileAs = MyItem.LastNameandFirstName                  End IF               Case "Last, First (Company)"                  MyItem.FileAs = MyItem.LastNameAndFirstName                  If MyItem.CompanyName <> "" Then                     If MyItem.FileAs <> "" Then                        MyItem.FileAs = MyItem.FileAs & " (" & _                                        MyItem.CompanyName & ")"                     Else                        MyItem.FileAs = MyItem.FileAs & _                                  MyItem.CompanyName                     End If                  End If               Case "Company (Last, First)"                  MyItem.FileAs = MyItem.CompanyName                  If MyItem.LastNameandFirstName <> "" Then                     If MyItem.FileAs <> "" Then                        MyItem.FileAs = MyItem.FileAs & " (" & _                               MyItem.LastNameAndFirstName & ")"                     Else                        MyItem.FileAs = MyItem.FileAs & _                               MyItem.LastNameAndFirstName                     End If                  End If            End Select            MyItem.Save         End If           ' check TypeName      Next      MsgBox "Finished updating contacts."   Else      MsgBox "The current folder must be a contacts folder."   End If                 ' check contacts folder   Set MyItem = Nothing   Set MyItems = Nothing   Set CurFolder = NothingEnd Sub
    3. In Script Editor scegliere Chiudi dal menu File per tornare al modulo.
    4. Fare clic sulla pagina Messaggio del modulo.
    5. Scegliere Visualizza questa pagina dal menu Modulo. La pagina del modulo verrà nascosta in modo che non venga visualizzata quando il modulo viene utilizzato.
  5. Pubblicare il modulo. Per effettuare questa operazione:
    1. Scegliere Moduli dal menu Strumenti, quindi Pubblica modulo come.
    2. Verificare che accanto al pulsante Cerca in sia visualizzato Libreria moduli personali.
    3. Nella casella Nome visualizzato digitare un nome descrittivo per il nuovo modulo, ad esempio Modifica campi Archivia come, quindi scegliere il pulsante Pubblica.
    4. Alla richiesta di salvare la definizione del modulo con l'elemento, scegliere No.
    5. Chiudere il messaggio senza salvarlo.

Utilizzo del modulo personalizzato

Per utilizzare il nuovo modulo, attenersi alla procedura descritta di seguito:
  1. Trovare la cartella dei contatti per la quale si desidera modificare la sequenza.
  2. Scegliere Nuovo dal menu File, quindi scegliere Scegli modulo.
  3. Nella casella Cerca in selezionare Libreria moduli personali, fare clic sul nuovo modulo, quindi scegliere OK.
  4. Fare clic sul pulsante appropriato per aggiornare il campo Archivia come.
Riferimenti
Per ulteriori informazioni sulle risorse disponibili e sulle risposte alle domande più frequenti relative alle soluzioni di Microsoft Outlook, vedere il seguente articolo della Microsoft Knowledge Base (gli articoli con prefisso "Q" contengono informazioni in inglese):
287530OL2002: Domande relative ai moduli personalizzati e alle soluzioni di Outlook
OutSol OutSol2002
Proprietà

ID articolo: 291144 - Ultima revisione: 12/06/2015 01:04:17 - Revisione: 1.1

Microsoft Outlook 2002 Standard Edition

  • kbnosurvey kbarchive kbhowto KB291144
Feedback