MS15-041: Descrizione dell'aggiornamento della protezione per.NET Framework 4 su Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2: 14 aprile 2015

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 3037578
Introduzione
Questo aggiornamento risolve una vulnerabilità in di Microsoft.NET Framework che potrebbe consentire l'intercettazione di informazioni personali se un utente malintenzionato invia una richiesta web appositamente predisposto a un server interessato che ha disabilitati i messaggi di errore personalizzato. Un utente malintenzionato che riesca a sfruttare la vulnerabilità sarebbe in grado di visualizzare le parti di un file di configurazione web che potrebbero esporre informazioni riservate.
Sommario
Microsoft ha rilasciato il Bollettino Microsoft sulla sicurezza MS15-041. Ulteriori informazioni su come ottenere le correzioni incluse in questo bollettino sulla sicurezza:

Come ottenere la Guida in linea e supporto tecnico per questo aggiornamento della protezione

Guida all'installazione degli aggiornamenti: Supporto per Microsoft Update

Soluzioni di protezione per i professionisti IT: Supporto e risoluzione dei problemi di sicurezza TechNet

Per proteggere il computer basato su Windows da virus e malware: Soluzione di virus e Centro sicurezza PC

Supporto locale in base al proprio paese: Supporto internazionale

Ulteriori informazioni su questo aggiornamento della protezione

Informazioni sul download

Per installare questo aggiornamento, è possibile installarlo dal Microsoft Windows Update.

Inoltre, è possibile installare l'aggiornamento dal Area Download Microsoft.

Prerequisiti

Per installare questo aggiornamento, è necessario disporre di Windows Installer 3.1 o versione successiva installato nel computer.

Opzioni della riga di comando per questo aggiornamento

Informazioni sui vari opzioni della riga di comando che sono supportate da questo aggiornamento per Microsoft.NET Framework.

Informazioni sul riavvio

Questo aggiornamento non richiede un riavvio del sistema dopo l'applicazione a meno che i file da aggiornare sono bloccati o in uso.

Nota Questo aggiornamento causerà il riavvio del servizio IIS.

Informazioni sulla sostituzione dell'aggiornamento

Questo aggiornamento sostituisce il seguente aggiornamento:

2901110 MS14-009: Descrizione dell'aggiornamento della protezione per.NET Framework 4 su Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2: 11 febbraio 2014

Informazioni sulla rimozione di aggiornamento

Nota Non è consigliabile rimuovere un aggiornamento della protezione.

Per rimuovere questo aggiornamento, utilizzare l'elemento programmi e funzionalità nel Pannello di controllo.

Informazioni sui file

La versione inglese (Stati Uniti) di questo aggiornamento consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.

Per tutte le versioni x86 versioni supportate dei sistemi
Ramo del servizio GDR
Nome del fileVersione del fileDimensione del fileDataOra
ServiceModelReg.exe4.0.30319.1031192,66405-Feb-201513:16
Setup.exe10.0.30319.103178,99205-Feb-201513:15
SetupEngine.dll10.0.30319.1031811,15205-Feb-201513:15
SetupUi.dll10.0.30319.1031296,58405-Feb-201513:15
aspnet_wp.exe4.0.30319.103133,42405-Feb-201514:12
Extensions4.0.30319.10311,867,44005-Feb-201514:12
System.Web.dll4.0.30319.10315,258,39205-Feb-201514:12
System4.0.30319.1031835,75205-Feb-201514:12
webengine.dll4.0.30319.103114,99205-Feb-201514:12
webengine4.dll4.0.30319.1031496,27205-Feb-201514:12
LDR ramo del servizio
Nome del fileVersione del fileDimensione del fileDataOra
ServiceModelReg.exe4.0.30319.2056192,66405-Feb-201515:00
Setup.exe10.0.30319.205678,98405-Feb-201514:59
SetupEngine.dll10.0.30319.2056811,15205-Feb-201514:59
SetupUi.dll10.0.30319.2056296,58405-Feb-201514:59
aspnet_wp.exe4.0.30319.205633,42405-Feb-201516:08
Extensions4.0.30319.20561,867,43205-Feb-201516:08
System.Web.dll4.0.30319.20565,263,00005-Feb-201516:08
System4.0.30319.2056835,74405-Feb-201516:08
webengine.dll4.0.30319.205614,99205-Feb-201516:08
webengine4.dll4.0.30319.2056496,27205-Feb-201516:08
Per tutte le versioni basate su x64 dei sistemi di supportate
GDR ramo del servizio
Nome del fileVersione del fileDimensione del fileDataOra
ServiceModelReg.exe4.0.30319.1031261,79205-Feb-201513:32
ServiceModelReg.exe4.0.30319.1031192,66405-Feb-201513:16
Setup.exe10.0.30319.103178,99205-Feb-201513:15
SetupEngine.dll10.0.30319.1031811,15205-Feb-201513:15
SetupUi.dll10.0.30319.1031296,58405-Feb-201513:15
aspnet_wp.exe4.0.30319.103141,61605-Feb-201514:24
aspnet_wp.exe4.0.30319.103133,42405-Feb-201514:12
Extensions4.0.30319.10311,867,44005-Feb-201514:12
System.Web.dll4.0.30319.10315,228,18405-Feb-201514:23
System.Web.dll4.0.30319.10315,258,39205-Feb-201514:12
System4.0.30319.1031835,75205-Feb-201514:12
webengine.dll4.0.30319.103116,52805-Feb-201514:24
webengine.dll4.0.30319.103114,99205-Feb-201514:12
webengine4.dll4.0.30319.1031721,55205-Feb-201514:24
webengine4.dll4.0.30319.1031496,27205-Feb-201514:12
LDR ramo del servizio
Nome del fileVersione del fileDimensione del fileDataOra
ServiceModelReg.exe4.0.30319.2056261,79205-Feb-201515:21
ServiceModelReg.exe4.0.30319.2056192,66405-Feb-201515:00
Setup.exe10.0.30319.205678,98405-Feb-201514:59
SetupEngine.dll10.0.30319.2056811,15205-Feb-201514:59
SetupUi.dll10.0.30319.2056296,58405-Feb-201514:59
aspnet_wp.exe4.0.30319.205641,61605-Feb-201516:24
aspnet_wp.exe4.0.30319.205633,42405-Feb-201516:08
Extensions4.0.30319.20561,867,43205-Feb-201516:08
System.Web.dll4.0.30319.20565,232,78405-Feb-201516:24
System.Web.dll4.0.30319.20565,263,00005-Feb-201516:08
System4.0.30319.2056835,74405-Feb-201516:08
webengine.dll4.0.30319.205616,53605-Feb-201516:24
webengine.dll4.0.30319.205614,99205-Feb-201516:08
webengine4.dll4.0.30319.2056722,07205-Feb-201516:24
webengine4.dll4.0.30319.2056496,27205-Feb-201516:08
Per tutti basati su IA-64 versioni supportate dei sistemi
GDR ramo del servizio
Nome del fileVersione del fileDimensione del fileDataOra
ServiceModelReg.exe4.0.30319.1031545,43205-Feb-201513:52
ServiceModelReg.exe4.0.30319.1031192,66405-Feb-201513:16
Setup.exe10.0.30319.103178,99205-Feb-201513:15
SetupEngine.dll10.0.30319.1031811,15205-Feb-201513:15
SetupUi.dll10.0.30319.1031296,58405-Feb-201513:15
aspnet_wp.exe4.0.30319.103181,04005-Feb-201514:36
aspnet_wp.exe4.0.30319.103133,42405-Feb-201514:12
Extensions4.0.30319.10311,867,44005-Feb-201514:12
System.Web.dll4.0.30319.10314,847,24805-Feb-201514:35
System.Web.dll4.0.30319.10315,258,39205-Feb-201514:12
System4.0.30319.1031835,75205-Feb-201514:12
webengine.dll4.0.30319.103126,25605-Feb-201514:36
webengine.dll4.0.30319.103114,99205-Feb-201514:12
webengine4.dll4.0.30319.10311,342,09605-Feb-201514:36
webengine4.dll4.0.30319.1031496,27205-Feb-201514:12
LDR ramo del servizio
Nome del fileVersione del fileDimensione del fileDataOra
ServiceModelReg.exe4.0.30319.2056545,44005-Feb-201515:46
ServiceModelReg.exe4.0.30319.2056192,66405-Feb-201515:00
Setup.exe10.0.30319.205678,98405-Feb-201514:59
SetupEngine.dll10.0.30319.2056811,15205-Feb-201514:59
SetupUi.dll10.0.30319.2056296,58405-Feb-201514:59
aspnet_wp.exe4.0.30319.205681,04005-Feb-201516:40
aspnet_wp.exe4.0.30319.205633,42405-Feb-201516:08
Extensions4.0.30319.20561,867,43205-Feb-201516:08
System.Web.dll4.0.30319.20564,851,86405-Feb-201516:40
System.Web.dll4.0.30319.20565,263,00005-Feb-201516:08
System4.0.30319.2056835,74405-Feb-201516:08
webengine.dll4.0.30319.205626,25605-Feb-201516:40
webengine.dll4.0.30319.205614,99205-Feb-201516:08
webengine4.dll4.0.30319.20561,343,12805-Feb-201516:40
webengine4.dll4.0.30319.2056496,27205-Feb-201516:08

Si applica a

In questo articolo si applica al seguente:
  • Microsoft.NET Framework 4 Se utilizzato con:
    • Windows Server 2008 R2 Service Pack 1
    • Windows 7 Service Pack 1
    • Windows Server 2008 Service Pack 2
    • Windows Vista Service Pack 2
    • Windows Server 2003 Service Pack 2

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 3037578 - Ultima revisione: 07/21/2015 10:22:00 - Revisione: 2.0

Microsoft .NET Framework 4.0

  • kbsecvulnerability kbsecurity kbsecbulletin kbfix kbexpertiseinter kbbug atdownload kbmt KB3037578 KbMtit
Feedback