Al momento sei offline in attesa che la connessione Internet venga ristabilita

Possibile rimozione delle autorizzazioni di protezione dei file ereditate quando vengono modificate in modalità remota

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l Ulteriori informazioni su come continuare a essere protetti.

Sintomi
Quando un'unità è connessa a un punto di condivisione di un server e si modificano le autorizzazioni relative al file system NTFS remoto, le eventuali autorizzazioni ereditate esistenti vengono rimosse e vengono mantenute solo le autorizzazioni esplicite.
Cause
Il problema si verifica perché il client interpreta l'unità connessa come cartella principale dell'unità. Poiché la cartella principale di un'unità non eredita autorizzazioni, le eventuali autorizzazioni ereditate vengono rimosse.
Risoluzione

Windows XP

Informazioni sul service pack

Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Acquisizione della versione più recente del service pack di Windows 2000

Informazioni sull'aggiornamento rapido (hotfix)

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo aggiornamento rapido (hotfix) vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale aggiornamento rapido (hotfix).

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido (hotfix). Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Informazioni sui file
La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data         Ora      Versione     Dimensioni    Nome file   -------------------------------------------------------------   21/03/2002   23.01    5.1.2600.40      36.352    Rshx32.dll   21/03/2002   00.22    5.1.2600.40       3.584    Xpsp1res.dll

Windows 2000

Informazioni sul service pack

Per risolvere il problema è necessario ottenere la versione più recente del service pack per Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
260910 Come ottenere il Service Pack più recente per Windows 2000

Informazioni sull'aggiornamento rapido (hotfix)

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo aggiornamento rapido (hotfix) vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows 2000 contenente tale aggiornamento rapido (hotfix).

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido (hotfix). Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Informazioni sui file
La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data            Ora        Versione  Dimensioni   Nome file   -------------------------------------------------------------   28/01/2002    23.28   5.0.2195.4881      34.576   Rshx32.dll   28/01/2002    23.23   5.0.2195.4881      13.824   Sp3res.dll

Windows NT 4.0

Per risolvere il problema, modificare le autorizzazioni NTFS mentre si è connessi alla console o mentre si è connessi al computer utilizzando una sessione di Servizi terminal.

È possibile modificare le autorizzazioni NTFS in modalità remota utilizzando un'unità connessa se la modifica viene effettuata a un livello inferiore della cartella principale dell'unità connessa. Ad esempio, è possibile modificare le autorizzazioni NTFS in modalità remota se si modifica una sottocartella dell'unità connessa.
Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo.

Windows XP

Questo problema è stato corretto per la prima volta nel Service Pack 1 per Windows XP.

Windows 2000

Questo problema è stato corretto per la prima volta nel Service Pack 3 per Windows 2000.
Informazioni
Quando si modifica l'elenco di controllo di accesso (ACL, Access Control List) a livello di cartella principale dell'unità, eventuali autorizzazioni ereditate vengono rimosse. Le autorizzazioni ereditate a livello di cartella principale di un'unità non sono valide perché non esiste una cartella padre della cartella principale. Pertanto, quando si connette un'unità a un punto di condivisione remoto e si modifica l'elenco di controllo di accesso, tale punto viene interpretato dal client come cartella principale dell'unità e vengono mantenute solo le autorizzazioni esplicite.

Se si impostano autorizzazioni in modalità remota per la cartella principale di una condivisione, tutte le autorizzazioni ereditate verranno rimosse dalla cartella principale e da tutte le relative sottocartelle e verrà visualizzato un messaggio di errore. Per impostare autorizzazioni in modalità remota per la cartella principale di una condivisione senza rimuovere le autorizzazioni ereditate, scegliere No nel messaggio di errore visualizzato. Modificare quindi le autorizzazioni su una sottocartella o apportare la modifica mentre si è connessi localmente.

È possibile ripristinare le autorizzazioni perse sul server o sulla workstation che ospita il punto di condivisione, attenendosi alla procedura seguente: Utilizzare la lettera e il percorso dell'unità locale e aggiungere o rimuovere un'autorizzazione utente o di gruppo nella directory che ha perso le autorizzazioni ereditate, quindi applicare la modifica. Tutti i diritti ereditati verranno nuovamente visualizzati e applicati a tale directory e a tutte le relative sottodirectory.
kbMgmtAdmin
Proprietà

ID articolo: 304140 - Ultima revisione: 03/31/2006 13:41:40 - Revisione: 2.2

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • kbqfe kbhotfixserver kbwin2ksp4fix kbbug kbenv kbfix kbsecurity kbsysadmin kbwin2000presp3fix kbwin2000sp3fix kbwinxpsp1fix KB304140
Feedback