Come creare una query di selezione in Access 2002

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 304325
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Richiedente: Richiede la conoscenza dell'interfaccia utente a utente singolo computer.

Il contenuto di questo articolo è applicabile solo ai database Microsoft Access (mdb).

Per la una versione di Microsoft Access 97 di questo articolo, vedere 304444.
Per la una versione di Microsoft Access 2000 di questo articolo, vedere 304361.

Contenuto dell'attività

Sommario
In Microsoft Access, è possibile creare una query per recuperare informazioni da una tabella o da più tabelle. È quindi possibile utilizzare la query come base di un modulo, un report o una pagina di accesso ai dati. In questo articolo viene illustrato come creare semplici query in Microsoft Access e come applicare l'ordinamento e i criteri per le query. Il presente articolo contiene le seguenti sezioni:
  • Che cos'È una query di seleziona?
  • Creazione di una query di seleziona utilizzando la creazione guidata
  • Creazione di una query di seleziona in visualizzazione struttura
  • Aggiunta di criteri di query
  • Come raggruppare record e creare somme e altri totali
  • L'ordinamento dei record in una query

back to the top

Che cos'È una query di seleziona?

Una query di selezione è il tipo più comune di query. Viene utilizzata per:
  • Recuperare di dati da una o più tabelle utilizzando i criteri specificati e quindi visualizzare i dati nell'ordine desiderato.
  • Modificare e aggiornare record nel foglio dati di una query di selezione (con alcune limitazioni).
  • Raggruppare i record e calcolare somme, conteggi, medie e altri tipi di totali.
back to the top

Creazione di una query di seleziona utilizzando la creazione guidata

La procedura seguente è illustrato come creare una query per recuperare informazioni su clienti e ordini dal database di esempio Northwind incluso in Microsoft Access 2002.

Per ulteriori informazioni sulla visualizzazione del database di esempio Northwind, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
276376ACC2002: Sono in cui i file di esempio Northwind?
attenzione : se la procedura in questo esempio, è possibile modificare il database di esempio Northwind.mdb. È possibile che si desidera eseguire il backup del file Northwind.mdb attenersi alla seguente procedura su una copia del database.

  1. Avviare Microsoft Access 2002.
  2. Database di esempio dal menu ? , quindi Database di esempio Northwind . Chiudere la maschera Pannello comandi principale quando viene visualizzata.
  3. Oggetti di database dal menu Visualizza , quindi query .
  4. Nel menu Inserisci , fare clic su query .
  5. Nella finestra di dialogo Nuova Query selezionare Creazione guidata query semplice e scegliere OK .
  6. Nella finestra di dialogo Creazione guidata query semplice , fare clic sulla tabella clienti nell'elenco Tabelle/query . Fare doppio clic su tutti i campi seguenti per aggiungere le casella Campi selezionati : CustomerID , CompanyName , ContactName , ContactTitle .
  7. Nella stessa pagina della creazione guidata query semplice, fare clic su questa tabella nell'elenco Tabelle/query . Fare clic su >> per aggiungere tutti i campi della tabella Ordini alla casella Campi selezionati .
  8. Fare clic su Fine . La creazione guidata query semplice crea la query e visualizza i risultati in visualizzazione Foglio dati.
back to the top

Creazione di una query di seleziona in visualizzazione struttura

  1. Avviare Microsoft Access 2002.
  2. Database di esempio dal menu ? , quindi Database di esempio Northwind . Chiudere la maschera Pannello comandi principale quando viene visualizzata.
  3. Oggetti di database dal menu Visualizza , quindi query .
  4. Nel finestra database, fare doppio clic Crea Query in visualizzazione struttura .
  5. Nella finestra di dialogo Mostra tabella fare clic su clienti e scegliere Aggiungi .
  6. Ripetere il passaggio 5 per questa tabella.
  7. Fare clic su Chiudi per chiudere la finestra di dialogo Mostra tabella .
  8. Nell'elenco clienti tabella campo nella parte superiore della finestra di Progettazione query fare doppio clic per aggiungere i seguenti campi: CustomerID , CompanyName , ContactName , ContactTitle .
  9. Nell'elenco campo tabella ordini nella parte superiore della finestra di Progettazione query, fare doppio clic sul * . Aggiunta di * equivale a selezionando tutti i campi da una determinata tabella.
  10. Nel menu file , fare clic su Salva . Digitare qryCustomerOrders il nome della query.
  11. Nel menu query , fare clic su Esegui per visualizzare i risultati della query.
back to the top

Aggiunta di criteri di query

I seguenti passaggi modificherà la query creata in "Creazione di un selezionare query in visualizzazione progettazione" più indietro in questo articolo.
  1. Avviare Microsoft Access 2002.
  2. Database di esempio dal menu ? , quindi Database di esempio Northwind . Chiudere la maschera Pannello comandi principale quando viene visualizzata.
  3. Oggetti di database dal menu Visualizza , quindi query .
  4. Fare clic sulla query qryCustomerOrders creata nella sezione precedente e quindi fare clic su struttura per aprire la query in visualizzazione struttura.
  5. Nell'elenco campo tabella ordini nella parte superiore metà della finestra di Progettazione query, fare doppio clic sul campo PaeseDestinatario per aggiungerlo alla griglia di struttura della query.
  6. Nella colonna PaeseDestinatario nella griglia di struttura della query, fare clic per deselezionare la casella di controllo Mostra . Poiché in questo campo è incluso selezionando il * da questa tabella, se si deseleziona questa casella di controllo verrà evitare di includere il campo due volte.
  7. Immettere UK nella riga criteri per il campo PaeseDestinatario .
  8. Dal menu file scegliere Salva . Digitare qryUKOrders il nome della query.
  9. Nel menu query , fare clic su Esegui per visualizzare i risultati della query. Si noti che la query restituisce gli ordini spediti nel Regno Unito.
back to the top

Come raggruppare record e creazione di somme e altri totali

La procedura seguente è illustrato come creare una query di totali per recuperare le informazioni di riepilogo relative agli ordini dal database di esempio Northwind.
  1. Avviare Microsoft Access 2002.
  2. Database di esempio dal menu ? , quindi Database di esempio Northwind . Chiudere la maschera Pannello comandi principale quando viene visualizzata.
  3. Oggetti di database dal menu Visualizza , quindi query .
  4. Nella finestra database, fare doppio clic su Crea Query in visualizzazione struttura .
  5. Nella finestra di dialogo Mostra tabella fare clic per selezionare ordini e scegliere Aggiungi .
  6. Fare clic su Chiudi per chiudere la finestra di dialogo Mostra tabella .
  7. Nell'elenco ordini tabella campo nella parte superiore della finestra di Progettazione query fare doppio clic per aggiungere i seguenti campi: PaeseDestinatario , trasporto .
  8. Nel menu Visualizza , fare clic su totali . Si noti che una riga denominata Totale viene aggiunta alla griglia di struttura della query.
  9. Fare clic nella riga cella Totale nella colonna trasporto , fare clic sulla freccia visualizzata e quindi fare clic su Somma .
  10. Nel menu file , fare clic su Salva . Digitare qryFreightByCountry il nome della query.
  11. Nel menu query , fare clic su Esegui per visualizzare i risultati della query. Si noti che la query restituisce le Totale spese di trasporto per ogni paese nella tabella Ordini.
back to the top

L'ordinamento dei record in una query

  1. Aprire la query di qryFreightByCountry è creato nella sezione "Raggruppamento record e creazione di somme e altri totali" in visualizzazione struttura.
  2. Fare clic nella riga ordinamento cella nella colonna trasporto , fare clic sulla freccia visualizzata e quindi fare clic su decrescente .
  3. Dal menu file scegliere Salva . Digitare qryFreightByCountrySorted il nome della query.
  4. Nel menu query , fare clic su Esegui per visualizzare i risultati della query. Si noti che la query restituisce le Totale spese di trasporto per ogni paese nella tabella Ordini, in ordine decrescente.
back to the top


Riferimenti
Per ulteriori informazioni sulla creazione di query, scegliere Guida in linea di Access dal menu Guida digitare creare una query di selezione nella casella dell'Assistente di Office o nella ricerca libera e scegliere il pulsante Cerca per visualizzare gli argomenti restituiti.

Queste informazioni sono inoltre disponibili nel sito Web il seguente sito Web Microsoft: Per ulteriori informazioni sulla creazione di query a campi incrociati, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
304349Procedura: Creare una query a campi incrociati in Microsoft Access 2002
Per ulteriori informazioni sulla creazione di query con parametri, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
304352Procedura: Creare una query di parametri in Microsoft Access 2002
Per ulteriori informazioni sulla conversione di una query di selezione in una query di azione, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
304354HOW TO: Conversione di una query di seleziona in una query di azione in Access
Per ulteriori informazioni sulla modifica delle proprietà delle query, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
304356Come modificare le proprietà della query in Microsoft Access
Per scaricare un database di esempio Microsoft Access che contiene più di 20 esempi di query, incluse le tecniche descritte in questi articoli, vedere il seguente articolo della Microsoft Knowledge Base riportato di seguito:
207626Il database "Access 2000 esempio: query argomenti" disponibile nell'area Download Microsoft


back to the top







OfficeKBHowTo inf

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 304325 - Ultima revisione: 12/06/2015 04:17:52 - Revisione: 4.2

Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbquery kbdownload kbhowtomaster KB304325 KbMtit
Feedback