Arresto anomalo del servizio di accesso Client RPC e 4999 evento viene registrato in Exchange Server 2013

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 3061079
Sintomi
Quando si accedono a determinati messaggi di posta elettronica utilizzando Microsoft Outlook in modalità in linea, il servizio di accesso Client RPC si blocca o viene riavviato inaspettatamente. In questo caso, vengono registrati i seguenti errori nel registro eventi.

Nota In alcuni casi, il servizio non bloccarsi anche se viene comunque registrata una voce per l'evento.

Nome di log: applicazione
Origine: MSExchangeIS comune
Data: [tempo di ricorrenza]
ID evento: 4999
Categoria di attività: generale
Livello: errore
Parole chiave: classico
Utente: n/d
Computer: [NomeComputer]
Descrizione:
Segnalazione Watson sta per essere inviata per l'id di processo: 1852, con parametri: E12IIS, c-d-s-AMD64, 15.00.1076.009, M.E.RpcClientAccess.Service, sconosciuto, M.E.D.T.I.F.F.TextStore.AddText, System. IndexOutOfRangeException, 5453, sconosciuto.
ErrorReportingEnabled: False

Di seguito viene registrato nei registri RCA che vengono salvati nel percorso seguente:

Accesso Client di C:\Program Files\Microsoft\Exchange Server\V15\Logging\RPC

2015-04-23T19:05:35.961Z,3,603,/o=<id>/ou=exchange administrative group(fydibohf23spdlt)/cn=recipients/cn=5dd9b1444df54688b0d2367fbc5e47aa-crashmbx,,OUTLOOK.EXE,15.0.4711.1000,Classic,,,,ncacn_http,Client=MSExchangeRPC,,,,fault,00:00:00.2970000,,"Watson: [IndexOutOfRangeException] Index was outside the bounds of the array. at M.E.D.TextConverters.Internal.Format.FormatStore.TextStore.AddText(TextRunType runType, Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Format.FormatStore.AddMarkupText(Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.OutputEncapsulatedMarkup() at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.Process(HtmlTokenId tokenId) at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressCommon.ReadMoreData() at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressConverter.Run() at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.BodyReadStream.<>c__DisplayClassb.<Read>b__a() at M.E.D.S.ConvertUtils.<>c__DisplayClass1`1.&lt;CallCtsWithReturnValue>b__0() at M.E.D.S.ConvertUtils.CallCts(Trace tracer, String methodName, LocalizedString exceptionString, CtsCall ctsCall) at M.E.D.S.ConvertUtils.CallCtsWithReturnValue[T](Trace tracer, String methodName, LocalizedString exceptionString, CtsCallWithReturnValue`1 ctsCall) at M.E.D.S.BodyReadStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.Util.StreamHandler.CopyStreamData(Stream readStream, Stream writeStream, Nullable`1 numBytes, Int32 t",,,.in,
Cause
Il problema è causato da un errore logico che si verifica nella classe TextConverterquando TextConverter esegue un'operazione di copia del buffer.
Workaround
Per risolvere questo problema, identificare la cassetta postale che ha causato il servizio stopby utilizzando i registri RCA. Quindi, si consiglia di disporre la cassetta postale utente changetheir Outlook impostazione dalla modalità in linea alla modalità cache.

Assicurarsi inoltre che l'utente non copiare o spostare i messaggi di posta elettronica specifico in un file pst o una cartella locale, direttamente o tramite una regola di Outlook. Per determinare il messaggio che causa il problema, copiare o spostare tutti i messaggi nel file pst uno alla volta. Il messaggio Impossibile moveis l'uno che viene il problema. Questo problemcauses una perdita del servizio di accesso Client di perdita o causestheRPC la connettività per arresto anomalo del sistema.
Status
Microsoft ha confermato che questo è un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 3061079 - Ultima revisione: 08/10/2015 17:35:00 - Revisione: 2.0

Microsoft Exchange Server 2013 Standard, Microsoft Exchange Server 2013 Enterprise

  • kbqfe kbsurveynew kbmt KB3061079 KbMtit
Feedback