Distribuzione di Windows 7 non riesce durante un aggiornamento di computer o di sostituzione

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 3084782
Sintomi
Distribuzione di Windows 7 non riesce se si sta aggiornando o sostituendo un computer. In questo caso, è che venga visualizzato il seguente messaggio di errore:

Impossibile avviare il programma perché manca dal computer DismApi.DLL. Provare a reinstallare il programma per risolvere il problema.
Cause
Questo problema si verifica a causa di mancare dipendenze del componente Loadstate.exe nel computer basato su Windows 7.
Risoluzione
Per risolvere questo problema, utilizzare uno dei metodi descritti di seguito.

Metodo 1

Quando si installa Windows Assessment and Deployment Kit (Windows ADK), selezionare la funzionalità Strumenti di distribuzione oltre il Windows migrazione stato utente dello strumento (). Quindi, eseguire Scanstate.exe da un prompt dei comandi strumenti di distribuzione.

Metodo 2

Se non è possibile installare il Windows ADK sul sistema che esegue Loadstate, installare il Windows ADK 10 in un altro sistema e assicurarsi di installare anche la funzionalità Strumenti di distribuzione. Attenersi alla seguente procedura:

  1. Individuare la cartella appropriata architettura dai seguenti percorsi del sistema che dispone di ADK installato:

    • Per x 64 computer

      C:\Program Files (x86) \Windows Kits\10\Assessment e Tools\amd64\DISM Kit\Deployment di distribuzione

      C:\Program Files (x86) \Windows Kits\10\Assessment e Tools\x86\DISM Kit\Deployment di distribuzione
    • Per x 32 computer

      C:\Programmi\Microsoft c:\Programmi\Windows Kits\10\Assessment e Tools\amd64\DISM Kit\Deployment di distribuzione

      C:\Programmi\Microsoft c:\Programmi\Windows Kits\10\Assessment e Tools\x86\DISM Kit\Deployment di distribuzione
  2. Copiare i seguenti file binari nella corrispondente cartella architettura dal passaggio 1 contenente Loadstate.exe:

    • dismapi.dll
    • API-MS-Win-downlevel-advapi32-L1-1-1.dll
    • API-MS-Win-downlevel-Kernel32-L1-1-0.dll
    • API-MS-Win-downlevel-Kernel32-L2-1-0.dll
    • API-MS-Win-downlevel-ole32-L1-1-1.dll
    • API-MS-Win-downlevel-User32-L1-1-1.dll
    • API-MS-Win-downlevel-Version-L1-1-0.dll
  3. Se si utilizza System Center Configuration Manager, aggiornare il pacchetto USMT nei punti di distribuzione che contengono il pacchetto USMT.
Ad esempio, se si desidera aggiornare il pacchetto per x64 distribuzioni, copiare i file nel passaggio 2 dalla cartella seguente:

C:\Program Files (x86) \Windows Kits\10\Assessment e Setup\amd64\Sources Kit\Windows di distribuzione
Quindi, incollare i file nella seguente cartella:
C:\Program Files (x86) \Windows Kits\10\Assessment e MigrationTool\amd64 dello stato di distribuzione Kit\User

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 3084782 - Ultima revisione: 01/11/2016 16:36:00 - Revisione: 3.0

Windows 7 Enterprise, Windows 7 Professional, Windows 7 Ultimate

  • kbexpertiseadvanced kbsurveynew kbtshoot kbmt KB3084782 KbMtit
Feedback