Errore "401 accesso negato" quando si esegue il cmdlet Test-OAuthConnectivity

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PROBLEMA
Quando si esegue il cmdlet Test-OAuthConnectivity per verificare l'autenticazione OAuth per un utente, l'operazione non riesce e viene visualizzato un messaggio analogo al seguente:
401 accesso negato
CAUSA
Questo problema può verificarsi se una delle seguenti condizioni è vera:
  • Il nome principale servizio (SPN) che ha richiesto per l'autenticazione OAuth è manca.
  • Si verifica un account che non verrà sincronizzato tra l'ambiente on-premise e Microsoft Exchange Online.
SOLUZIONE
Per risolvere questo problema, effettuare una delle seguenti operazioni, come appropriato alla situazione.

Scenario: il SPN è manca

  1. Aprire Exchange Management Shell.
  2. Eseguire il comando seguente:
    Get-IntraOrganizatioConfiguration 
    Osservare i valori restituiti perOnPremisesDiscoveryEndPoint e OnPremisesWebServiceEndPoint.
  3. Eseguire il comando seguente:
    Get-MsolServicePrincipal -ServicePrincipalName "00000002-0000-0ff1-ce00-000000000000").ServicePrincipalNames
    Controllare se vengono restituiti i nomi di dominio per gli endpoint sono elencati.
  4. Se non vengono restituiti i nomi dei domini, utilizzare il cmdletSet-MsolServicePrincipal per aggiungerli.

    Ad esempio, il comando che segue aggiunge il dominio Mail.contoso.com.
    Set-MsolServicePrincipal -ServicePrincipalName "00000002-0000-0ff1-ce00-000000000000").Mail.contoso.com

Scenario: Si sta utilizzando un account che non è sincronizzato tra l'ambiente locale e in linea di Exchange

Quando si esegue il cmdlet Test-OAuthConnectivity , assicurarsi di utilizzare un account che verrà sincronizzato tra l'ambiente locale e in linea di Exchange. Questo problema, ad esempio, si verificano se si utilizza un account di amministratore locale.

Nell'esempio seguente, "Fred" è un account utente che verrà sincronizzato tra l'ambiente locale e in linea di Exchange.
Test-OAuthConnectivity -Service EWS -TargetUri https://cas.contoso.com/ews/ -Mailbox "Fred”
ULTERIORI INFORMAZIONI
Ulteriore assistenza? Vai al Community di Office 365 sito Web o il Forum TechNet di Exchange.

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Proprietà

ID articolo: 3090197 - Ultima revisione: 08/27/2015 18:56:00 - Revisione: 2.0

Microsoft Exchange Online, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard

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