Errore InvalidShellID in RPS in Office 365 dedicato/ITAR

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Sintomi
Quando uno script viene eseguito lungo o quando si esegue un cmdlet di amministrazione in remoto PowerShell (RPS) in Microsoft Office 365 dedicato/ITAR, viene talvolta visualizzato un messaggio di errore analogo al seguente:
Elaborazione dei dati per un comando remoto non riuscita con il seguente messaggio di errore: [ClientAccessServer = Server1, BackEndServer = Server2, RequestId =<>, TimeStamp = 8/4/2014 3:42:44 PM] [FailureCategory = WS-Management-InvalidShellID] la richiesta di Windows Remote Shell con ShellId <> non riuscito perché la shell non è stata trovata sul server. Le cause possibili sono: il ShellId specificato non è corretto o la shell non esiste più sul server. Garantire il corretto ShellId o creare una nuova shell e ritentare l'operazione. Per ulteriori informazioni, vedere l'argomento della Guida about_Remote_Troubleshooting.

+ CategoryInfo: OperationStopped: [] (o mail.contoso.com:String), PSRemotingTransportException

+ FullyQualifiedErrorId: JobFailure

+ PSComputerName: mail.Contoso. com
Cause
Questo problema si verifica se sono vere le seguenti condizioni:
  • Si utilizza un account che ha associato a un utente abilitato alla posta elettronica (MEU) in un ambiente con più aree.
  • Le connessioni vengono instradate attraverso un'area diversa dall'area dell'utente.
Questo errore può verificarsi quando un server back-end viene rimosso dalla rotazione da aggiornare. Inoltre, questo problema si verifica raramente.
Risoluzione

Scenario 1: Quando uno script è in esecuzione del flusso di lavoro automatizzato lunghi o quando si

In questo scenario, potrebbe essere necessario modificare lo script per riconnettersi automaticamente se un server viene rimosso dalla rotazione mentre è in corso. È possibile farlo utilizzando l'appropriata gestione degli errori in script per intercettare eventuali errori. Quindi riconnettersi e riavviare i processi.

Scenario 2: Quando si esegue un cmdlet di amministrazione in RPS

In questo scenario, è necessario eseguire nuovamente il cmdlet. È necessario contattare un server back-end diversi e quindi il cmdlet deve essere eseguita correttamente.

Nota In una distribuzione di Exchange Online più aree, si consiglia di utilizzare account di amministrazione che sono abilitati. Ciò garantisce che le connessioni di RPS vengono effettuate tramite l'ambiente corrente. Se l'account dell'amministratore è associato a un MEU, le connessioni possono essere instradate attraverso le altre regioni. Questo comportamento potrebbe ritardare gli errori di connessione o un trigger.

Se il problema continua a verificarsi, passare da a Microsoft per ulteriori indagini. È possibile inviare una richiesta di supporto in linea per Microsoft Online Services supporto oppure è possibile contattare telefonicamente il supporto di Microsoft Online Services.

Microsoft potrebbe richiedere una traccia Fiddler ad analizzare questo problema. Se necessario, un addetto del supporto tecnico invierà un pacchetto di diagnostica supporto per acquisire e caricare le informazioni in modo sicuro. Per acquisire queste informazioni nella traccia Fiddler, youmust aggiungere un'opzione di sessione di PowerShell con il parametro ProxyAccessType impostato su IEConfig. Ad esempio:
Import-PSSession (New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://mail.contoso.com/powershell -Credential (Get-Credential) -Authentication Basic -AllowRedirection -SessionOption (New-PSSessionOption -ProxyAccessType IEConfig))
Per ulteriori informazioni su come eseguire i pacchetti di diagnostica supporto tecnico di Microsoft, vedereCome eseguire una traccia Fiddler utilizzando servizi di risoluzione automatica Microsoft.

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Proprietà

ID articolo: 3090768 - Ultima revisione: 10/13/2015 18:54:00 - Revisione: 2.0

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