Configurazione non viene aggiornata e viene registrato l'ID evento 29181 in System Center Operations Manager

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 3092452
Sintomi
In un ambiente di Microsoft System Center che dispone di molti client, le modifiche di configurazione non vengono aggiornate su un server di gestione. Inoltre, il seguente evento viene registrato ripetutamente nel Registro di Operations Manager:


Nome di log: Operations Manager
Origine: Configurazione di gestione di OpsMgr
ID evento: 29181
Livello: errore
Utente: n/d
Computer: <server></server>

Descrizione: Impossibile eseguire 'SnapshotSynchronization' elemento di lavoro di motore a causa del seguente exceptionMicrosoft.EnterpriseManagement.ManagementConfiguration.DataAccessLayer.DataAccessException servizio di configurazione di gestione di OpsMgr: scrittura di Snapshot dei dati trasferimento operazione batch non riuscito.

Cause
Questo problema si verifica quando il servizio di Gestione configurazione non riesce perché il trasferimento di istanza non può eseguire un inserimento di massa. In genere questo problema si verifica quando l'ambiente dispone di numerosi client, ad esempio 2000 o più.
Risoluzione
Per risolvere questo problema, attenersi alla seguente procedura per modificare le impostazioni di dimensione di batch per il servizio di Gestione configurazione sul server di gestione:
  1. Eseguire il backup del file Manager\Server\ConfigService.Config 2012\Operations Center di file di programma.
  2. Modificare il file ConfigService.config e modificare le impostazioni come segue:
    <Setting Name="SnapshotSyncManagedEntityBatchSize" Value="10000" /><Setting Name="SnapshotSyncRelationshipBatchSize" Value="10000" /><Setting Name="SnapshotSyncTypedManagedEntityBatchSize" Value="20000" />
  3. Riavviare il servizio di configurazione.
Informazioni
Per determinare se si sta verificando questo problema, eseguire la seguente query SQL sul database OperationsManager:
select * from cs.WorkItem where workitemname like '%snapshot%' order by StartedDateTimeUtc desc
Nello scenario descritto nella sezione "Sintomi", ilworkitemstateid è sempre 10 (operazione non riuscita) invece di 20 (riuscito).

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 3092452 - Ultima revisione: 11/01/2015 20:25:00 - Revisione: 1.0

Microsoft System Center 2012 Operations Manager Service Pack 1, Microsoft System Center 2012 R2 Operations Manager

  • kbexpertiseadvanced kbsurveytest kbtshoot kbmt KB3092452 KbMtit
Feedback