Errore "Nessuna credenziale" quando un utente federato tenterà di attivare un'applicazione di Office

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PROBLEMA
Si supponga che l'organizzazione di Microsoft Office 365 è federato e abilitata per l'autenticazione moderno. Inoltre, si presuppone che si sta utilizzando la sincronizzazione delle directory per sincronizzare locale di Active Directory per Azure (Azure ad Active Directory).

In questo ambiente, quando un utente federato tenterà di attivare un'applicazione di Microsoft Office, viene visualizzato il seguente messaggio di errore:
Nessuna credenziale
Il sistema richiede di accedere a un account valido
CAUSA
Questo problema si verifica se l'attributommutableID dell'utente. Quando la piattaforma di identità federativa invia i valori previsti, il nome principale utente (UPN) e l'attributo ImmutableID , è Impossibile verificare l'attributo ImmutableIDin Azure Active Directory poiché la proprietà è vuota. In questo modo il servizio negare l'accesso. In questo caso, il servizio è Office.
SOLUZIONE
Aggiornare l'attributo ImmutableIDdell'utente. Tuttavia, essere consapevoli che non è possibile aggiornare direttamente l'attributoImmutableID di un utente federato. Pertanto, per risolvere questo problema, utilizzare uno dei seguenti metodi:

Metodo 1: Convertire il dominio federato a un dominio gestito

  1. Installazione di Azure Active Directory Module per Windows PowerShell (se non è già installato) e quindi connettersi AD Azure.

    Per ulteriori informazioni, vedere Gestire Azure Active Directory utilizzando Windows PowerShell.
  2. Convertire il dominio in un dominio gestito. A tale scopo, eseguire il comando seguente:
    Convert-MSOLDomainToStandard –DomainName contoso.com -SkipUserConversion $false -PasswordFile c:\userpasswords.txt
    Per ulteriori informazioni, vedere Converti-MsolDomainToStandard.
  3. Aggiornare l'attributo ImmutableID dell'utente. A tale scopo, eseguire il comando seguente:
    Set-MsolUserPrincipalName -UserPrincipalName user@contoso.com -ImmutableID <ImmutableID>

Metodo 2: Convertire utente federato a un utente gestito

  1. Installazione di Azure Active Directory Module per Windows PowerShell (se non è già installato) e quindi connettersi AD Azure.

    Per ulteriori informazioni, vedere Gestire Azure Active Directory utilizzando Windows PowerShell.
  2. Convertire l'utente a un utente gestito. A tale scopo, modificare il nome principale utente in un dominio che non è federato. Ad esempio, eseguire il comando seguente:
    Set-MsolUserPrincipalName -UserPrincipalName user@contoso.com -NewUserPrincipalName user@contoso.onmicrosoft.com
  3. Aggiornamento di ImmutableID attributo dell'utente. A tale scopo, eseguire il comando seguente:
    Set-MsolUserPrincipalName -UserPrincipalName user@contoso.com -ImmutableID <ImmutableID>
  4. Impostare il dominio federato l'UPN. A tale scopo, eseguire il comando seguente:
    Set-MsolUserPrincipalName -UserPrincipalName user_temp@contoso.onmicrosoft.com -NewUserPrincipalName user@contoso.com
ULTERIORI INFORMAZIONI
Ulteriore assistenza? Vai al Community di Office 365 sito Web o il Forum di Azure Active Directory sito Web.

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Proprietà

ID articolo: 3097057 - Ultima revisione: 09/24/2015 20:28:00 - Revisione: 2.0

Microsoft Office 365, Microsoft Azure Active Directory, Office 365 Identity Management, Microsoft Office 365 ProPlus, Microsoft Office Professional Plus 2016, Microsoft Office Professional Plus 2013

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