Al momento sei offline in attesa che la connessione Internet venga ristabilita

Come risolvere i problemi di riferimento in un database di Access

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 310803
Sommario
In questo articolo vengono descritti i problemi che riguardano l'utilizzo dei riferimenti in un database di Access.

Informazioni su errori di riferimento richiede la comprensione di come le librerie fanno riferimento in un database di Access sia degli elementi necessari per installare un database nel computer di destinazione senza interrompere questi riferimenti. In questo articolo è riportato un riepilogo degli argomenti seguenti:
  • Visualizzazione riferimenti database di Access
  • La risoluzione di Microsoft Visual Basic per Applicationsreferences in Access
  • Messaggi di errore di riferimento di conoscenza
  • Risoluzione dei problemi di riferimento per la developmentcomputer
  • Distribuzione di file di database
  • Aggiornamento dell'elenco di riferimento
  • Distribuzione di file di database che dispongono di controlli ActiveX
  • Registrare di nuovo un file
Informazioni

Visualizzazione riferimenti al Database Access

Per visualizzare i riferimenti al database corrente:
  1. Aprire il database.
  2. Premere ALT + F11 per avviare l'Editor di Visual Basic.
  3. Scegliere riferimentidal menu Strumenti .

La risoluzione dei riferimenti di Visual Basic in Access

Access carica il file pertinente (ad esempio, una libreria dei tipi, una libreria di oggetti o una libreria di controlli) per ogni riferimento, secondo le informazioni visualizzate nella casella riferimenti . Se non viene trovato il file, Access esegue le procedure seguenti per individuare il file:
  1. Accesso controlla se iscurrently il file indicato caricato in memoria.
  2. Se il file non viene caricato in memoria, Access tenta di verifythat che è presente la chiave RefLibPaths . Se la chiave esiste, Access cerca un namedvalue che ha lo stesso nome come riferimento. Se viene trovata una corrispondenza, Accessloads il riferimento dal percorso che indichi il valore denominato.
  3. Access cerca quindi il file di riferimento nelle posizioni thefollowing, nel seguente ordine:
    1. Cartella dell'applicazione (il percorso del file Msaccess.exe).
    2. La cartella corrente che si vede se si sceglie Apri dal menu File .
    3. La cartella Windows o Winnt in file del sistema operativo in esecuzione.
    4. La cartella di sistema nella cartella Windows o Winnt.
    5. Le cartelle nella variabile di ambiente PATH che sono accessibili direttamente dal sistema operativo.
  4. Se non viene trovato il file, un erroroccurs di riferimento.

Informazioni sui messaggi di errore di riferimento

Esistono diversi messaggi di errore correlati a un file mancante o a un file con una versione diversa da quella utilizzata nel database. Nella maggior parte dei casi, è possibile eseguire la ricerca della Microsoft Knowledge Base per un articolo sul messaggio di errore specifico e quindi per risolvere l'errore, la procedura descritta nell'articolo. In alcuni casi, un file di dipendenza non associato correttamente il file primario.

Nell'elenco seguente vengono descritti alcuni dei messaggi di errore di riferimento che potrebbe essere visualizzato. Si noti tuttavia che l'elenco non include tutti i messaggi di errore di riferimento possibili.
  • Metodo" NomeMetodo dell'oggettoNomeOggetto Non riuscita"

    In genere, si mayreceive questo messaggio di errore se si è verificato un problema con una libreria dei tipi programmazione, ad esempio, un file di collegamento dinamico library(DLL) di oggetti DAO (Data Access) non valido. È possibile cercare nella Microsoft Knowledge Base thatdescribe articoli le varie forme di questo messaggio di errore.
  • "Funzione non è disponibile inUtilizzo espressione"

    Messaggio di thiserror se si è verificato un problema con una libreria dei tipi di programmazione, o se visualizzare la chiamata in modo specifico alla libreria corretta e il file listedat una priorità più bassa nell'elenco di riferimento rispetto a un file che contiene il nome di samefunction, ad esempio, se il codice DAO viene utilizzato con la libreria Object(ADO) dati ActiveX indicato una priorità maggiore rispetto alla libreria di DAO. È possibile che alsoreceive questo messaggio di errore se una maschera o un report contiene un controllo ActiveX.
  • "Impossibile trovare il progetto o libreria"

    Se non è possibile individuare un file nell'elenco di riferimento, è possibile messaggio di errore receivethis. Oftenthe file è contrassegnato come mancante nella finestra di dialogo riferimenti . In alcuni casi il file esiste nel computerbut di sviluppo non nel computer di destinazione. Per ulteriori informazioni su questo errore, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
    208218 ACC2000: Funzioni VBA si interrompono in Database con riferimenti mancanti
  • "Variabile non definita" o "tipo definito dall'utente non definita"

    Venga visualizzato uno dei seguenti messaggi di errore se si utilizza theUser impostazione guidata protezione per proteggere un database che fa riferimento a librerie otherthan le librerie incluse per impostazione predefinita. Ad esempio, tolibraries di riferimenti presenti nel database non protetto non sono automaticamente createdin il nuovo database protetto.
  • "Errore di run-time 5," "chiamata di routine non valido o argomento", "che contiene questo simbolo non è fa riferimento alla libreria currentproject" o "la libreria che contiene questo simbolo non fa riferimento il progetto thecurrent, pertanto non è definito il simbolo"

    Potrebbe essere visualizzato uno messaggi di errore di ofthese se è presente un riferimento a un database, una libreria dei tipi, la libreria di oggetti oran contrassegnato come mancante. Per ulteriori informazioni, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
    231413 ACC2000: Messaggi di errore che indicano un riferimento mancante
  • "Il componente ActiveX non può creare l'oggetto"

    Thiserror messaggio non significa necessariamente che interessa un controllo ActiveX. Ad esempio, una causa possibile è che DAO, che è un componente ActiveX, è possibile creare un oggetto perché Impossibile avviare il Server di automazione DAO. Spesso la causa è che le DLL che forniscono funzionalità di cui si fa riferimento per il programma non sono registrate o non sono registrate correttamente.Per ulteriori informazioni su questo errore, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
    244264 INFORMAZIONI: Risoluzione dei problemi errore 429 quando l'automazione delle applicazioni di Office
    In questo articolo, sebbene dal punto di vista Visual Basic, vengono illustrate molte delle cause di questo errore.

Risoluzione dei problemi di riferimento nel Computer di sviluppo

La creazione di un nuovo database vuoto e quindi importare oggetti da un altro file di database può creare problemi di riferimento se il codice o controlli ActiveX si basano sui riferimenti che non sono inclusi in un database per impostazione predefinita. I riferimenti di default per un database di Access 2000 sono:
  • Visual Basic, Applications Edition
  • Libreria oggetti di Microsoft Access 9.0
  • Automazione OLE
  • Libreria Microsoft ActiveX Data Objects (ADO) 2.1
Se l'origine è un altro database di Access 2000, verificare che i riferimenti corrispondano. Se l'origine è una versione precedente di Access, DAO 3.5 o precedente è probabilmente in uso; Access 2000 non fornisce tuttavia DAO 3.5 per impostazione predefinita. Provare a rimuovere il riferimento ADO 2.1 library (se presente) e aggiungendo il riferimento alla libreria di oggetti DAO 3.6.

Se il database è stato convertito da una versione precedente di Access e il database contiene un riferimento al file Utility. mda, nella maggior parte dei casi è possibile rimuovere questo riferimento perché le funzioni che chiama questo riferimento sono inclusi nei riferimenti predefinita in Access 2000. Se sono presenti riferimenti a versioni precedenti di DAO, è anche possibile rimuovere questi riferimenti poiché DAO 3.6 può risolvere queste funzioni.

Per aggiungere un riferimento a una libreria:
  1. Aprire il database.
  2. Premere ALT + F11 per avviare l'Editor di Visual Basic.
  3. Scegliere riferimentidal menu Strumenti .
  4. Nella casella Riferimenti disponibili, fare clic per selezionare la casella di controllo accanto al nome della libreria e quindi fare clic su OK.
Per rimuovere un riferimento a una libreria:
  1. Aprire il database.
  2. Premere ALT + F11 per avviare l'Editor di Visual Basic.
  3. Scegliere riferimentidal menu Strumenti .
  4. Nella casella Riferimenti disponibili, fare clic per deselezionare la casella di controllo accanto al nome della libreria e quindi fare clic su OK.

Distribuzione di file di Database

Esistono due metodi di distribuzione di file di database di base. È possibile copiare il file dal computer di sviluppo al computer di destinazione oppure è possibile utilizzare il Package e distribuzione guidata per creare un pacchetto di installazione.

Se si copia il file dal computer di sviluppo al computer di destinazione, viene copiato solo il file di database. È necessario verificare manualmente che tutti i file elencati nell'elenco Riferimenti disponibili, il livello di versione corretto e nella stessa posizione relativa nel computer di destinazione come computer di sviluppo.

Se si utilizza il Package e distribuzione guidata per creare un pacchetto di installazione, consultare l'articolo della Knowledge Base che serve come un elenco di controllo per lo sviluppo di applicazioni in fase di esecuzione in Access. Per ulteriori informazioni sull'elenco di controllo, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
247530 MOD2000: Come evitare errori comuni quando si creano applicazioni distribuibili di Run-Time
Quando si sviluppano applicazioni in fase di esecuzione in Access, si tenga presente che alcuni file del sistema operativo devono essere distribuiti con l'applicazione run-time. L'imballaggio di questi file viene eseguita automaticamente dal componente Package e distribuzione guidata di Microsoft Office 2000 Developer. In alcuni casi le versioni dei file inclusi dipendono da altre applicazioni installate nel computer di sviluppo e che potrebbe avere modificato i file del sistema operativo.

Seguire determinate linee guida verrà in genere assicurarsi che le versioni dei file in uso non sono in conflitto con i file nel computer di destinazione quando si installa l'applicazione run-time. Di seguito vengono fornite le istruzioni:
  1. Sviluppo di database di Access su qualsiasi computer.
  2. Creare un ambiente di computer in cui il disco rigido ha beenreformatted e dove è installata la versione meno recente di operatingsystem applicabile, di Office e di Office 2000 Developer. Eseguire la distribuzione guidata Packageand su questo computer per creare la versione in fase di esecuzione del processo. Ciò garantisce che i livelli di revisione dei file funzionerà su qualsiasi computer di destinazione.
  3. Creare un ambiente di computer in cui il disco rigido ha beenreformatted e in cui è installato solo il sistema operativo. In questo ambiente di test di timeapplication di esecuzione.
    • Se l'applicazione non viene eseguito correttamente, è noto che vi sia un problema con l'applicazione stessa. È necessario identificare e risolvere il problema prima di distribuire l'applicazione.
    • Se l'applicazione funziona correttamente nel computer di prova, ma nel computer di destinazione, è noto che vi sia un valore errato nel computer di destinazione e non nell'applicazione. È necessario identificare e correggere la causa probabile nel computer di destinazione, probabilmente un problema di incompatibilità o un file danneggiato.

Aggiornamento dell'elenco di riferimento

Se il problema di riferimento interessa un controllo ActiveX, è talvolta possibile risolvere il problema aggiornando l'elenco di riferimento. Per aggiornare l'elenco di riferimento:
  1. In Visual Basic Editor, scegliere riferimenti dal menu Strumenti .
  2. Nella finestra di dialogo riferimenti , fare clic per selezionare un riferimento non alreadyselected, prendere nota di cui uno selezionare e quindi fare clic su OK.
  3. Dal menu Strumenti , fare clic su riferimenti .
  4. Fare clic per annullare la selezione di riferimento e quindi fai clic su OK.

Distribuzione di file di Database che dispongono di controlli ActiveX

Esistono due tipi di licenze per i controlli ActiveX: una licenza design-time e una licenza in fase di esecuzione.
  • Una licenza design-time consente di inserire controlli licensedActiveX da Office 2000 Developer in maschere e report in un Accessdatabase.
  • Una licenza runtime consente di utilizzare il controlsin ActiveX un database di Access in un computer che non dispone di Office 2000 Developerinstalled, ma non consente di inserire nuovi controlli licensedActiveX una licenza in fase di esecuzione. Per installare una licenza in fase di esecuzione, distribuire i controlli ActiveX utilizzando il Package e distribuzione guidata, che scrive il licensefor i controlli nel Registro di sistema del computer di destinazione.
Un flag mancante , che venga visualizzato quando si apre un modulo in visualizzazione struttura e quindi scegliere riferimenti dal menu Strumenti , indica che il riferimento al controllo della finestra di dialogo comune nel computer di destinazione non corrisponde all'origine nel file di database dal computer di sviluppo.

Se si distribuisce un file di database senza installare il controllo finestra di dialogo comune distribuibile, il riferimento del controllo può essere contrassegnato come mancanteo venga visualizzato un messaggio di errore che "si dispone della licenza necessaria per utilizzare questo controllo ActiveX" se il controllo non è distribuibile è già installato nel computer di destinazione.

Anche quando il file di database è parte di un'applicazione in fase di esecuzione, venga visualizzato il messaggio di errore che "si dispone della licenza necessaria per utilizzare questo controllo ActiveX" se il controllo non è distribuibile che è già installato nel computer di destinazione di una versione più recente rispetto al controllo fornito da un'applicazione run-time. Questo problema può verificarsi perché il programma di installazione non sovrascrive le versioni successive di un file con una versione precedente dello stesso file.

Registrare di nuovo un File

È possibile che un file sia nell'elenco di riferimento senza essere correttamente registrato nel Registro di sistema. Se si ritiene che questo potrebbe essere il caso, attenersi alla seguente procedura per registrare nuovamente il file:
  1. In Microsoft Windows NT 4.0, fare clic su Start, scegliere Trovae quindi fare clic su file o cartelle, o in Windows 2000, fare clic su Start, scegliere Cercae quindi fare clic su andFolders per i file.
  2. Digitare nella casella nome , o nella casella di ricerca per file e foldersnamedregsvr32.exe.
  3. Nella casella Cerca in , selezionare la cartella principale del disco thehard (generalmente c).
  4. Fare clic per selezionare la casella di controllo Includi sottocartelle se non è già selezionata e quindi fare clic su Trova o Cerca ora.
  5. Dopo aver individuato il file, fare clic su Start, scegliere Eseguie quindi eliminare tutti gli elementi nella casella Apri .
  6. Trascinare il file Regsvr32.exe dal riquadro dei risultati della ricerca nella casella Apri .
  7. Ripetere i passaggi da 2 a 6, la ricerca diNome del fileDLL, doveNome del file è il nome del file che si desidera toreregister.
  8. Dopo il Nome del fileDLL file isin la Apri con il file Regsvr32.exe, fare clic su OK.
  9. In Access, eseguire un test per vedere se il problema stillexists.
Se non è il file Regsvr32.exe nel computer, controllare altri computer per il file. Se il file non è disponibile, è possibile ottenere il file dal sito Web Microsoft. Per ulteriori informazioni, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
161983 ACC: Regsvr32a.exe disponibili per il download
Nota: Ricordarsi di compilare tutti i moduli, dopo aver modificato i riferimenti. Per compilare tutti i moduli, con il modulo aperto e scegliere Compila database dal menu Debug . Se non si compila i moduli, è possibile che ulteriori riferimenti non risolti.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 310803 - Ultima revisione: 10/01/2015 02:35:00 - Revisione: 4.0

Microsoft Access 2000 Standard Edition, Microsoft Access 2002 Standard Edition, Microsoft Office Access 2003, Microsoft Office Access 2007, Microsoft Access 2010, Microsoft Access 2013, Access 2016

  • kbhowto kbenv kbinfo kbinterop kbprogramming kbmt KB310803 KbMtit
Feedback
0&did=1&t=">