Gli utenti locali non possono visualizzare informazioni sulla disponibilità degli utenti di Exchange Online

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 3137325
PROBLEMA
Gli utenti che dispongono di una cassetta postale nell'ambiente locale non possono visualizzare informazioni sulla disponibilità per le cassette postali in Exchange Online nello scenario seguente:
  • Si dispone di una distribuzione di ibridi di Exchange Online e di Exchange Server on-premise 2016 o Exchange Server 2013.
  • Installazione di un connettore intraorganization tra l'organizzazione Exchange Online e l'organizzazione di Exchange locale.
  • Installazione di una relazione di organizzazione tra l'organizzazione Exchange Online e l'organizzazione di Exchange locale.
CAUSA
Questo problema si verifica se i locale di Exchange server non è in grado di ottenere un token di autenticazione tramite OAuth. Exchange non tenta di utilizzare la relazione di organizzazione, se esiste un connettore intraorganization.
SOLUZIONE
Per risolvere questo problema, attenersi alla seguente procedura.

Passaggio 1: Verificare il certificato OAuth

  1. Aprire Exchange Management Shell.
  2. Identificare il certificato per il quale è alla ricerca della configurazione di autenticazione. A tale scopo, eseguire il comando seguente:
    Get-AuthConfig |fl
  3. Se viene restituito alcun valore nell'output per CurrentCertificateThumbprint, creare un nuovo certificato. A tale scopo, eseguire il comando seguente:
    New-ExchangeCertificate -KeySize 2048 -SubjectName "cn= Microsoft Exchange ACS Certificate" -FriendlyName "Microsoft Exchange Server ACS Certificate" -PrivateKeyExportable $true -Services SMTP -DomainName <YourPrimarySmtpDomain>
  4. Assegnare il nuovo certificato per l'autenticazione OAuth. A tale scopo, eseguire i seguenti comandi:
    Set-AuthConfig -NewCertificateThumbprint <ThumbprintFromStep3> -NewCertificateEffectiveDate (Get-Date)
    Set-AuthConfig -PublishCertificate

Passaggio 2: Specificare l'account utente per l'applicazione del partner

  1. Aprire Exchange Management Shell.
  2. Identificare l'account utente collegato per l'applicazione del partner. A tale scopo, eseguire il comando seguente:
    Get-PartnerApplication |fl
  3. Se non viene restituito alcun conto nell'output, aggiungere l'account utente appropriato. A tale scopo, eseguire il comando seguente:
    Set-PartnerApplication "Exchange Online" -LinkedAccount "contoso.com/Users/Exchange Online-ApplicationAccount"
ULTERIORI INFORMAZIONI
Per ulteriori informazioni sui cmdlet utilizzati in questo articolo, vedere le seguenti risorse di Microsoft TechNet:

Proprietà

ID articolo: 3137325 - Ultima revisione: 03/10/2016 23:08:00 - Revisione: 2.0

Exchange Server 2016 Enterprise Edition, Exchange Server 2016 Standard Edition, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard, Microsoft Exchange Online

  • o365022013 o365 o365a o365e o365m hybrid kbmt KB3137325 KbMtit
Feedback