Skype per Business StatsMan Perf agente (PerfAgent.exe) si blocca a causa di un URI di Listener non corretto

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 3147840
Sintomi
L'agente di gestione di statistiche di prestazioni (PerfAgent.exe) per Skype per gli arresti anomali di Business e i seguenti ID evento vengono registrati nel registro eventi:

Event ID 1000 / Source: Application ErrorFaulting application name: PerfAgent.exe, version: 1.0.0.0, time stamp: 0x56258ce0Faulting module name: KERNELBASE.dll, version: 6.3.9600.18202, time stamp: 0x569e7eb1Exception code: 0xe0434352Fault offset: 0x0000000000008a5cFaulting process id: 0x34d0Faulting application start time: 0x01d174c569326a54Faulting application path: C:\Program Files\Skype for Business Server StatsMan Agent\PerfAgent.exeFaulting module path: C:\Windows\system32\KERNELBASE.dllReport Id: a82a4b96-e0b8-11e5-80ef-001dd8b722d0Faulting package full name: Faulting package-relative application ID:Event ID 1026 / Source: .NET RuntimeApplication: PerfAgent.exeFramework Version: v4.0.30319Description: The process was terminated due to an unhandled exception.Exception Info: System.InvalidOperationException  at Microsoft.PerfAgent.Client.PerfAgentClient.Initialize()  at PerfAgent.LyncPerfAgent.InitalizeClient()  at PerfAgent.LyncPerfAgent.InitializeAndStart()  at PerfAgent.LyncPerfAgent.Run(System.String, Microsoft.Lync.Management.OptionCollection, Boolean)  at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)  at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)  at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)  at System.Threading.ThreadHelper.ThreadStart()
Cause
Questo problema si verifica perché durante l'installazione di Skype per Business Manager di statistiche delle prestazioni agente è stato specificato un URI di Listener non corretto.
Risoluzione
Per risolvere il problema, attenersi alla seguente procedura:

  1. Aprire C:\Program Files\Skype per la cartella Business Server StatsMan agente, quindi individuare e aprire il file seguente:

    PerfAgent.exe.config
  2. Nel file, individuare l'impostazione di ListenerURI.
  3. Tra il <value>tag, esaminare l'URL del servizio di Listener per assicurarsi che sia corretto.</value>

    Nota È necessario utilizzare il nome completo FQDN del servizio StatsMan e non Localhost.
  4. Ripetere questa procedura su tutti i computer che hanno installato PerfAgent.exe. Di Skype per Business StatsMan PerfAgent servizio verrà riavviato automaticamente.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 3147840 - Ultima revisione: 03/22/2016 01:56:00 - Revisione: 1.0

Skype for Business

  • kbsurveynew kbmt KB3147840 KbMtit
Feedback