Il debug non viene inizializzato in alcune periferiche con PC Card 1394

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Questo articolo è stato precedentemente pubblicato con il codice di riferimento I315399
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Quando si tenta di eseguire il debug utilizzando una PC Card 1394, è possibile che in alcuni casi il debug non venga avviato.
Cause
Questo problema si verifica perché l'HAL (Hardware Abstraction Layer, Livello di astrazione hardware) potrebbe non attendere sufficientemente a lungo per consentire l'inizializzazione della scheda CardBus. Oppure in altri casi, è possibile che l'HAL non attenda sufficientemente a lungo per consentire l'inizializzazione della scheda dopo che questa è stata alimentata. Quando ciò si verifica, Windows non viene avviato in modalità debug, nemmeno se vengono utilizzati i parametri corretti del file Boot.ini e viene caricato il file Kd1394.dll.

È possibile verificare se la modalità debug è in uso creando un programma che contiene il seguente codice di esempio:
void main(void)  {     _asm {  int 3 }     return 0;}
Se la modalità debug è in uso, eseguendo questo codice, il programma si bloccherà durante il debug. Se la modalità debug non è in uso, verrà visualizzato un messaggio di errore Dr. Watson.
Risoluzione
Per risolvere il problema, procurarsi l'ultimo Service Pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 How to Obtain the Latest Windows XP Service Pack
La versione in lingua inglese di questa correzione deve avere i seguenti attributi di file (o successivi):
   Data       Ora    Versione     Dimensione  Nome file   -------------------------------------------------------   27-Gen-02  17:56  5.1.2600.28  101.376     Hal.dll   27-Gen-02  17:56  5.1.2600.28  128.000     Halaacpi.dll   27-Gen-02  17:56  5.1.2600.28   77.440     Halacpi.dll   27-Gen-02  17:56  5.1.2600.28  146.432     Halapic.dll   27-Gen-02  17:56  5.1.2600.28  130.048     Halmacpi.dll   27-Gen-02  17:56  5.1.2600.28  148.352     Halmps.dll   27-Gen-02  17:56  5.1.2600.28   75.136     Halsp.dll

Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo. Questo problema è stato corretto per la prima volta nel Service Pack 1 per Windows XP.
pcmcia
Proprietà

ID articolo: 315399 - Ultima revisione: 01/11/2015 21:21:21 - Revisione: 3.1

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional Edition

  • kbnosurvey kbarchive kbqfe kbhotfixserver kbbug kbfix kboswin2000fix kbwinxppresp1fix kbwinxpsp1fix KB315399
Feedback