Al momento sei offline in attesa che la connessione Internet venga ristabilita

Il tuo browser non è supportato

Devi aggiornare il browser per usare il sito.

Esegui l'aggiornamento all'ultima versione di Internet Explorer

Come utilizzare l'aggiornamento guidato Visual Basic

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 317885
Sommario
In questo articolo viene descritto come creare un semplice Applicazione Visual Basic 6.0 e quindi l'aggiornamento dell'applicazione Visual Basic .NET o Visual Basic 2005 tramite l'aggiornamento guidato Visual Basic in Visual Studio .net o in Visual Studio 2005.

Nota L'aggiornamento guidato Visual Basic .net è incluso in Visual Studio .net Professional.

Nota L'aggiornamento guidato 2005 Visual Basic è stato migliorato rispetto alle versioni precedenti di Visual Basic. back to the top

Requisiti

Di seguito sono indicati l'hardware consigliato, software, infrastruttura di rete, competenze, conoscenze e i service pack è necessario:
  • Microsoft Windows 2000 Professional (o Server), o Microsoft Windows XP Professional (o Server) con il.NET Framework installato
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 o versione successiva con Northwind database, le autorizzazioni appropriate e i valori di ID utente e Password
Conoscenza necessaria:
  • Conoscenza generale di come creare applicazioni utilizzando Visual Basic 6.0
back to the top

Utilizzare l'aggiornamento guidato Visual Basic

La seguente procedura mostra come creare un semplice Visual Basic applicazione 6.0 e quindi l'aggiornamento dell'applicazione .net Visual Basic o Visual Basic 2005 utilizzando Visual Basic aggiornamento guidato di Visual Studio .net o di Visual Studio 2005:
  1. Nel menu Start , scegliere programmiMicrosoft Visual Studio 6.0e quindi fare clic su Microsoft 6.0 Visual Basic.
  2. Nella finestra di dialogo Nuovo progetto , fare clic su EXE Standarde quindi fare clic su Apri.
  3. Il primo modulo in questa applicazione utilizza ADO per recuperare un Recordset e visualizza l'oggetto recordset in un controllo Microsoft Hierarchical FlexGrid Controllo. Nel campo nome della finestra di dialogo proprietà di Form1, digitarefrmADO.
  4. Se la casella degli strumenti non è aperto, scegliere casella degli strumentidal menu Visualizza .
  5. Dalla casella degli strumenti, posizionare un MSHFlexGrid sul form in modo che occupi gran parte del modulo. Lasciare spazio sufficiente nella parte inferiore della maschera per inserire un pulsante.

    Nota: se non vedete l'icona MSHFlexGrid nella casella degli strumenti, è necessario aggiungerlo alla casella degli strumenti. Pulsante destro del mouse il Casella degli strumenti, quindi fare clic su componenti. Nella finestra di dialogo componenti selezionare Microsoft Hierarchical FlexGrid controllo 6.0 (OLEDB) dall'elenco dei componenti disponibili e quindi fare clic su OK.
  6. Dalla casella degli strumenti, posizionare un controllo CommandButton nel form sotto il MSHFlexGrid. Nel campo didascalia della finestra di dialogo proprietà , digitare OK.
  7. Il pulsante destro del mADOe quindi scegliere Visualizza codice. Aggiungere il codice seguente, che crea una connessione di database e Restituisce un recordset che contiene tutti i dati della tabella Products del database Northwind.

    Nota: nell'esempio di codice riportato di seguito, è necessario modificare id utente =<username></username> e password =<strong password=""></strong> per i valori corretti. Assicurarsi che l'ID utente dispone delle autorizzazioni appropriate per eseguire questa operazione sul database.
    Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub					
  8. Premere CTRL + S per salvare il modulo. Dal menu File scegliere Salva con nome. Nella finestra di dialogo Salva con nome , fare clic su Salva.
  9. In Esplora progetti destro Progetto1, fare clic su Aggiungie quindi fare clic su modulo. Fare clic su Apri.
  10. Nel campo nome della finestra di dialogo proprietà , digitare frmClipboard.
  11. Dalla casella degli strumenti, posizionare un controllo Textbox sul form. Nel campo di testo , digitare La rapida pelide Achille l'ira cane.
  12. Inserire un controllo CommandButton di sotto della casella di testo. Nel campo didascalia della finestra di dialogo proprietà , digitare Copia.
  13. Inserire un secondo controllo CommandButton nel form. Nel campo didascalia della finestra di dialogo proprietà , digitare Incolla.
  14. Il pulsante destro del frmClipboarde quindi scegliere Visualizza codice. Incolla il seguente codice per il controllo CommandButton eventi click. Questo codice viene utilizzato negli Appunti l'oggetto GET e Incolla il testo:
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd Sub					
  15. Premere CTRL + S per salvare il modulo.
  16. L'ultimo modulo che è necessario è il form principale dell'applicazione. In Esplora progetti destro Progetto1, scegliere Aggiungi, fare clic su moduloe quindi fare clic su Apri.
  17. Nel campo nome della finestra di dialogo proprietà , digitare frmMain.
  18. Dalla casella degli strumenti, inserire un controllo CommandButton nel form frmMain. Nel campo didascalia della finestra di dialogo proprietà , digitare ADO.
  19. Inserire un secondo controllo CommandButton nel form. Nel campo didascalia della finestra di dialogo proprietà , digitare Appunti.
  20. Destro frmMaine quindi scegliere Visualizza codice. Incolla il seguente codice per il controllo CommandButton, eventi, fare clic per Mostra le due forme:
    Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub					
  21. Premere CTRL + S per salvare il modulo.
  22. In Esplora soluzioni, destro Progetto1e quindi scegliere Proprietà Progetto1. Nel campo Oggetto di avvio , fare clic su frmMaine quindi fare clic su OK.
  23. Per aggiungere un riferimento al componente di ADO, dal menu progetto , fare clic su riferimenti. Nell'elenco dei riferimenti disponibili, fare clic per selezionare Libreria di oggetti dati Microsoft ActiveX (esegue qualsiasi versione 2.0 o versione successiva). Fare clic su OK.
  24. Per compilare il progetto dal menu File , fare clic su Progetto1 apportare. Fare clic su OK nella finestra di dialogo Crea progetto (accettare il nome file predefinito).
  25. Premere F5 per eseguire l'applicazione in modalità debug.

    Nota: non è necessario verificare che il precedente Visual Basic applicazione viene eseguita senza problemi prima dell'aggiornamento.
  26. Chiudere l'ambiente di sviluppo Visual Basic. Al Chiedi conferma prima di salvare le modifiche apportate al progetto, fare clic su . Utilizzare il nome predefinito e salvare il progetto.
  27. Nel menu Start , scegliere programmiMicrosoft Visual Studio.NETe quindi fare clic su Microsoft Visual Studio.NET.
  28. Nella pagina iniziale, fare clic su Apri progetto. Individuare la cartella che contiene il progetto 6.0 Visual Basic file che avete appena creato (generalmente C:\Program Files\Microsoft Visual Studio\VB98). Fare clic su Project1.vdpe quindi fare clic su Apri.
  29. Visual Studio .net rileva che si tratta di un elemento visivo legacy Progetto di base e viene avviato l'aggiornamento guidato Visual Basic. La procedura guidata visualizza una Descrizione di ogni passaggio come si procede attraverso la procedura di seguito sequenza:
    • Creare un nuovo progetto di in cui il progetto esistente viene aggiornato.
    • Copiare i file di modulo e classe nella nuova progetto.
    • Fornire un rapporto di aggiornamento che elenca i componenti di il progetto aggiornato correttamente e i componenti che non esegue l'aggiornamento completata.

  30. Fare clic su Avanti attraverso i passaggi fino a quando non inizia il processo di aggiornamento. Il aggiornamento richiederà circa 30-60 secondi per il completamento.
  31. In Esplora soluzioni, fare doppio clic su UpgradeReport. htm. Questo report vengono visualizzati i risultati dell'aggiornamento. Si noti che tutti i i moduli, ad eccezione di frmClipboard aggiornato senza problemi.
  32. Espandere frmClipboard.vb per visualizzare i problemi. Clipboard.SetText e GetText non sono stati aggiornati correttamente. Fare clic sui collegamenti nella Descrizione per visualizzare la procedura correggere i problemi.
  33. In Esplora soluzioni, si noti che tutti i moduli conservati i nomi originali, ma l'estensione del file viene modificato da frm a . vb.
  34. Espandere i riferimenti. Si noti che i riferimenti a tutti i componenti necessari Per utilizzare i componenti legacy Visual Basic e ADO sono stati aggiunti automaticamente.
  35. Pulsante destro del mouse una delle forme e quindi scegliere Visualizza codice. Espandere l'area di Supporto per l'aggiornamento . Questa area Visualizza come configurata Visual Studio .net o Visual Studio 2005 diverse proprietà e variabili per supportare il codice aggiornato.
  36. In Esplora soluzioni, fare frmClipboard.vbe quindi scegliere Visualizza codice. Si noti che esistono commenti inseriti prima le righe che non aveva non eseguire l'aggiornamento.
  37. Modificare gli eventi Command1_Click e Command2_Click come segue:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click        Clipboard.SetDataObject(Text1.Text)    End Sub    Private Sub Command2_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command2.Click        Text1.SelectedText = _            Clipboard.GetDataObject().GetData(GetType(System.String))    End Sub					
back to the top

Esempi di codice completo

Elenco completo del codice (frmADO.frm)

Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub				
back to the top

Elenco completo del codice (frmClipboard.frm)

Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd SubComplete Code Listing (frmMain.frm)Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub				
back to the top

Verificare che l'applicazione funzioni

  1. Premere F5 per avviare l'applicazione.
  2. Alla richiesta di salvare il progetto, fare clic su OK.
  3. In Form1, fare clic su ADO. Viene visualizzato un modulo che contiene i dati in una griglia. Chiudere questa modulo.
  4. In Form1, fare clic su Appunti.
  5. Fare clic su Copia.
  6. Posizionare il cursore nella casella di testo all'inizio il testo, quindi scegliere Incolla. Verrà visualizzato il testo incollato.
back to the top

Risoluzione dei problemi

Visual Basic .net è un cambiamento importante rispetto alle versioni precedenti di Visual Basic. Per molti progetti, è consigliabile un lavoro di preparazione approfondita prima dell'aggiornamento. Consultare il documento seguente per le informazioni che possono consentono di eseguire più facilmente l'aggiornamento:
back to the top

RIFERIMENTI

Per ulteriori informazioni, consultare il seguente Microsoft Developer Articoli Network (MSDN): back to the top

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 317885 - Ultima revisione: 07/02/2012 05:27:00 - Revisione: 1.0

  • Microsoft Visual Basic 2005
  • Microsoft Visual Basic .NET 2003 Standard Edition
  • Microsoft Visual Basic .NET 2002 Standard Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft .NET Framework 1.1
  • kbvs2005swept kbvs2005applies kbmigration kbhowtomaster kbmt KB317885 KbMtit
Feedback
//c1.microsoft.com/c.gif?DI=4050&did=1&t=">.appendChild(m);" src="http://c1.microsoft.com/c.gif?"> >>ow.location.protocol) + "//c.microsoft.com/ms.js'><\/script>");