Al momento sei offline in attesa che la connessione Internet venga ristabilita

Visualizzazione di un messaggio di errore "Accesso negato" quando si eliminano cartelle da un'unità montata

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l Ulteriori informazioni su come continuare a essere protetti.

Sintomi
Quando si tenta di eliminare delle cartelle memorizzate su un'unità montata e di inviarle al Cestino, è possibile che venga visualizzato il seguente messaggio di errore:
Impossibile eliminare nome cartella: accesso negato. Il file d'origine potrebbe essere in uso.
Cause
Questo comportamento si verifica in quanto il Cestino non riconosce i volumi montati. Si supponga ad esempio di disporre del seguente layout di unità:
Unità C della dimensione di 1 gigabyte (1 GB) che utilizza il file system NTFS.
C:\Host-dir è il punto di montaggio per un'altra unità da 9 GB.
Quando si tenta di eliminare una cartella con percorso C:\Host-dir\Mydir, questa viene interpretata come appartenente all'unità C da parte di Esplora risorse di Windows, che tenta inutilmente di inserirla nel Cestino sull'unità C.
Risoluzione
Per evitare il problema, utilizzare uno dei metodi descritti di seguito:
  • Quando si eliminano file o cartelle in Esplora risorse utilizzare la combinazione di tasti MAIUSC+CANC, che evita il trasferimento al Cestino.
  • Aprire la finestra del prompt dei comandi e utilizzare il comando rd /s /q per eliminare file o cartelle.
NOTA: entrambi i metodi consentono di eliminare i dati in maniera permanente. Questo significa che non sarà più possibile ripristinarli a meno di non disporre di una copia di backup aggiornata.
Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo.
Proprietà

ID articolo: 319368 - Ultima revisione: 10/22/2003 16:37:00 - Revisione: 1.0

  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • kberrmsg kbui kbprb KB319368
Feedback