Non viene stabilita una connessione di DirectPlay e non vengono visualizzati messaggi di errore

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Se un peer (in modalità peer-to-peer) effettua una chiamata IDirectPlay8Peer::Connect o se un client (in modalità client/server) effettua una chiamata IDirectPlay8Client::Connect per la connessione con una sessione di DirectPlay8, la sessione non viene stabilita e non viene visualizzato alcun messaggio di errore.
Cause
Nel caso di un peer, la connessione viene stabilita con il lettore host per la sessione peer-to-peer. Nel caso di un client, la connessione viene stabilita con il lettore server per la sessione client/server. Il processo di connessione comporta un collegamento tra il peer (il client) e l'host (il server), seguito dalla sincronizzazione in più fasi attraverso il collegamento per convalidare l'ingresso del nuovo lettore nella sessione. Se la connessione al lettore host o server viene persa mentre il processo di connessione è ancora in corso, la connessione non viene stabilita, generando il seguente comportamento:
  • Se la chiamata a IDirectPlay8Peer::Connect o IDirectPlay8Client::Connect viene effettuata in modo sincrono, viene restituito un errore.
  • Se la chiamata a IDirectPlay8Peer::Connect o IDirectPlay8Client::Connect viene effettuata in modo asincrono, viene inviata una notifica DPN_MSGID_CONNECT_COMPLETE con un errore al sistema di gestione dei messaggi del programma.
  • Per le notifiche DPN_MSGID_CREATE_PLAYER generate prima dell'interruzione della connessione dovrà essere effettuata un'operazione di unwind tramite notifiche DPN_MSGID_DESTROY_PLAYER corrispondenti.
In alcuni casi, questo comportamento non viene applicato da Microsoft DirectX 8.1 e dalle versioni di DirectPlay 8.0 del client Windows XP (non è possibile installare DirectX 8.1 in un client Windows XP). Al contrario, la connessione al lettore host (o server) viene persa senza notifiche, presentando il seguente comportamento:
  • Se la chiamata a IDirectPlay8Peer::Connect o IDirectPlay8Client::Connect viene effettuata in modo sincrono, il risultato restituito è corretto (DPN_OK).
  • Se la chiamata a IDirectPlay8Peer::Connect o IDirectPlay8Client::Connect viene effettuata in modo asincrono, viene inviata una notifica di completamento corretto (DPN_MSGID_CONNECT_COMPLETE) al sistema di gestione dei messaggi del programma (DPN_OK).
  • Non vengono inviati messaggi DPN_MSGID_DESTROY_PLAYER al sistema di gestione dei messaggi del programma.
Risoluzione
Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 How to Obtain the Latest Windows XP Service Pack
La versione in lingua inglese di questa correzione deve avere i seguenti attributi di file (o attributi successivi):
   Data        Ora    Versione     Dimensione  Nome file   -----------------------------------------------------   18/04/2002  17.05  5.1.2600.43  156.672     Dpnet.dll

Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo. Questo problema è stato corretto per la prima volta nel Service Pack 1 per Windows XP.
Proprietà

ID articolo: 321463 - Ultima revisione: 01/12/2015 20:10:53 - Revisione: 2.1

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • kbnosurvey kbarchive kbqfe kbhotfixserver kbbug kbfix kbmm kbwinxpsp1fix KB321463
Feedback