FIX: STI applicazione si blocca quando si tenta di utilizzare UnLockDevice() per sbloccare il dispositivo

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 323571
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
In alcuni casi, un'applicazione di acquisizione l'opzione relativa al architettura immagine (STI) bloccato correttamente una periferica smetta di rispondere (si blocchi) per un periodo di tempo indefinito quando si utilizza il metodo UnLockDevice sbloccare il dispositivo.
Cause
Questo problema si verifica perché il servizio WIA (Windows Image ACQUISITION) viene generato un deadlock in questo momento e non può elaborare le richieste più WIA o STI.
Risoluzione
Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389Come ottenere Windows XP Service Pack più recente

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft: Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Informazioni sui file

La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o successivi). Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time    Version        Size    File Name   -----------------------------------------------------   11-Jun-2002  10:29   5.2.2.8        3,584   Spmsg.dll   19-Jun-2002  15:48   5.1.2600.48   61,952   Sti.dll   11-Jun-2002  15:50   5.1.2600.48  314,368   Wiaservc.dll				

Status
Microsoft ha confermato che questo un bug nei prodotti Microsoft elencati all'inizio di questo articolo. Questo problema è stato corretto per la prima volta nel Service Pack 1 per Windows XP.
Informazioni
Questo problema si verifica a causa di un presupposto non valido su cui il blocco ID del thread appartiene a. Il servizio di WIA utilizza l'ID di thread di chiamata a procedura remota (RPC) anziché l'ID del thread del client. Poiché RPC utilizza un pool di thread, le richieste in ingresso possono essere elaborate su thread diversi, causando la mancata corrispondenza ID del thread.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 323571 - Ultima revisione: 01/12/2015 20:28:59 - Revisione: 1.4

Microsoft Windows XP Professional

  • kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbshell kbwinxpsp1fix KB323571 KbMtit
Feedback