Al momento sei offline in attesa che la connessione Internet venga ristabilita

Avvio del Blocco note con "[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\System32\Shell32.dll,-21787" all'avvio del computer

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Sintomi
All'avvio del computer, viene avviato il Blocco note e uno o più documenti di testo contenenti le seguenti righe vengono visualizzati sul desktop di Windows:
[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787
Cause
Questo comportamento può verificarsi nelle seguenti circostanze:
  • Un file Desktop.ini è presente in una o più delle cartelle elencate di seguito, dove unità rappresenta l'unità su cui è stato installato Windows:
    • unità:\Documents and Settings\All Users\Menu Avvio\Programmi\Esecuzione automatica
    • unità:\Documents and Settings\All Users\Menu Avvio\Programmi
    • unità:\Documents and Settings\All Users\Menu Avvio
    -e-
  • Il file Desktop.ini contiene le righe seguenti:
    [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787
Risoluzione
Per risolvere il problema, utilizzare uno dei metodi descritti di seguito:

Per consentire al supporto tecnico di eseguire il Metodo 1, andare alla sezione "Correzione automatica". Per risolvere manualmente il problema, accedere alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul collegamento o sul pulsante Fix it. Fare clic su Esegui nella finestra di dialogo Download file e attenersi alla procedura guidata Fix it.




Note
  • Questa procedura guidata è disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Fix it su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Accedere, quindi, alla sezione "Verifica della risoluzione del problema".



Correzione manuale

Metodo 1: eliminare il file Desktop.ini

  1. Avviare Esplora risorse.
  2. Scegliere Opzioni cartella dal menu Strumenti, quindi fare clic sulla scheda Visualizza.
  3. Nella casella Impostazioni avanzate, deselezionare le caselle di controllo Nascondi le estensioni per i tipi di file conosciuti e Nascondi i file protetti di sistema (se non ancora deselezionate), quindi fare clic su OK.
  4. Eliminare qualsiasi occorrenza del file Desktop.ini contenente le righe precedentemente descritte nella sezione "Sintomi" di questo articolo. Per effettuare questa operazione:
    1. Individuare ognuna delle seguenti cartelle, fare clic con il pulsante destro del mouse sul file Desktop.ini (se presente nella cartella), quindi scegliere Apri:
      • unità:\Documents and Settings\All Users\Menu Avvio\Programmi\Esecuzione automatica
      • unità:\Documents and Settings\All Users\Menu Avvio\Programmi
      • unità:\Documents and Settings\All Users\Menu Avvio
      dove unità rappresenta l'unità su cui è installato Windows.
    2. Verificare che il file contenga le righe seguenti:
      [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787
      Se il file contiene tali righe, fare clic con il pulsante destro del mouse sul file, scegliere Elimina e fare clic su alla richiesta di conferma dell'eliminazione.
  5. Riavviare il computer e verificare che il problema sia stato risolto.

Metodo 2: utilizzare l'Utilità Configurazione di sistema (Msconfig.exe) per disabilitare l'elemento di avvio

  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri digitare msconfig, quindi scegliere OK.
  3. Fare clic sulla scheda Avvio.
  4. Fare clic per deselezionare la casella di controllo accanto a ogni voce del desktop nella colonna dell'elemento di avvio elencata come Esecuzione automatica (comune) nella colonna Percorso e presente anche nei seguenti percorsi (come indicato nella colonna Comando):
    • unità:\Documents and Settings\All Users\Menu Avvio\Programmi\Esecuzione automatica
    • unità:\Documents and Settings\All Users\Menu Avvio\Programmi
    • unità:\Documents and Settings\All Users\Menu Avvio
  5. Fare clic su OK per chiudere l'Utilità Configurazione di sistema.
  6. Riavviare il computer e verificare che il problema sia stato risolto.

Verifica della risoluzione del problema

  • Verificare che il problema sia stato corretto. Se il problema è stato risolto, è possibile interrompere la lettura di questa sezione. Se il problema persiste, è possibile rivolgersi al supporto tecnico.
  • Invio di commenti. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento nel blog "Correzione automatica" o inviare un messaggio di posta elettronica a Microsoft.
Informazioni
Per ulteriori informazioni sulla risoluzione dei problemi mediante l'Utilità Configurazione di sistema in Windows XP, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
310560 Risoluzione degli errori di configurazione utilizzando l'Utilità Configurazione di sistema in Windows XP
fixit fix it fixme
Proprietà

ID articolo: 330132 - Ultima revisione: 11/30/2012 18:31:00 - Revisione: 3.0

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional

  • kbprb kbfixme kbmsifixme KB330132
Feedback
: none; " src="https://c1.microsoft.com/c.gif?DI=4050&did=1&t=">