Aggiornamenti dello schermo lenti dopo la riconnessione alla sessione della console

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Quando ci si connette alla sessione della console in un computer basato su Windows XP utilizzando il client Desktop remoto, è possibile che gli aggiornamenti dello schermo siano lenti e che il computer non risponda ai comandi. Se si fa clic sul desktop con il pulsante destro del mouse, gli aggiornamenti vengono visualizzati.
Cause
Questo problema dovrebbe verificarsi solo se viene chiamata una specifica funzione Win32 (EnumDisplaySettings) durante una precedente disconnessione di una sessione RDP alla console.
Risoluzione
È disponibile una correzione supportata da Microsoft, che è tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarla solo nei computer in cui si verifica questo problema specifico. È possibile che su questa correzione vengano eseguiti ulteriori test. Se dunque questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del Service Pack di Windows XP contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Microsoft (PSS) e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:NOTA: in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Clienti potrebbero essere annullate qualora un addetto del Supporto tecnico Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi dell'assistenza verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questa correzione ha gli attributi di file elencati nella tabella seguente (o successivi). Date e ore elencate di seguito sono espresse in formato UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data      Ora    Versione       Dimensione  Nome file    Piattaforma  SP   -----------------------------------------------------------------------------   18/12/02  19.03  5.1.2600.108    87.048     Rdpdd.dll    x86          nessuno   20/12/02  21.55  5.1.2600.1152   87.304     Rdpdd.dll    x86          nessuno   18/12/02  19.03  5.1.2600.108   259.976     Rdpdd.dll    IA86         nessuno   05/12/02  01.28  5.1.2600.1148  261.128     Rdpdd.dll    IA64         nessuno

Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo.
Informazioni
Quando si verifica questo problema, il computer non sembra risentirne in altri modi, ad esempio l'utilizzo della CPU rimane normale. È possibile annullare la condizione con un accesso interattivo (alla console fisica).

Per stabilire se questo problema si verifica, aprire un prompt dei comandi e digitare alcuni caratteri. Se si verifica, i caratteri vengono visualizzati solo se si fa clic sul desktop con il pulsante destro del mouse.

L'agente Inventory di Microsoft Systems Management Server (SMS) utilizza le classi WMI Win32_DisplayControllerConfiguration e Win32_VideoController. Queste classi WMI utilizzano la funzione interessata dal problema. Poiché l'agente è in esecuzione normalmente in background, come un servizio, provoca il problema se una sessione della console remota viene lasciata disconnessa.
Proprietà

ID articolo: 811080 - Ultima revisione: 02/27/2014 07:46:18 - Revisione: 3.2

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition SP1
  • kbnosurvey kbarchive kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB811080
Feedback