L'installazione di Internet Information Services può causare problemi in Windows XP

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Dopo l'installazione del servizio FTP o dopo l'aggiunta del componente Microsoft Internet Information Services (IIS) in Windows XP, è possibile che prima dell'accesso venga visualizzato il messaggio di errore "C000021A" in una schermata blu.
Cause
Questo problema potrebbe verificarsi se il nome del computer contiene la parola "system" (ad esempio "Mysystem" o "System 32"). Il programma di installazione di IIS rimuove l'autorizzazione dell'account IUSER per i file di sistema critici nel processo di installazione o nel componente IIS. A causa di un problema di confronto delle stringhe, il programma rimuove per errore gli ACL dell'account di sistema per i file di sistema, rendendo impossibile l'avvio del computer.
Risoluzione

Informazioni sul service pack

Per risolvere il problema, procurarsi il service pack più recente per Microsoft Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Come ottenere il service pack più recente per Windows XP

Informazioni sull'aggiornamento rapido (hotfix)

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo aggiornamento rapido (hotfix) vengano eseguiti ulteriori test. Se questo problema non causa gravi difficoltà, è pertanto consigliabile attendere la versione successiva del Service Pack 2 di Windows XP contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo: Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Nome file   ---------   Iis.dll

Il file Iis.dll consente di risolvere preventivamente il problema. Tuttavia, se viene visualizzato un messaggio di errore "C000021A" e non è possibile riavviare il computer, spostare l'unità in un altro sistema operativo NTFS, riassegnare il sistema (autorizzazione di controllo completo per i file presenti nella cartella system32), quindi riavviare il sistema operativo Windows XP originale.
Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo. Questo problema è stato corretto per la prima volta nel Service Pack 2 per Microsoft Windows XP.
Workaround
Per risolvere il problema, modificare il nome del computer.
Proprietà

ID articolo: 811412 - Ultima revisione: 01/12/2015 21:12:40 - Revisione: 4.5

  • Microsoft Windows XP Professional
  • kbnosurvey kbarchive kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB811412
Feedback