Al momento sei offline in attesa che la connessione Internet venga ristabilita

Le modifiche alla dimensione, visualizzazione, icona o la posizione di una cartella vengono perse

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 813711
Sintomi
Le modifiche alla dimensione, visualizzazione, icona o la posizione di una cartella vengono persi in un computer che esegue Windows XP, Windows Vista o Windows 7.

Ad esempio, si verifichi uno o più dei seguenti problemi:
  • Microsoft Windows non memorizza le impostazioni di visualizzazione per una cartella quando si riapre la cartella.

    Nota Le impostazioni di visualizzazione includono anteprime, titoli, icone, elenco, dettagli e così via.
  • Non è possibile mantenere le dimensioni o la posizione di una finestra di cartella quando si riapre la cartella.
  • Per una cartella viene visualizzata un'immagine di anteprima non corretta.
  • L'immagine di anteprima non viene visualizzata per una cartella.


Nota Questo problema può verificarsi in Windows XP o in Windows Vista, anche se si seleziona la casella di controllo memorizza le impostazioni di visualizzazione di ogni cartella nel menu Impostazioni avanzate nella scheda visualizzazione delle Opzioni cartella nel Pannello di controllo.
Cause
Questo problema si verifica perché le impostazioni del Registro di sistema per Opzioni cartella non sono corrette.
Risoluzione

Diagnosticare e risolvere il problema automaticamente

Microsoft fix it banner
Il Esegui diagnosi e ripristina automaticamente i File di Windows e problemi relativi alla cartella risoluzione dei problemi è possibile risolvere automaticamente il problema descritto in questo articolo.

Risoluzione dei problemi corregge molti problemi.
Ulteriori informazioni
Esegui ora
Il Esegui diagnosi e ripristina automaticamente i File di Windows e problemi relativi alla cartella risoluzione dei problemi è possibile risolvere automaticamente il problema descritto in questo articolo.
Risoluzione dei problemi corregge molti problemi.Ulteriori informazioniEsegui ora

Correggere il problema manualmente

Importante Questa sezione, metodo o attività contiene passaggi su come modificare il Registro di sistema. Tuttavia, può causare seri problemi la modifica del Registro di sistema in modo non corretto. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Cosicché sia possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
322756 Eseguire il backup e ripristino del Registro di sistema in Windows
Per risolvere il problema, ripristinare le impostazioni del Registro di sistema per le cartelle. A tale scopo, attenersi alla procedura appropriata per il sistema operativo:

Windows XP

  1. Eliminare le seguenti sottochiavi del Registro di sistema:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags
  2. Ricreare le sottochiavi del Registro di sistema seguente:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam
  3. Creare e quindi impostare il valore del Registro di sistema BagMRU Size su 5000 nelle sottochiavi del Registro di sistema creato nel passaggio 2.

Windows Vista o Windows 7

  1. Eliminare le seguenti sottochiavi del Registro di sistema:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags


    Per le versioni x64 di Windows Vista o Windows 7, eliminare le seguenti sottochiavi del Registro di sistema:
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
  2. Ricreare le sottochiavi del Registro di sistema seguente:
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags


    Per le versioni x64 di Windows Vista o Windows 7, ricreare le sottochiavi del Registro di sistema seguente:
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\Bags
    • HKEY_CURRENT_USER\Software\Classes\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
  3. Creare e quindi impostare il valore del Registro di sistema BagMRU Size su 5000 nelle sottochiavi del Registro di sistema creato nel passaggio 2.
Informazioni

Modalità di funzionamento il pacchetto passe-partout per risolvere il problema

  1. Il pacchetto MATS analizza il computer e rileva se il computer è in esecuzione Windows XP, Windows Vista o Windows 7.

    Se il computer è in esecuzione Windows XP, il pacchetto MATS verifica che una delle seguenti condizioni è vera:
    • Il valore del Registro di sistema BagMRU Size nella seguente sottochiave del Registro di sistema non esiste o è minore di 5000:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
    • Il numero più alto di sottochiavi nella seguente sottochiave del Registro di sistema è supera al 20% del valore del Registro di sistema BagMRU Size :
      HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags


      Nota Durante questo processo, viene visualizzata una finestra di dialogo. Nella finestra di dialogo offre la possibilità di correggere il problema automaticamente (questo è l'opzione consigliata) o di selezionare manualmente i singoli problemi da correggere. Se si selezionano manualmente singoli problemi da correggere, è necessario selezionare l' icona e cartella personalizzazioni o l'opzione non conosce ad altri utenti o I nella finestra di dialogo.


    Se il computer è in esecuzione Windows Vista o Windows 7, il pacchetto MATS verifica che una delle seguenti condizioni è vera:
    • Il valore del Registro di sistema NoSaveSettings nella seguente sottochiave del Registro di sistema non è uguale a 1:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
      Inoltre, il valore del Registro di sistema BagMRU Size nella seguente sottochiave del Registro di sistema non esiste o è minore di 5000:
      HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
    • Il numero più alto di sottochiavi nella seguente sottochiave del Registro di sistema è supera al 20% del valore del Registro di sistema BagMRU Size :
      HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags


      Nota Durante questo processo, viene visualizzata una finestra di dialogo. Nella finestra di dialogo offre la possibilità di correggere il problema automaticamente (questo è l'opzione consigliata) o di selezionare manualmente i singoli problemi da correggere. Se si selezionano manualmente singoli problemi da correggere, yot necessario selezionare l' icona e cartella personalizzazioni o l'opzione non conosce ad altri utenti o I nella finestra di dialogo.
  2. Il pacchetto MATS verifica che le impostazioni del Registro di sistema e le personalizzazioni per le cartelle sono ripristinate correttamente.

Altri elementi che le correzioni del pacchetto passe-partout

2394521 Impossibile svuotare il Cestino in Windows XP o in Windows Vista
949109 Messaggio di errore "il file o la cartella non esiste" in Windows Vista
934160 "Autorizzazione di rete o il file" o "non esiste" errore
2394740 Non è possibile selezionare più elementi dopo l'aggiornamento da Windows XP a Windows Vista
2396571 Modifica di icone in modo non corretto in Windows

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 813711 - Ultima revisione: 07/03/2015 22:31:00 - Revisione: 14.0

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional, Windows Vista Enterprise 64-bit edition, Windows Vista Home Basic 64-bit edition, Windows Vista Home Premium 64-bit edition, Windows Vista Ultimate 64-bit edition, Windows Vista Business, Windows Vista Business 64-bit edition, Windows Vista Enterprise, Windows Vista Home Basic, Windows Vista Home Premium, Windows Vista Starter, Windows Vista Ultimate, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Starter, Windows 7 Ultimate

  • kbtshoot kbprb kbexpertisebeginner kbexpertiseinter kbsurveynew kbmatsfixme kbmt KB813711 KbMtit
Feedback