Al momento sei offline in attesa che la connessione Internet venga ristabilita

Le periferiche USB composite le cui interfacce non sono numerate in sequenza non funzionano in Windows XP

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l Ulteriori informazioni su come continuare a essere protetti.

Sintomi
Una periferica che contiene più di una descrizione di interfaccia è detta periferica USB composita. In una periferica di questo tipo ogni interfaccia è identificata da un numero. Quando una periferica USB composita le cui interfacce non sono numerate in sequenza viene collegata a un computer che esegue Microsoft Windows XP, la periferica non viene avviata.
Cause
Questo problema si verifica perché un nuovo driver per periferiche USB composite incluso in Windows XP presuppone che tutte le periferiche USB composite dispongano di interfacce numerate in sequenza.

Se le interfacce non sono numerate in sequenza, il driver (Usbccgp.sys) non è in grado di trovare tutte le interfacce in fase di selezione di una configurazione iniziale per la periferica. Di conseguenza, la configurazione iniziale non funziona quando viene inviata allo stack di driver USB perché alcune delle interfacce risultano mancanti nella richiesta di configurazione. Questa differenza nell'elenco delle interfacce fa sì che il driver Usbccgp.sys non avvii la periferica.
Risoluzione
È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
Data         Ora      Versione      Dimensione   Nome file     Piattaforma-----------------------------------------------------------------------------24/02/2003   14.03    5.1.2600.111      24.960   usbccgp.sys   Windows XP21/02/2003   18.57    5.1.2600.1172     28.160   usbccgp.sys   Windows XP SP1
Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo.
Proprietà

ID articolo: 814560 - Ultima revisione: 05/31/2006 05:48:00 - Revisione: 3.7

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1a
  • Microsoft Windows XP Service Pack 1a
  • kbbug kbfix kbqfe kbprb kbusb kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB814560
Feedback