Al momento sei offline in attesa che la connessione Internet venga ristabilita

Problemi durante l'esecuzione di un programma che accede a un'unità DVD-ROM o CD-RW USB 2.0

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l Ulteriori informazioni su come continuare a essere protetti.

Il supporto per Windows Server 2003 è terminato il 14 luglio 2015.

Microsoft ha sospeso il supporto per Windows Server 2003 in data 14 luglio 2015. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Sintomi
Quando si esegue un programma che accede a un'unità DVD-ROM o CD-RW USB (Universal Serial Bus) 2.0, si possono verificare problemi simili a quelli descritti nei seguenti scenari:
  • Se si esegue Intervideo WinDVD con un'unità DVD-ROM USB 2.0, l'audio o il video può risultare distorto e potrebbe essere problematico visualizzare un particolare menu o scena del disco. Questi problemi si verificano quando si riproduce un DVD per un determinato periodo di tempo, ad esempio da 30 a 60 minuti, si chiude e si riavvia WinDVD e si tenta di nuovo di riprodurre il DVD.
  • Se si esegue Easy CD Creator di Roxio, ad esempio la versione 5, con un'unità CD-RW USB 2.0 e si utilizza la funzionalità di copia del disco, quando tale funzionalità tenta di trovare l'unità CD-RW potrebbe essere visualizzato un messaggio di errore analogo al seguente:
    Impossibile trovare un lettore di CD di supporto.
    In un computer basato su Windows 2000 può anche essere visualizzato un messaggio di rimozione non sicura di una periferica che si riferisce all'unità CD-RW, oppure può essere visualizzato il messaggio "Windows 2000 ha terminato l'installazione delle nuove periferiche" e viene richiesto di riavviare il computer perché le modifiche abbiano effetto.
  • Se si esegue Easy CD Creator di Roxio, ad esempio la versione 5, con un'unità CD-RW USB 2.0, potrebbe non essere possibile cancellare un disco CD-RW esistente.
Cause
Questi problemi possono verificarsi se il controller host genera un comando di reimpostazione del bus USB dopo avere ricevuto numerosi pacchetti USB STALL dalla periferica DVD-ROM o CD-RW. Questi pacchetti STALL sono solitamente generati dalla periferica in risposta a un comando che il controller host non è in grado di eseguire.

Quando si verifica questa situazione mentre nel bus è presente un'ulteriore quantità di traffico significativa, il driver del controller host USB 2.0 (Usbehci.sys) può non riuscire a restituire lo stato dei risultati corretto per un trasferimento USB che è stato interrotto a causa della condizione STALL. Questa condizione può fare in modo che i driver USB di livello superiore non interpretino correttamente lo stato della periferica e del bus USB. I driver generano quindi una reimpostazione del bus per risolvere le condizioni di errore e reinizializzare la periferica USB nel bus.

Le operazioni critiche comprendono il rilevamento dell'unità CD-RW o l'autenticazione di un titolo DVD. Se la reimpostazione del bus USB si verifica durante l'esecuzione di un'operazione critica, tale operazione può non andare a buon fine e potrebbe non essere possibile correggere l'errore da parte dell'applicazione, vale a dire da un lettore di DVD o da un masterizzatore. Questa condizione causa i sintomi descritti nella sezione "Sintomi" del presente articolo.

Nota Tra le periferiche USB che generano ulteriore traffico USB sufficiente a causare i problemi descritti nella sezione "Sintomi" sono comprese:
  • Schede Bluetooth, comprese quelle incorporate nei computer portatili
  • Periferiche Pocket PC che eseguono un'operazione ActiveSync mediante una connessione USB
Risoluzione

Informazioni sul service pack per Windows XP

Per risolvere il problema, procurarsi il service pack più recente per Microsoft Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Come ottenere il service pack più recente per Windows XP

Informazioni sull'aggiornamento rapido

Windows Server 2003

È disponibile una correzione supportata da Microsoft, che è tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che la correzione venga sottoposta ad altre verifiche allo scopo di migliorare ulteriormente la qualità del prodotto. Se dunque questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows Server 2003 contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo: Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Informazioni sui file
La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione     Dimensione  Nome file    Piattaforma   --------------------------------------------------------------------   13/05/2003  00.40  5.2.3790.25      19.968  Usbehci.sys  i386   13/05/2003  00.40  5.2.3790.25      61.312  Usbehci.sys  ia64

Windows XP

È disponibile una correzione supportata da Microsoft, che è tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarla solo nei computer in cui si verifica questo problema specifico. È possibile che su questa correzione vengano eseguite ulteriori verifiche. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:NOTA: in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi dell'assistenza verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione       Dimensione   Nome file    Piattaforma   -----------------------------------------------------------------------   13/05/2003  01.14  5.1.2600.1222      19.456   Usbehci.sys  i386   12/05/2003  04.22  5.1.2600.1221     137.600   Usbport.sys  i386   13/05/2003  01.14  5.1.2600.1222      64.768   Usbehci.sys  ia64   10/05/2003  13.10  5.1.2600.1221     482.816   Usbport.sys  ia64				

Windows 2000

È disponibile un aggiornamento rapido supportato da Microsoft, destinato esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico.

Per risolvere il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data            Ora    Versione Dimensione  Nome file   --------------------------------------------------------   15/01/2003  19.45  5.0.2195.6655   24.752  Hidclass.sys   08/05/2003  17.22  5.0.2195.6743   24.912  Openhci.sys   23/04/2003  17.52  5.0.2195.6739   32.944  Uhcd.sys   23/04/2003  17.52  5.0.2195.6739   20.752  Usbd.sys   13/05/2003  19.47  5.0.2195.6745   19.728  Usbehci.sys   15/01/2003  19.46  5.0.2195.6655   49.776  Usbhub20.sys   28/04/2003  17.41  5.0.2195.6741  138.768  Usbport.sys				

Workaround
Per risolvere questi problemi, riavviare il computer. In questo modo il problema potrebbe anche essere risolto.
Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine di questo articolo. Questo problema è stato corretto per la prima volta nel Service Pack 2 per Microsoft Windows XP.
Informazioni
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.
Proprietà

ID articolo: 820759 - Ultima revisione: 12/03/2007 06:58:00 - Revisione: 6.3

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • kbbug kbfix kbqfe kbsound kbdriver kbwinxpsp2fix kbdisplay kbwinxppresp2fix kbwin2000presp5fix kbwinserv2003presp1fix kbhotfixserver KB820759
Feedback