Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore di inizializzazione "User32.dll non riuscita" o l'interfaccia utente non viene aggiornata correttamente

Il supporto per Windows Server 2003 è terminato il 14 luglio 2015.

Microsoft ha sospeso il supporto per Windows Server 2003 in data 14 luglio 2015. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 826518
Sintomi
Se un programma (ad esempio Microsoft Word) utilizza una funzione di GDI (Graphics Device Interface) API che crea un pennello, ad esempio CreateSolidBrush , e se il programma rimuove una finestra prima rimuove il pennello, le risorse GDI diventi insufficiente e si potrebbe verificarsi uno o più dei seguenti sintomi:
  • È visualizzato un messaggio di errore analogo al seguente:
    Service_NameErrore di inizializzazione DLL - inizializzazione del c:\windows\system32\user32.dll di libreria di collegamento dinamico non riuscito. Il processo è stato terminato in modo anomalo.
  • L'interfaccia utente non può essere aggiornata correttamente. Ad esempio, i menu non vengono visualizzati correttamente, testo del pulsante viene persa o immagini icona non ridisegnata.
Cause
Questo problema si verifica perché il sistema operativo possibile una perdita di un handle per un oggetto brush GDI se una finestra viene rimosso prima di rimossa il pennello.

Per ulteriori informazioni su come risolvere questo problema, vedere la sezione "More Information" di questo articolo.
Risoluzione

Windows Server 2003

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft: Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Non è richiesto alcun prerequisito.
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
  Date         Time   Version       Size       File name   -------------------------------------------------------  08-Dec-2003  06:11  5.2.3790.110  1,811,456  Win32k.sys

Windows 2000

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft: Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario installato nel computer Windows 2000 Service Pack 4 (SP4). Per ulteriori informazioni su come ottenere il service pack più recente, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
260910Come ottenere Windows 2000 Service Pack più recente
Necessità di riavvio
È necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version            Size    File name   --------------------------------------------------------------   10-Sep-2003  18:52  5.0.2195.6738      42,256  Basesrv.dll         17-Jan-2003  16:06  5.0.2195.6656     236,304  Cmd.exe             10-Sep-2003  18:52  5.0.2195.6762     222,992  Gdi32.dll           10-Sep-2003  18:52  5.0.2195.6816     711,440  Kernel32.dll        10-Sep-2003  18:52  5.0.2195.6807     333,584  Msgina.dll          10-Sep-2003  18:52  5.0.2195.6701      90,232  Rdpwd.sys   04-Sep-2003  17:06  5.0.2195.6801   5,232,128  Sp3res.dll          10-Sep-2003  18:52  5.0.2195.6799     380,176  User32.dll          10-Sep-2003  18:52  5.0.2195.6794     385,808  Userenv.dll         08-Sep-2003  17:21  5.0.2195.6817   1,628,464  Win32k.sys   03-Sep-2003  22:13  5.0.2195.6815     182,032  Winlogon.exe        10-Sep-2003  18:52  5.0.2195.6775     243,984  Winsrv.dll          10-Sep-2003  18:52  5.0.2195.6816     711,440  Kernel32.dll        08-Sep-2003  17:21  5.0.2195.6817   1,628,464  Win32k.sys   10-Sep-2003  18:52  5.0.2195.6775     243,984  Winsrv.dll 
Status
Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a" di questo articolo.
Informazioni
Per risolvere questo problema, è possibile utilizzare lo strumento Gdiobj.exe per monitorare la colonna pennello 0 numero di serie . PID 0 rappresenta gli oggetti GDI non sono privati. Se la colonna pennello continuamente aumenta, ma non diminuisce, è possibile che si verifichino il problema descritto in questo articolo. In questo caso, è possibile visualizzare la perdita quando si avvia e interrompere la riproduzione Microsoft; la colonna pennello aumenta di 2, ma quando si esce dal programma, non si riducano.

Per scaricare lo strumento Gdiobj.exe, è necessario visitare il seguente sito Web Yuan Feng:Per ulteriori informazioni sugli oggetti GDI, visitare il sito di Web di Microsoft:Per ulteriori informazioni sulla denominazione dei pacchetti di aggiornamento rapido (hotfix), fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
816915Nuovo assegnazione dei nomi dello schema per di pacchetti di Hotfix di Microsoft Windows

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 826518 - Ultima revisione: 07/24/2007 19:05:52 - Revisione: 3.7

Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows 2000 Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows 2000 Advanced Server

  • kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB826518 KbMtit
Feedback