Al momento sei offline in attesa che la connessione Internet venga ristabilita

How to Cambiare a livello di programmazione la visualizzazione predefinita di un modulo di Microsoft Office InfoPath 2003

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Sommario
I moduli di Microsoft Office InfoPath supportano più visualizzazioni. Una di queste è la visualizzazione predefinita. Quando si apre un modulo in InfoPath, tale modulo viene aperto nella visualizzazione predefinita. In questo articolo viene descritto come modificare a livello di programmazione la visualizzazione predefinita di un modulo di InfoPath.

Torna all'inizio

Creazione di un nuovo modulo

  1. Avviare InfoPath 2003.
  2. Scegliere Progetta modulo dal menu File.
  3. Nel riquadro Progetta modulo scegliere Nuovo modulo vuoto.
Torna all'inizio

Creazione della visualizzazione 1

  1. Nel modulo vuoto digitare Questa è la visualizzazione 1 nella prima riga, quindi digitare Selezionare per mostrare la visualizzazione 2 all'apertura del modulo nella seconda riga.
  2. Nel menu a discesa Riquadro attività fare clic su Controlli.
  3. Nel riquadro attività Controlli fare clic su Casella di controllo.
  4. Sostituire il testo Casella di controllo con Visualizzazione 2.
Torna all'inizio

Creazione della visualizzazione 2

  1. Nel menu a discesa Riquadro attività fare clic su Visualizzazioni.

    Visualizzazione 1 è la visualizzazione predefinita del modulo.
  2. Nella sezione Azioni del riquadro attività scegliere Aggiungi nuova visualizzazione.
  3. Digitare il nome Visualizzazione 2, quindi scegliere OK.
  4. Nel modulo vuoto digitare Questa è la visualizzazione 2.
Torna all'inizio

Aggiunta dello script

  1. Scegliere Script dal menu Strumenti, quindi scegliere Microsoft Script Editor.
  2. Aggiungere il seguente codice nella finestra del codice:
    function XDocument::OnLoad(eventObj){	//Pick the default view based on the value of element DefaultView	var objDefaultView = XDocument.DOM.selectSingleNode("//my:field1");	if ((objDefaultView != null) && (objDefaultView.text != ""))   	{		switch (objDefaultView.text)      		{         		case "false":				    XDocument.ViewInfos("View 1").IsDefault = true;            			break;         		case "true":            			XDocument.ViewInfos("View 2").IsDefault = true;            			break;      		}   	}}
  3. Salvare lo script, quindi chiudere Microsoft Script Editor.
  4. Salvare il modello di modulo con nome SwitchDefaultView.xsn, quindi chiuderlo.
Torna all'inizio

Esercizio

  1. Scegliere Compila modulo dal menu File.

    Nota Compilare il modulo in questo passaggio invece di visualizzare l'anteprima del modulo. Nell'anteprima non vengono visualizzate le modifiche apportate a livello di programma alla visualizzazione predefinita in corrispondenza dell'evento OnLoad. In modalità anteprima viene sempre mostrata la visualizzazione correntemente selezionata nella finestra di progettazione di InfoPath.
  2. Nel riquadro attività fare clic su SwitchDefaultView.

    Il modulo verrà aperto in visualizzazione 1 (la visualizzazione predefinita iniziale).
  3. Selezionare la casella di controllo Visualizzazione 2.
  4. Salvare il modulo con nome SwitchDefaultViewForm.xml, quindi chiudere il modulo.
  5. Scegliere Apri dal menu File.
  6. Individuare il file SwitchDefaultViewForm.xml e scegliere Apri.

    Il modulo verrà aperto in visualizzazione 2.
Torna all'inizio
Proprietà

ID articolo: 826997 - Ultima revisione: 01/20/2006 06:53:00 - Revisione: 3.0

Microsoft Office InfoPath 2003

  • kbhowto KB826997
Feedback