Servizi potrebbero smettere improvvisamente di chiusura o riavviare un computer basato su Windows Small Business Server 2003

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 839262
Avviso
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
importante in questo articolo sono contenute informazioni su come modificare il Registro di sistema (chiamato Registro di configurazione in Windows NT). Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986Descrizione del Registro di sistema di Microsoft Windows
Sintomi
Quando si arresta o si riavvia un computer basato su Microsoft Windows Small Business Server 2003, servizi in esecuzione nel computer potrebbero interrompere immediatamente il prima i servizi possono arrestare correttamente. In alcuni casi, la chiusura improvvisa di questi servizi può comportare il dati la perdita.
Cause
Questo problema si verifica perché il programma di installazione di Windows Small Business Server 2003 modifica in modo errato il valore del Registro di sistema WaitToKillServiceTimeout a un tipo REG_DWORD. Questo valore dovrebbe per essere di tipo REG_SZ. Di conseguenza, il sistema interpreta il valore WaitToKillServiceTimeout come un timeout 0 millisecondi e termina immediatamente servizi in esecuzione.
Risoluzione

Per risolvere il problema, è necessario eliminare il valore del Registro di sistema WaitToKillServiceTimeout e quindi ricreare il valore di WaitToKillServiceTimeout come un tipo REG_SZ. Per effettuare questa operazione, attenersi alla seguente procedura.

avviso Se si utilizza Editor del Registro di sistema in modo non corretto, si potrebbero provocare problemi gravi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce la che è possibile risolvere i problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. Utilizzare Editor del Registro di sistema a proprio rischio.
  1. Fare clic su Start , scegliere Esegui , digitare regedit nella casella Apri e quindi fare clic su OK .
  2. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
  3. Fare clic con il pulsante destro del mouse sul WaitToKillServiceTimeout valore fare clic su Elimina e quindi fare clic su per confermare la rimozione del valore del Registro di sistema.
  4. Nel riquadro sinistro dell'editor del registro, fare clic con il pulsante destro del mouse sul controllo , scegliere Nuovo , quindi Valore stringa .
  5. Creare il seguente valore di registro:
    • Nome valore: WaitToKillServiceTimeout
    • Tipo di valore: REG_SZ
    • Dati valore: 120000
  6. Chiudere l'editor del Registro di sistema e riavviare il computer.
Status
Microsoft ha confermato che questo un bug nei prodotti sono elencati nella sezione "Si applica a" di questo articolo.
WaitToKillServiceTimeout SBS smallbiz

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 839262 - Ultima revisione: 12/08/2015 06:45:35 - Revisione: 1.2

Microsoft Windows Small Business Server 2003 Premium Edition, Microsoft Windows Small Business Server 2003 Standard Edition

  • kbnosurvey kbarchive kbmt kbnofix kbbug KB839262 KbMtit
Feedback