Come utilizzare l'API di finestra di dialogo comuni in un database in Access 2003 o Access 2007

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 888695
INTRODUZIONE
In questo articolo viene descritto come utilizzare l'API di finestra di dialogo comuni più in Microsoft Office Access 2003 o in Microsoft Office Access 2007 per sostituire la funzionalità di finestra di dialogo comuni che è incluso solo in Microsoft Office 2000 Developer Edition o in Microsoft Office XP Developer Edition.
Informazioni
Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia espressa o implicita. Questo include, ma non è limitato a, le garanzie implicite di commerciabilità o idoneità per uno scopo specifico. Questo articolo si presuppone che conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug di procedure. Tecnici del supporto Microsoft possono spiegare la funzionalità di una particolare procedura, ma in nessun sono caso a modificare questi esempi per fornire funzionalità aggiuntive o creare procedure per soddisfare specifiche esigenze.

Procedura per sostituire la funzionalità della finestra di dialogo comune

Microsoft Office Access 2003

  1. In Access, aprire il database di esempio denominato Northwind.mdb.

    Nota Il database Northwind.mdb per Access 2003 trova in genere il Office\OFFICE11\Samples di C:\Program Files\Microsoft nella cartella.
  2. Fare clic su Form nell'elenco oggetti nella finestra del database.
  3. Fare clic su Nuovo sulla barra degli strumenti finestra database .
  4. Nella finestra di dialogo Nuova maschera , fare clic su Visualizzazione struttura e scegliere OK .
  5. Aggiungere una casella di testo a Form1, fare clic con il pulsante destro del mouse sulla casella di testo e quindi scegliere Proprietà .
  6. Fare clic sulla scheda tutte , fare clic su Nome , digitare Testo1 e chiudere la finestra di dialogo Proprietà .
  7. Clic col pulsante destro del mouse sul controllo etichetta è associato la casella di testo Testo1 , fare clic su Proprietà , quindi scegliere la scheda tutte .
  8. Fare clic su didascalia , digitare Testo1 e chiudere la finestra di dialogo Proprietà .
  9. Aggiungere un pulsante di comando a Form1 , fare clic con il pulsante destro del mouse sul pulsante comando, fare clic su Proprietà , fare clic su nome , digitare Command1 , fare clic su didascalia e digitare Command1 .
  10. Fare clic sulla scheda evento , fare clic su [Routine evento] nell'elenco Al clic del mouse e quindi fare clic sul pulsante con i puntini di sospensione per avviare Microsoft Visual Basic Editor.
  11. Modificare il codice nella procedura Command1_Click al seguente:
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  13. Dal menu debug scegliere Compila Northwind e chiudere l'editor di Visual Basic.
  14. Scegliere dal menu Visualizza , Form visualizza .
  15. Fare clic sul pulsante Command1 e quindi fare clic su un file nella finestra visualizzata.

    Il percorso del file verrà visualizzato nella casella di testo Testo1 .

Microsoft Office Access 2007

  1. In Access 2007 aprire il database di esempio denominato Northwind.accdb.
  2. Nella scheda Crea , fare clic su modulo nel gruppo +++ maschere .
  3. Nella scheda formato , fare clic sulla freccia sotto visualizzazione verso il basso e quindi scegliere Visualizzazione struttura .
  4. Aggiungere una casella di testo a Form1, fare clic con il pulsante destro del mouse sulla casella di testo e quindi scegliere Proprietà .
  5. Fare clic sulla scheda tutte , fare clic su Nome e quindi digitare Testo1 .
  6. Clic col pulsante destro del mouse sul controllo etichetta è associato la casella di testo Testo1 , fare clic su Proprietà , quindi scegliere la scheda tutte .
  7. Fare clic su didascalia e quindi digitare Testo1 .
  8. Aggiungere un pulsante di comando a Form1 , fare clic con il pulsante destro del mouse sul pulsante comando, fare clic su Proprietà , fare clic su nome , digitare Command1 , fare clic su didascalia e digitare Command1 .
  9. Fare clic sulla scheda evento , fare clic su [Routine evento] nell'elenco Al clic del mouse e quindi fare clic sul pulsante con i puntini di sospensione (... ) per avviare Microsoft Visual Basic Editor.
  10. Modificare il codice nella procedura Command1_Click simile a quella il seguente esempio di codice.
    Private Sub Command1_Click()    Me!Text1 = LaunchCD(Me)End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _"GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As LongPrivate Type OPENFILENAME    lStructSize As Long    hwndOwner As Long    hInstance As Long    lpstrFilter As String    lpstrCustomFilter As String    nMaxCustFilter As Long    nFilterIndex As Long    lpstrFile As String    nMaxFile As Long    lpstrFileTitle As String    nMaxFileTitle As Long    lpstrInitialDir As String    lpstrTitle As String    flags As Long    nFileOffset As Integer    nFileExtension As Integer    lpstrDefExt As String    lCustData As Long    lpfnHook As Long    lpTemplateName As StringEnd TypeFunction LaunchCD(strform As Form) As String    Dim OpenFile As OPENFILENAME    Dim lReturn As Long    Dim sFilter As String    OpenFile.lStructSize = Len(OpenFile)    OpenFile.hwndOwner = strform.hwnd    sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _      "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)    OpenFile.lpstrFilter = sFilter    OpenFile.nFilterIndex = 1    OpenFile.lpstrFile = String(257, 0)    OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1    OpenFile.lpstrFileTitle = OpenFile.lpstrFile    OpenFile.nMaxFileTitle = OpenFile.nMaxFile    OpenFile.lpstrInitialDir = "C:\"    OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"    OpenFile.flags = 0    lReturn = GetOpenFileName(OpenFile)        If lReturn = 0 Then            MsgBox "A file was not selected!", vbInformation, _               "Select a file using the Common Dialog DLL"         Else            LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1))          End IfEnd Function
  12. Dal menu debug scegliere Compila Northwind e chiudere l'editor di Visual Basic.
  13. Nella scheda formato , fare clic sulla freccia sotto visualizzazione , quindi Visualizzazione del form .
  14. Fare clic sul pulsante Command1 e quindi fare clic su un file nella finestra visualizzata.

    Il percorso del file verrà visualizzato nella casella Text1 .
ACC2003 ACC2007

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 888695 - Ultima revisione: 06/04/2007 19:34:07 - Revisione: 4.3

Microsoft Office Access 2007, Microsoft Office Access 2003

  • kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtit
Feedback