Informazioni sulla presenza non vengono visualizzato correttamente in un programma Real-Time Communications Client quando si connette a Office Live Communications Server 2005 su una connessione remota

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Sintomi
Se si crea un programma che utilizza l'API del client RTC (Real-Time Communications) Microsoft per connettersi a Microsoft Office Live Communications Server 2005, si verificano i seguenti sintomi:
  • Il programma client che si connette correttamente a Live Communications Server 2005 e la registrazione ha esito positivo.
  • Informazioni sulla presenza per i contatti dell'utente connesso non vengono visualizzato correttamente. In questo scenario, i contatti dell'utente connesso vengono visualizzati con lo stato non in linea .
  • CONTATTO SUBSCRIBE eventi restituiscono un codice di stato di errore di 0x80EE000C.

    Nota Questo codice di errore significa "SIP scaduto."
Cause
Questo problema si verifica se sono vere tutte le condizioni seguenti:
  • Il programma client di RTC si connette a Live Communications Server 2005 utilizzando una connessione remota o tramite una connessione con 56 kilobyte (KB) o meno larghezza di banda.
  • Il programma client di RTC è collegato a Live Communications Server 2005 mediante una connessione TCP.
  • Il programma client di RTC dispone di più di 150 voci configurate in un elenco di contatti.
Le API RTC versione 1.3 non supporta più di 150 voci dei contatti in questo scenario. In questo scenario, le informazioni sulla presenza per 150 contatti (amici) tramite una connessione a 56 KB richiede più di 32 secondi per il download tramite TCP. In questo scenario, il programma client RTC esito un errore di timeout.
Workaround
Per aggirare il problema, utilizzare uno dei seguenti metodi.

Metodo 1: Utilizzare Transport Layer Security

Per risolvere questo problema, configurare il programma di client RTC per utilizzare una connessione TLS (Transport Layer Security) con la compressione. In questo modo le informazioni sulla presenza da scaricare prima il client di RTC timeout del programma.

Metodo 2: Ridurre il numero di contatti a 150 o meno

In Live Communications Server 2005, specificare il numero massimo di contatti che un utente può aggiungere. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Inizio Live Communications Server 2005. Per effettuare questa operazione, fare clic su Start , scegliere Strumenti di amministrazione e quindi fare clic su Live Communications Server 2005 .
  2. Espandere l'insieme di strutture, espandere domini , espandere il dominio e quindi espandere server e pool di Live Communications Server .
  3. Fare clic con il pulsante destro del mouse sul server o il pool e quindi fare clic su Proprietà .
  4. Nella scheda Generale digitare 150 nella casella massimo contatti per utente .

    importante Se gli utenti che eseguono Microsoft Windows Messenger 5.1 o versioni precedenti, è necessario specificare il limite predefinito di 150 contatti per utente. Windows Messenger non funziona correttamente con più di 150 contatti per utente.
  5. Fare clic su Applica e quindi fare clic su OK .
Informazioni
Per ulteriori informazioni sul client di RTC, visitare il sito di Web di Microsoft: Per ulteriori informazioni su come ottenere l'API del client RTC, visitare il sito di Web di Microsoft:
RTC im chat

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Proprietà

ID articolo: 890301 - Ultima revisione: 01/15/2015 00:51:53 - Revisione: 1.4

  • Microsoft Office Live Communications Server 2005 Standard Edition
  • Microsoft Office Live Communications Server 2005 Enterprise Edition
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