Come aprire i documenti utilizzando la funzionalità Apri e ripristina in Word

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 893672
INTRODUZIONE
In questo articolo viene descritto come aprire i documenti utilizzando la funzionalità Apri e ripristina in Microsoft Office Word 2002 e versioni successive.
Informazioni
Microsoft Word utilizza automaticamente la funzionalità Apri e ripristina se Word rileva un problema con un documento quando si apre. Tuttavia, è possibile imporre l'utilizzare la funzionalità Apri e ripristina , quando si apre un documento. Può risultare particolarmente utile quando si desidera salvare il documento in un formato di file diverso. Se si salva un documento danneggiato in un formato diverso, non sarà possibile aprire il documento salvato. Per ulteriori informazioni sulla risoluzione dei documenti di Word danneggiati, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
826864 Come risolvere i documenti danneggiati di Word (per Word 2002 e 2003)
918429 Come risolvere i problemi relativi a documenti danneggiati in Word 2007 e Word 2010


Per aprire un documento utilizzando la funzionalità Apri e ripristina in Word, utilizzare uno dei metodi descritti di seguito.

Metodo 1: Per aprire un documento specifico

Per aprire un documento specifico utilizzando la funzionalità Apri e ripristina in Word, attenersi alla seguente procedura:
  1. Avvio di Word.
  2. Dal menu File, fare clic su Apri.

    Nota In Word 2007 o Word 2010, fare clic sul Pulsante Microsoft Officee quindi fare clic su Apri.
  3. Nella finestra di dialogo Apri fare clic per selezionare il file che si desidera aprire.
  4. Fare clic sulla freccia sul pulsante Apri e quindi fare clic su Apri e ripristina.

Metodo 2: Aprire tutti i documenti

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia espressa o implicita. Ciò include, ma non limitato a, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presuppone che si abbia familiarità con il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire la procedura di debug. I tecnici del supporto Microsoft possono spiegare la funzionalità di una particolare procedura, ma in nessun caso possono modificare questi esempi per fornire funzionalità aggiuntive o creare procedure atte a soddisfare specifiche esigenze. Per aprire tutti i documenti utilizzando la funzionalità Apri e ripristina in Word, sostituire la macro FileOpen incorporata in Word con la macro di Microsoft Visual Basic for Applications (VBA) Edition A tale scopo, attenersi alla seguente procedura:
  1. Avviare Word e quindi aprire un nuovo documento vuoto.
  2. In Word 2007, fare clic su macro nella scheda sviluppo . In Word 2003, scegliere Macro dal menu Strumenti e quindi fare clic su macro.
  3. Fare clic sulla freccia nella casella macro in e quindi fare clic su comandi di Word.
  4. Nell'elenco Nome Macro , fare clic su FileOpen.
  5. Fare clic sulla freccia nella casella macro in e quindi fare clic su Normal. dot (modello generale).

    Nota In Word 2007 e Word 2010, fare clic suNormal. dotm (modello generale).
  6. Fare clic su Crea.
  7. La macro FileOpen incorporata viene visualizzato come illustrato di seguito:
    Sub FileOpen()'' FileOpen Macro' Opens an existing document or template'    Dialogs(wdDialogFileOpen).ShowEnd Sub
  8. Nel seguente esempio di macro, sostituire la macro FileOpen incorporata:
    Option Explicit' WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS EXAMPLE IS' AT YOUR OWN RISK. Microsoft provides this macro code "as is" without warranty of' any kind, either expressed or implied, including but not limited to the implied ' warranties of merchantability and/or fitness for a particular purpose.Sub FileOpen()'' FileOpen Macro' Opens an existing document or template'Dim sFileName As String' Display the File Open dialog and capture the filename selected and pass it to a' variableWith Application.Dialogs(wdDialogFileOpen)    .Display    sFileName = .NameEnd With' Test to verify the filename has a value' If no file is chosen or if the Open dialog is dismissed, ' the following code is skippedIf sFileName <> "" Then    ' Use the filename as a variable to be opened using Open and Repair feature    Documents.Open FileName:=sFileName, OpenAndRepair:=TrueEnd IfEnd Sub
  9. Dal menu File , scegliere Chiudi e torna a Microsoft Word.
  10. Dal menu File , premere MAIUSC e quindi fare clic su Salva tutto.
Note
  • La nuova macro FileOpen verrà eseguita solo se si apre un documento utilizzando uno qualsiasi dei seguenti metodi:
    • Scegliere Apri dal menu File .
    • Si fa clic su Apri sulla barra degli strumenti Standard .
  • La nuova macro FileOpen non verrà eseguito se si apre un documento utilizzando uno qualsiasi dei seguenti metodi:
    • Aprire il documento in Esplora risorse.
    • Si apre il documento dall'elenco di file utilizzato di recente (MRU).
file Word2003 word2002 wd2003 2002 wd2k3 wd2k2 WD2007 word2010 wd2010

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 893672 - Ultima revisione: 08/06/2016 22:03:00 - Revisione: 3.0

Microsoft Office Word 2007, Microsoft Word 2002 Standard Edition, Microsoft Word 2010

  • kbopenfile kbprogramming kbautomation kbvba kbhowto kbmt KB893672 KbMtit
Feedback