Al momento sei offline in attesa che la connessione Internet venga ristabilita

Possibile riduzione delle prestazioni di Exchange 2000 Server ed Exchange Server 2003 quando sui computer client Outlook o su altri computer client MAPI viene eseguito un software di motore di ricerca desktop

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l Ulteriori informazioni su come continuare a essere protetti.

Sommario
In questo articolo vengono descritti i problemi che possono verificarsi nel computer client Outlook o MAPI e sul server di Exchange quando gli utenti del computer client utilizzano un motore di ricerca desktop. Viene descritto come identificare gli utenti che utilizzano motori di ricerca desktop e vengono altresì indicati i metodi seguenti utilizzabili per limitare i problemi causati dai motori di ricerca desktop:
  • Utilizzo della modalità cache di Exchange in Microsoft Office Outlook 2003.
  • Piano di utilizzo dei motori di ricerca desktop da stilare in contemporanea con il piano per l'ambiente del server di Exchange.
  • Utilizzo dei criteri software sul lato client per impedire agli utenti di utilizzare i motori di ricerca desktop.
  • Utilizzo dell'indicizzazione Exchange del contenuto.
Sintomi
Se si utilizza un computer client Microsoft Outlook 2002 o Microsoft Office Outlook 2003, possono verificarsi dei ritardi. Può inoltre essere visualizzato un messaggio analogo al seguente relativo alle connessioni RPC:
Outlook sta richiedendo informazioni dal server di Exchange.
Se si utilizza un computer client che esegue una versione precedente di Outlook o se si utilizza un computer client MAPI, possono verificarsi dei ritardi oppure il computer potrebbe bloccarsi. Su un server che esegue Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003, può notarsi un utilizzo maggiore della CPU nel processo Store.exe o un'attività del disco del database maggiore del previsto.
Cause
Questo problema si verifica se il computer client Outlook o MAPI esegue un motore di ricerca desktop che si integra con Outlook per indicizzare i dati della cartella pubblica o della cassetta postale dell'utente che si trovano sul server di Exchange.

Il numero di utenti che utilizzano motori di ricerca desktop, ad esempio MSN Desktop Search, è in continua crescita. La presenza di motori di ricerca desktop può raddoppiare o triplicare il carico sul server di Exchange. L'utilizzo incrementato, o non ottimale, delle risorse del server porta a percepire sul computer client prestazioni scadenti e a evidenti cali di prestazioni sul server. Questi problemi sono stati osservati con vari motori di ricerca desktop integrati con la funzionalità di ricerca nelle cassette postali.

Quando gli utenti impiegano motori di ricerca desktop, possono verificarsi i seguenti problemi:
  • Incremento dell'utilizzo della CPU e picchi di I/O del disco sul server di Exchange
  • Colli di bottiglia RPC sul lato client
  • Incremento delle operazioni RPC al secondo sul server di Exchange
Questi problemi possono portare a un incremento dei valori complessivi della latenza media RPC sul server di Exchange. L'aumento dei valori della latenza media RPC può causare i sintomi descritti nella sezione "Sintomi". Sul computer client il motore di ricerca desktop può inviare numerose richieste RPC al server. Ciò provoca un collo di bottiglia RPC sul lato client. Quando si verifica un collo di bottiglia RPC sul lato client, può aversi un ritardo nella risposta RPC anche se il server funziona normalmente e non vi sono problemi di connettività di rete.
Risoluzione

Come identificare gli utenti che eseguono motori di ricerca desktop

Per favorire l'identificazione degli utenti che utilizzano un motore di ricerca desktop a fronte del server di Exchange, è possibile utilizzare lo strumento Microsoft Exchange Server User Monitor (Exmon.exe).

Il seguente file è disponibile per il download dall'Area download Microsoft (informazioni in lingua inglese):
Download del pacchetto Exmon.exe
Per ulteriori informazioni sul download di file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file è stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus più recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.


Per informazioni su come utilizzare lo strumento Exchange Server User Monitor, consultare la relativa documentazione disponibile dopo l'installazione dello strumento stesso.


Questo strumento può essere utilizzato per identificare specifici client MAPI responsabili della maggiore attività sul server.

Inoltre, è possibile utilizzare lo strumento Microsoft Exchange Server Performance Troubleshooting Analyzer Tool per raccogliere informazioni sulle prestazioni e analizzare le informazioni create dallo strumento EXMON.EXE. Per scaricare lo strumento Microsoft Exchange Server Performance Troubleshooting Analyzer Tool, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):

Come ridurre il numero di problemi correlati a un motore di ricerca desktop

Per ridurre il numero di problemi correlati a un motore di ricerca desktop, utilizzare uno o più dei metodi riportati di seguito.

Metodo 1: Utilizzo della modalità cache di Exchange in Outlook 2003

Quando si configura Outlook 2003 affinché venga eseguito in modalità cache di Exchange, il motore di ricerca desktop effettua le ricerche nella copia locale della cassetta postale anziché nel contenuto della cassetta postale sul server.

Nota Questo metodo non è utile se il motore di ricerca desktop include un'opzione che consente di eseguire ricerche nelle cartelle pubbliche di Exchange. Le cartelle pubbliche infatti non vengono memorizzate nella cache. Tuttavia, non tutti i motori di ricerca desktop includono tale opzione.

Metodo 2: Pianificazione di un incremento del carico quando si pianifica l'ambiente del server di Exchange

Se si prevede che gli utenti utilizzeranno i motori di ricerca desktop sui computer client, è opportuno pianificare l'incremento del carico quando si pianifica l'ambiente del server di Exchange qualora si verifichino le seguenti condizioni:
  • Gli utenti non utilizzeranno Outlook 2003 in modalità cache di Exchange.
  • Gli utenti utilizzeranno una versione precedente di Outlook.
  • Gli utenti utilizzeranno un altro client MAPI.
Nell'elenco seguente sono incluse alcune indicazioni generali per pianificare l'ambiente del server di Exchange:
  • Assicurarsi che il server di Exchange disponga di sufficiente capacità per la CPU e di sufficiente larghezza di banda per le operazioni I/O del disco così da poter gestire il carico che si aggiungerà quando gli utenti utilizzeranno i motori di ricerca desktop. L'esatto effetto sulle prestazioni dell'ambiente deve essere misurato e confrontato con i parametri di base delle prestazioni. Per ulteriori informazioni su come raccogliere informazioni sulle prestazioni e su come creare un parametro di base, vedere i seguenti siti Web Microsoft (informazioni in lingua inglese):
  • Poiché i tempi e la frequenza di indicizzazione sono controllati dal client e non dal server, quest'ultimo potrebbe mostrare un incremento dell'utilizzo della CPU e picchi nelle operazioni I/O del disco. In un ambiente di Exchange esistente, è possibile utilizzare tali picchi per calcolare con approssimazione quando si verificano le attività di indicizzazione. Quindi è possibile pianificare conseguentemente gli aggiornamenti delle prestazioni del server di Exchange. Se si sta realizzando un nuovo ambiente server di Exchange, è possibile creare un laboratorio per testare l'effetto di più client che eseguono attività di indicizzazione del contenuto degli archivi di cassette postali. È possibile utilizzare i risultati di questo test per pianificare le specifiche delle prestazioni del server di Exchange. Quando si realizza un nuovo ambiente server di Exchange, si potrebbero programmare dei gruppi di computer client affinché eseguano l'indicizzazione del contenuto così da bilanciare il carico di prestazioni sul server di Exchange.
  • Monitorare l'utilizzo della memoria sul server. Per ulteriori informazioni, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
  • Monitorare la frammentazione della memoria virtuale sul server.
  • Monitorare eventuali messaggi con ID evento 9646 sul server. I messaggi con ID evento 9646 vengono registrati quando un motore di ricerca su un computer client apre molti oggetti sul server. Per ulteriori informazioni sui messaggi con ID evento 9646, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    830829 Possibile blocco del computer che esegue Exchange Server 2003 dopo l'apertura da parte di un client MAPI di un numero di oggetti server specifici superiore al valore predefinito

Metodo 3: Impedire agli utenti di utilizzare i motori di ricerca desktop

È possibile utilizzare i criteri software sul lato client per impedire agli utenti di utilizzare i motori di ricerca desktop.

Metodo 4: Attivazione dell'indicizzazione Exchange del contenuto

È consigliabile prendere in considerazione i vantaggi derivanti dall'attivazione dell'indicizzazione Exchange del contenuto. Talvolta può accadere che, se si attiva l'indicizzazione Exchange del contenuto, i risultati delle ricerche sono più veloci quando le ricerche vengono effettuate a fronte del contenuto delle cassette postali rispetto a quando si utilizza un motore di ricerca desktop sul computer client.
Riferimenti
Per ulteriori informazioni su come isolare i problemi di prestazioni, consultare la guida Troubleshooting Exchange Server 2003 Performance, reperibile sul seguente sito Web Microsoft (informazioni in lingua inglese):
Proprietà

ID articolo: 905184 - Ultima revisione: 11/26/2007 01:39:00 - Revisione: 2.3

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft Outlook 97 Standard Edition
  • kbexchtechbulletin KB905184
Feedback