Come installare e aggiornare .NET Framework 1.1 in sistemi operativi diversi

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 915756
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sommario
pacchetti di installazione informazioni sulle due tipi di Microsoft .NET Framework 1.1: pacchetti di Gestione componenti facoltativi (OCM) e pacchetti di Microsoft Windows Installer (MSI). Il tipo di pacchetto che consente di installare e aggiornare .NET Framework 1.1 dipende dal sistema operativo in esecuzione. In questo articolo contiene un elenco completo di sistemi operativi Microsoft e il tipo di pacchetto di installazione di .NET Framework 1.1 è necessario disporre per installare e aggiornare il computer.
INTRODUZIONE
In questo articolo vengono descritti i due tipi di pacchetti di .NET Framework 1.1 e il tipo di pacchetto da utilizzare per installare o aggiornare il computer. Il seguente due varianti di pacchetti di .NET Framework 1.1 esistono:
  • Pacchetti di installazione e aggiornamento di facoltativi OCM (componente Manager)
  • Pacchetti di installazione e aggiornamento di Microsoft Windows Installer (MSI)
Pacchetti di installazione di OCM vengono installati automaticamente quando viene installato il sistema operativo. Pacchetti di installazione MSI vengono installati separatamente. In genere, i pacchetti di installazione MSI vengono installati per scaricare il pacchetto MSI dal sito Web Microsoft Update.

Non è possibile installare un pacchetto MSI di .NET Framework 1.1 in un computer che è la versione OCM di .NET Framework 1.1. È anche vero il contrario. Non è possibile installare un pacchetto OCM in un computer dotato di versione di .NET Framework 1.1 installato MSI. Di conseguenza, quando si installa o aggiornamento di .NET Framework 1.1, è necessario assicurarsi di scaricare e installare il tipo di pacchetto corretto.

Pacchetti di aggiornamento .NET Framework 1.1 OCM includere in genere, il nome di sistema operativo nel nome dell'aggiornamento. Ad esempio, "Aggiornamento per Windows Server 2003" è un pacchetto di aggiornamento OCM per Microsoft Windows Server 2003 (32-bit). Tuttavia, i pacchetti di aggiornamento MSI di .NET Framework 1.1 includono in genere il numero di versione di .NET Framework nel nome dell'aggiornamento. Ad esempio, "Aggiornamento per .NET Framework 1.1" è un pacchetto di aggiornamento MSI applicabili a diversi sistemi operativi.

È possibile utilizzare il language pack di .NET Framework 1.1 con i pacchetti di installazione di OCM e MSI. È inoltre possibile utilizzare il Software Development Kit (SDK) di .NET Framework 1.1 con i pacchetti di installazione di OCM e MSI.
Informazioni
Nelle sezioni riportate di seguito specificare il tipo di pacchetto .NET Framework 1.1 è supportato in ogni sistema operativo.

OCM di .NET framework 1.1 sistemi operativi supportati

I seguenti sistemi operativi utilizzare il tipo di pacchetto OCM:
  • Windows Server 2003 (32 bit x 86)
    • Windows Server 2003, Standard Edition (32 bit x 86)
    • Windows Server 2003, Enterprise Edition (32 bit x 86)
    • Windows Server 2003, Datacenter Edition (32 bit x 86)
    • Windows Server 2003, Web Edition
Nota Se si tenta di installare un pacchetto MSI di .NET Framework 1.1 in Windows Server 2003 a 32 bit x 86 Edition, è visualizzato il seguente messaggio di errore:
La patch di aggiornamento Impossibile installare il servizio Windows Installer perché il programma da aggiornare potrebbe essere manca o la patch di aggiornamento può aggiornare una versione diversa del programma. Consente di verificare che il programma da aggiornare esista sul computer e che disporre la patch di aggiornamento corretta.

.NET framework 1.1 MSI sistemi operativi supportati

Utilizzare il tipo di pacchetto MSI per installare o aggiornare .NET Framework 1.1 nei seguenti sistemi operativi:
  • Microsoft Windows 98 Seconda edizione
  • Microsoft Windows Millennium Edition
  • Microsoft Windows NT 4.0
    • Windows NT Workstation 4.0
    • Windows NT Server 4.0
  • Microsoft Windows 2000
    • Windows 2000 Professional
    • Windows 2000 Server
    • Windows 2000 Advanced Server
  • Microsoft Windows XP (32 bit x 86)
    • Windows XP Home Edition
    • Windows XP (32 bit x 86)
    • Windows XP Tablet PC Edition
    • Windows XP Media Center Edition
    Nota Se si tenta di installare un pacchetto di OCM di .NET Framework 1.1 in un computer basato su Windows 2000 o in un Windows XP (32 bit x 86) - basata su computer, che è visualizzato il seguente messaggio di errore:
    Versione di Windows installata non corrisponde all'aggiornamento che tentando di installare.
  • Edizioni di Windows XP x 64
    • Professional x 64 Edition
    Nota .NET Framework 1.1 non è supportato nei computer basati su Windows XP 64-Bit Edition 2003.
  • Windows Server 2003 x 64
    • Windows Server 2003 x 64 Standard Edition
    • Windows Server 2003 x 64 Enterprise Edition
    • Windows Datacenter Server 2003 x 64 Edition
    Nota Se si tenta di installare un pacchetto di aggiornamento OCM di .NET Framework 1.1 in un computer basato su Itanium o su un computer che esegue una versione di x 64 di Windows, viene visualizzato il seguente messaggio di errore:
    Questo KB IncidentNumber è per una piattaforma hardware diverso.
    Nota IncidentNumber rappresenta il numero di incidenti KB.
  • Windows Server 2003 Service Pack 1 per sistemi basati su Itanium
    • Windows Server 2003 Enterprise Edition per sistemi basati su Itanium
    • Windows Server 2003 Datacenter Edition per sistemi basati su Itanium

      Nota Entrambi questi sistemi operativi necessario dispongono di Windows Server 2003 Service Pack 1 prima di installare .NET Framework 1.1.
Riferimenti

Informazioni generali di .NET Framework

Per ulteriori informazioni sui vantaggi di .NET Framework, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
829019Vantaggi di Microsoft .NET Framework
Per domande frequenti su Microsoft .NET Framework, il seguente sito MSDN (informazioni in lingua inglese) Web:Per informazioni generali su Microsoft .NET Framework, visitare il seguente sito Web MSDN:

Informazioni di installazione di .NET Framework

Per ulteriori informazioni sulle differenze tra i pacchetti OCM e MSI per .NET Framework, visitare il sito di Web di Microsoft:Per ulteriori informazioni sulla risoluzione dei problemi di installazione .NET Framework 1.1 in Microsoft Windows Server 2003, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
830646Risoluzione dei problemi di installazione Microsoft .NET Framework 1.1 in Microsoft Windows Server 2003
Per ulteriori informazioni sulla risoluzione dei problemi di installazione .NET Framework 1.1 in altri sistemi operativi, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824643Risoluzione dei problemi di installazione Microsoft .NET Framework 1.1 in Windows XP o in Windows 2000

Informazioni per i computer a 64 bit e la basati su Itanium e .NET Framework

Per ulteriori informazioni sui computer a 64 bit e .NET Framework, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
907750Versioni di .NET Framework, Visual Studio e Visual Studio .NET sono supportate su computer a 64 bit
Per ulteriori informazioni sulle prestazioni e scalabilità per computer basati su Itanium in .NET Framework, visitare il sito di Web di Microsoft:Per ulteriori informazioni su un problema di compatibilità IIS con ASP.NET 1.1 su un computer a 64 bit, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
895967Come configurare l'identità del processo per l'account ASPNET in ASP.NET 1.1 quando si utilizza la modalità di isolamento di IIS 5 in IIS 6.0 in Windows Server 2003
895976Windows Server 2003 S895976 consente di compatibilità di WOW64 per applicazioni Web in IIS 6.0 a 32 bit
894435Come passare tra le versioni a 32 bit di ASP.NET 1.1 e quella a 64 bit di ASP.NET 2.0 in una versione a 64 bit di Windows
895963Come sopprimere il messaggio Appshelp visualizzato quando si installa il file ridistribuibile di .NET Framework 1.1 in versioni a 64 bit di Windows

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 915756 - Ultima revisione: 12/09/2015 04:55:52 - Revisione: 1.4

Microsoft .NET Framework 1.1

  • kbnosurvey kbarchive kbmt kbinstallation kbdeployment kberrmsg kbhowto kbinfo KB915756 KbMtit
Feedback