Messaggio di errore quando si tenta di visualizzare il calendario di servizio in Microsoft Dynamics CRM 3.0: "è stata generata un'eccezione non gestita durante l'esecuzione della richiesta web corrente"

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importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756Come eseguire il backup e il ripristino del Registro di sistema in Windows


L'hotfix descritto in questo articolo non è disponibile per la versione cinese di Microsoft Dynamics CRM o per la versione giapponese di Microsoft Dynamics CRM.
Sintomi
Non è possibile visualizzare il calendario servizi in Microsoft Dynamics CRM 3.0. Inoltre, viene visualizzato il seguente messaggio di errore:
Durante l'esecuzione della richiesta web corrente è stata generata un'eccezione non gestita. Informazioni sulla posizione dell'eccezione e origine possono essere identificate utilizzando l'analisi dello stack dell'eccezione riportata di seguito.
Cause
Questo problema si verifica quando ore impostare in Microsoft Dynamics CRM 3.0 e una delle seguenti condizioni è vera:
  • È possibile modificare fuso orario del computer.
  • Si modifica da ora legale all'ora solare oppure modificare dall'ora solare all'ora legale.
Risoluzione
Questo problema è stato risolto nell'aggiornamento cumulativo 1 per Microsoft Dynamics CRM 3.0. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
922815L'aggiornamento cumulativo 1 per Microsoft Dynamics CRM 3.0 è disponibile
Informazioni
avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Per attivare l'hotfix, aggiungere il valore di ForceTimeZone DWORD alla seguente sottochiave del Registro di sistema:
HKLM\Software\Microsoft\MSCRM
Il valore DWORD ForceTimeZone deve avere un valore decimale 1. Per aggiungere il valore di DWORD ForceTimeZone, attenersi alla seguente procedura:
  1. Sul server Microsoft Dynamics CRM, fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Fare clic con il pulsante destro del mouse sulla chiave del Registro di sistema HKLM\Software\Microsoft\MSCRM , fare clic su Nuovo e quindi fare clic su valore DWORD .
  3. Digitare ForceTimeZone e quindi premere INVIO.
  4. Fare doppio clic su ForceTimeZone digitare 1 nella casella dati valore e quindi fare clic su OK .
Questo aggiornamento rapido (hotfix) per correggere il problema in futuro. Tuttavia, potrebbe essere necessario correggere manualmente alcuni record di calendario. È necessario correggere alcuni record di calendario manualmente se si riceve i messaggi di errore seguente quando si sceglie di Ore di lavoro dopo aver aperto un record utente in Microsoft Dynamics CRM.
Messaggio di errore 1
Richiesta SOAP non riuscita:
>Url:http://n30/MSCRMServices/calendar.asmx
>MethodName: Espandi
Risposta >: >
<? xml version = "1.0" codifica = "utf-8"? > >
<xmlns:xsd="http://www.w3.org/2001/XMLSchema"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" di soap: Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" >
><soap:Body>
><soap:Fault>
><faultcode>: Server soap </faultcode>
><faultstring> System.Web.Services.Protocols.SoapException: Impossibile elaborare la richiesta.---&gt; System.InvalidOperationException: ricorrenza relativo generato un intervallo che non è contenuto nell'ambito. >in Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (TimeIntervalCollection ambiti) >
Messaggio di errore 2
>CrmSoapExtension rilevato non di CrmException - report verrà inviato a Watson: System.Web.Services.Protocols.SoapException: Impossibile elaborare la richiesta. ---> System.InvalidOperationException: ricorrenza relativo generato un intervallo che non è contenuto nell'ambito. in Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (TimeIntervalCollection ambiti) in Microsoft.Crm.Scheduling.Engine.LeafCalendarRule.ExpandRecurrence (TimeIntervalCollection effectiveScopeIntervals, TimeIntervalCollection instanceIntervals effectiveTimeZoneCode Int32) in Microsoft.Crm.Scheduling.Engine.CalendarRule.Expand (TimeIntervalCollection scopeIntervals, TimeIntervalCollection instanceIntervals fallbackTimeZoneCode Int32)
Nota Viene visualizzato di questi messaggi di errore se si attiva l'impostazione DevErrors o se si esamina i file di registro traccia di piattaforma.

Per risolvere immediatamente questo problema, contattare il servizio di supporto clienti Microsoft. Per un elenco completo di numeri di telefono del supporto tecnico clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft: Nota in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Supporto Tecnico Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
887283Aggiornamenti e hotfix software Microsoft Business Solutions CRM standard di denominazione dei pacchetti
crm3.0 crm30 CRM3

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Proprietà

ID articolo: 917545 - Ultima revisione: 12/09/2015 05:24:03 - Revisione: 4.3

Microsoft CRM 3.0

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