Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore quando si cerca di passare alla modalità non in linea in un computer client laptop che esegue Microsoft Dynamics CRM 3.0: "Spostamento dei dati per l'entità non riuscito"

L'hotfix esaminato in questo articolo non è disponibile per le versioni in lingua cinese e giapponese di Microsoft Dynamics CRM.
Sintomi
Quando si cerca di passare alla modalità non in linea in un computer client laptop che esegue Microsoft Dynamics CRM 3.0, l'operazione ha esito negativo. Viene visualizzato un messaggio di errore analogo al seguente:
Spostamento dei dati per l'entità 'nome_entità' durante l'azione salnsert non riuscito, countRows=1. Contattare l'amministratore di sistema e riprovare l'attivazione della modalità fuori rete.
Il seguente messaggio di errore, inoltre, viene registrato nel registro applicazione del computer client laptop:

Tipo evento: Errore
Origine evento: MSCRMOfflineSync
Categoria evento: Nessuna
ID evento: 6000
Data: data
Ora: ora
Utente: nome_utente
Computer: nome_computer

Descrizione:

Si è verificato un errore durante la sincronizzazione non in linea. Riprovare l'attivazione della modalità fuori rete o riavviare Microsoft Outlook. L'azione saInsert non è riuscita per l'entità 'Account', batchRows=0 con l'eccezione System.Data.SqlClient.SqlException: Inserimento di massa non riuscito. Il file di dati contiene una colonna troppo lunga per la riga 1, colonna 71. Verificare che i caratteri di terminazione di campo e di riga siano specificati correttamente.

Errore del provider OLE DB 'STREAM'. Il provider non ha fornito informazioni sull'errore.
Traccia di errore OLE DB [Provider OLE DB 'STREAM' IRowset::GetNextRows ha restituito 0x80004005: Il provider non ha fornito informazioni sull'errore.].
L'istruzione è stata interrotta.
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at Microsoft.Crm.Application.Outlook.OfflineSync.Utility.ExecuteSql(String strCommand, CrmDbConnection dbConnection)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.PopulateTempTable(String tempTableName, String fileName, CrmDbConnection dbConnection, Int32 count, String formatFile)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsertTable(EntityMetadata entity, String fileName, Int32 count, Boolean extension, String attributes)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsert(EntityMetadata entity, String fileName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert(String entityName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows).

Cause
Questo problema si verifica in presenza delle seguenti condizioni:
  • È stato aggiunto un campo attributo personalizzato che utilizza il tipo NTEXT per il modulo principale di un'entità.
  • Il campo attributo personalizzato in un record correlato contiene più di 4.000 caratteri.
Risoluzione
Per risolvere il problema, attenersi alla seguente procedura:
  1. Installare l'hotfix descritto in questo articolo.
  2. Installare l'hotfix per Microsoft SQL Server descritto nel seguente articolo della Microsoft Knowledge Base:
    923327 FIX: Quando si importano i dati utilizzando il comando "Inserimento di massa" in SQL Server 2000 può venire visualizzato un messaggio di errore di violazione di accesso
    Note
    • Installare l'hotfix descritto in questo articolo in ogni workstation client nell'istanza NomeComputer\CRM di SQL Server.
    • L'hotfix espone un bug di Microsoft SQL Server nel processo di inserimento di massa. È necessario risolvere il bug contemporaneamente all'installazione dell'hotfix.
  3. Dopo l'installazione dei due hotfix, eliminare il contenuto della seguente cartella prima di disconnettersi:
    C:\Documents and Settings\<utente client laptop crm>\Application Data\Microsoft\MSCRM\BCP\FMT\
Nota Il segnaposto <utente client laptop crm> rappresenta l'utente client laptop CRM effettivo.

Informazioni sull'hotfix

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicarlo solo ai sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguite ulteriori verifiche. Se il problema in questione non costituisce una seria minaccia per il sistema, si consiglia pertanto di attendere il rilascio del prossimo service pack di Microsoft Dynamics CRM 3.0 contenente questo hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.

Client Microsoft Dynamics CRM 3.0 Professional Edition per provider di servizi per Microsoft Office Outlook

Nome fileVersione fileDimensioni fileDataOra
Microsoft.crm.application.outlook.offlinesync.dll3.0.5745.103083.30419.01.200711.06

Client Microsoft Dynamics CRM 3.0 per Microsoft Office Outlook

Nome fileVersione fileDimensioni fileDataOra
Microsoft.crm.application.outlook.offlinesync.dll3.0.5300.127880.76028.08.200613.42

Informazioni sull'installazione

Installare questo hotfix sui computer client laptop che eseguono componenti client di Microsoft Dynamics CRM 3.0 o di Microsoft Dynamics CRM 3.0 Professional Edition per provider di servizi.

Prerequisiti

Non esistono prerequisiti per l'applicazione di questo hotfix.

Informazioni sulla rimozione

Per rimuovere questo hotfix da un computer che esegue Microsoft Windows 2000, Microsoft Windows XP o Microsoft Windows Server 2003, aprire Installazione applicazioni dal Pannello di controllo.

Per la stessa operazione, gli amministratori di sistema possono utilizzare l'utilità Spuninst.exe che si trova nella cartella seguente:
%Windir%\$NTUninstallKB918108$\Spuninst
Per ulteriori informazioni sui parametri del programma di installazione pacchetti, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
832475 Descrizione delle nuove funzionalità del programma di installazione pacchetti per gli aggiornamenti software di Windows

Richiesta di riavvio

Se richiesto, riavviare il computer dopo avere installato questo hotfix.
Status
Questo problema è stato corretto nell'aggiornamento cumulativo 1 per Microsoft Dynamics CRM 3.0. Tale aggiornamento cumulativo, tuttavia, non è ancora disponibile per Microsoft Dynamics CRM 3.0 Professional Edition per provider di servizi. È pertanto necessario installare l'hotfix se si utilizza Microsoft Dynamics CRM 3.0 Professional Edition per provider di servizi.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
922815 Aggiornamento cumulativo 1 disponibile per Microsoft Dynamics CRM 3.0
Informazioni
Se, dopo l'installazione dell'hotfix, permane il problema descritto nella sezione "Sintomi", fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
916165 Messaggio di errore quando si cerca di passare alla modalità non in linea nel client per laptop di Microsoft Dynamics CRM per Outlook: "Impossibile spostare i dati per l'entità <NomeEntità> durante l'azione saInsert, countRows=<NumeroConteggio>"
Riferimenti
Per ulteriori informazioni sulla terminologia utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
887283 Standard di denominazione dei pacchetti di aggiornamenti e hotfix del software Microsoft Business Solutions CRM
crm3 crm30 crm3.0
Proprietà

ID articolo: 918108 - Ultima revisione: 06/13/2007 12:41:44 - Revisione: 7.3

  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
  • Microsoft Dynamics CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook
  • kbcrmv3cno kberrmsg kbbug kbmbscustomization kbhotfixserver kbqfe kbmbsmigrate kbpubtypekc KB918108
Feedback