Download di un file di grandi dimensioni si interrompe quando un computer client ISA Server 2004 SOCKS o un computer client ISA Server 2006 SOCKS utilizza la modalità FTP passiva

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

923322
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Quando un computer di client FTP scarica un file di grandi dimensioni utilizzando la modalità FTP passiva, nel download viene non una riesce se richiede più di 120 secondi.
Cause
Questo problema può verificarsi se le seguenti condizioni sono vere:
  • Il computer del client FTP è configurato per utilizzare il SOCKS protocollo.
  • Il computer del client FTP utilizza Microsoft Internet Security e di un Acceleration (ISA) Server 2004 o di una Microsoft Internet Security and di un'Acceleration (ISA) Server 2006 per l'accesso in uscita a FTP passivo.
  • Il valore di timeout connessione inattiva in ISA Server 2004 o ISA Server 2006 è impostato sul valore predefinito di 120 secondi.
Modalità passiva FTP utilizza una connessione canale di controllo in uscita e una connessione canale di dati in uscita. La trasmissione di file si verifica attraverso il canale di dati. Il canale di controllo FTP timeout se le seguenti condizioni sono true:
  • I dati non vengono inviati attraverso il canale di controllo durante l'operazione di download.
  • Un download di file di modalità passiva FTP richiede più di 120 secondi.
Quindi, il server FTP interrompe l'operazione di download del file.
Risoluzione
Per risolvere questo problema, è necessario ottenere il service pack più recente per ISA Server 2004 e ISA Server 2006.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
954258Come ottenere la versione più recente Internet Security and Acceleration (ISA) Server 2006 del service pack
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
891024Come ottenere il service pack più recente per ISA Server 2004
Dopo avere installato il service pack appropriato, è necessario eseguire lo script di Microsoft Visual Basic riportato di seguito per configurare il valore di timeout connessione inattiva filtro SOCKS su un valore appropriato.

Nota Per determinare il valore di timeout appropriato, utilizzare la seguente equazione:
Timeout (seconds) = file size / download speed * 1.2
Ad esempio, per determinare il valore di timeout appropriato per scaricare un file (MB) di 200 MB a 1 megabit al secondo (Mbps), è possibile utilizzare la seguente equazione:
 200*8 / 1 * 1.2 = 1920 seconds
È necessario calcolare il valore da utilizzare singolarmente.

Nota L'impostazione del timeout connessione inattiva consente di liberare le risorse inutilizzate affinché non si verificano problemi relativi alla risorsa. È pertanto consigliabile non aumentare il timeout impostazione inutilmente. Se si utilizza un'impostazione di timeout che è minore del valore predefinito di 120 secondi, è inoltre possibile creare problemi imprevisti.

Per modificare l'impostazione di timeout, attenersi alla seguente procedura:

Nota È necessario installare il service pack appropriato prima di visitare questi passaggi.
  1. Fare clic su Start , scegliere tutti i programmi , Accessori e quindi fare clic su Blocco note .
  2. Copiare e incollarvi il codice riportato di seguito un nuovo documento. Salvare quindi il codice al computer basato su ISA Server 2004 o al computer ISA Server 2006. A tal fine, utilizzare un nome di file che dispone di un'estensione vbs, ad esempio SetSocksIdleTimeout.vbs .
    '''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''' Copyright (c) Microsoft Corporation. All rights reserved.' THIS CODE IS MADE AVAILABLE AS IS, WITHOUT WARRANTY OF ANY KIND. THE ENTIRE' RISK OF THE USE OR THE RESULTS FROM THE USE OF THIS CODE REMAINS WITH THE' USER. USE AND REDISTRIBUTION OF THIS CODE, WITH OR WITHOUT MODIFICATION, IS' HEREBY PERMITTED.''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''' This script sets the idle connection time-out value for the SOCKS filter.' The value is in seconds.''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''Sub SetSocksIdleTimeout()    ' Create the root object.    Dim root  ' The FPCLib.FPC root object    Set root = CreateObject("FPC.Root")    'Declare the other objects needed.    Dim array       ' An FPCArray object    Dim Extensions  ' An FPCExtensions object    Dim ApplicationFilters ' An FPCApplicationFilters object    Dim ApplicationFilter  ' An FPCApplicationFilter object    Dim VendorSets  ' An FPCVendorParametersSets collection    Dim VendorSet   ' An FPCVendorParametersSet object    ' Get references to the array object    Set array = root.GetContainingArray    On Error Resume Next    Set Extensions = array.Extensions    CheckError    Set ApplicationFilters = Extensions.ApplicationFilters    CheckError    Set ApplicationFilter = ApplicationFilters.Item("{25765C04-C80B-494C-914E-286297DB8C8E}")    Set VendorSets = ApplicationFilter.VendorParametersSets    Set VendorSet = VendorSets.Item( "{25765C04-C80B-494C-914E-286297DB8C8E}" )    VendorSet.Value("SessionIdleTimeoutSeconds") = 120 ' value in seconds to be set to desired value    ApplicationFilter.Save false, true    WScript.Echo "Done..."End SubSub CheckError()    If Err.Number <> 0 Then        WScript.Echo "An error occurred: 0x" & Hex(Err.Number) & " " & Err.Description        Err.Clear    End IfEnd SubSetSocksIdleTimeout
  3. Questo script utilizza il valore di timeout predefinito di 120 secondi. Modificare l'impostazione che si desidera il valore di timeout e quindi salvare lo script.
  4. Fare doppio clic sul file vbs per eseguire lo script.
Dopo aver eseguito questo script, il nuovo valore di timeout viene applicato a nuove connessioni SOCKS effettuate tramite ISA Server 2004 o tramite ISA Server 2006.

Per modificare il valore di timeout predefinito, modificare il valore a 120 secondi lo script, salvare le modifiche e quindi eseguire nuovamente lo script.
Workaround
Per aggirare il problema, configurare il programma FTP per inviare comandi "keep-alive" sul canale di controllo FTP.

Per informazioni su se il programma FTP utilizzato supporta questa funzionalità, vedere la documentazione per il programma FTP.
Status
Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".
Riferimenti
Per ulteriori informazioni sull'installazione di ISA Server hotfix e aggiornamenti di ISA Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
885957Come installare ISA Server hotfix e aggiornamenti

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 923322 - Ultima revisione: 01/16/2015 01:59:47 - Revisione: 2.0

  • Microsoft Internet Security and Acceleration Server 2004 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2004 Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2006 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2006 Enterprise Edition
  • kbnosurvey kbarchive kbmt kbtshoot kbexpertiseadvanced kbqfe kbprb KB923322 KbMtit
Feedback