Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore durante la riproduzione di un file in Windows Media Player su un computer basato su Windows Vista: "Formato di file non valido. (Errore=8004022F)"

Sintomi
Si utilizza Windows Media Player su un computer basato su Microsoft Windows Vista. Quando si tenta di riprodurre un file in Windows Media Player, è possibile che venga visualizzato uno o più dei seguenti messaggi di errore:
Messaggio di errore 1
Formato di file non valido. (Errore=8004022F)
Messaggio di errore 2
Impossibile riprodurre il file. Formato non supportato. (Errore=80040265)
Messaggio di errore 3
Impossibile riprodurre il flusso video. Non è stato trovato alcun decompressore adatto. (Errore=80040255)
Messaggio di errore 4
Impossibile trovare una combinazione di filtri per il rendering del flusso. (Errore=80040218)
Messaggio di errore 5
Impossibile caricare il filtro di origine per il file. (Errore=80040241)
Messaggio di errore 6
Impossibile aprire. Verificare che il percorso e il nome del file siano corretti, quindi riprovare (Errore=8007000D).
Cause
Questo problema può verificarsi in presenza di una qualsiasi delle seguenti condizioni:
  • Windows Media Player non supporta il formato di file o il codec del file multimediale che si tenta di riprodurre.
  • Alcuni dei file di Windows Media Player mancano o sono danneggiati.
  • Il file multimediale è danneggiato.
  • Il file multimediale utilizza un codec non installato.
  • Il computer non dispone di funzionalità audio. Ad esempio, nel computer non è installato alcun dispositivo audio.
  • Il driver corretto per il dispositivo audio non è installato oppure è disabilitato.
  • La funzionalità Desktop remoto non è configurata per la riproduzione audio.
Risoluzione
Per risolvere il problema, utilizzare i metodi illustrati di seguito nell'ordine in cui vengono presentati. Dopo l'esecuzione di ogni metodo verificare se il problema è stato risolto.

Importante Windows Media Player non supporta la riproduzione di qualsiasi tipo di file multimediale attualmente disponibile, tuttavia include il supporto per i tipi di file multimediali più comuni. Verificare pertanto che il tipo di file multimediale da riprodurre sia supportato. In caso contrario, non utilizzare altri metodi eccetto il Metodo 1 per risolvere il problema. Se Windows Media Player non supporta il formato di file utilizzato, contattare il distributore del file per verificare se è disponibile un visualizzatore specifico.

Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
156286 Messaggio di errore: Impossibile riprodurre il flusso video
195880 Messaggio di errore: Impossibile trovare una combinazione di filtri per il rendering...

Metodo 1: Verificare che Windows Media Player supporti il tipo di file che si desidera utilizzare

Per ulteriori informazioni sui tipi di file supportati, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
316992 Formati di file multimediali di Windows Media Player

Metodo 2: Determinare se il file che si desidera riprodurre è danneggiato

In Windows Media Player provare a riprodurre un file diverso ma con la stessa estensione del file che non è stato possibile riprodurre. Se l'altro file viene riprodotto correttamente, il file originale è probabilmente danneggiato. Se durante la riproduzione di altri file supportati si riscontra la stessa difficoltà, provare il Metodo 3.

Metodo 3: Reinstallare Windows Media Player

Disinstallare Windows Media Player, riavviare il computer e reinstallare il programma. A questo scopo, attenersi alla seguente procedura:
  1. Nel Pannello di controllo fare clic su Visualizzazione classica, quindi fare doppio clic su Programmi e funzionalità.
  2. Fare clic su Attivazione o disattivazione delle funzionalità Windows, quindi deselezionare la casella di controllo Windows Media Player.
  3. Seguire le istruzioni visualizzate per completare la rimozione.
  4. Dopo la rimozione di Windows Media Player, riavviare il computer.
  5. Per scaricare la versione più recente di Windows Media Player, visitare il seguente sito Web Microsoft:
  6. Fare clic su Scarica ora per ricevere la versione più recente di Windows Media Player, quindi scegliere Salva per salvare il file di installazione in una posizione familiare.
  7. Individuare il file di installazione, fare doppio clic su di esso per avviare il processo, quindi seguire le istruzioni per completare l'installazione.

Metodo 4: Reinstallare Microsoft DirectX o effettuare l'aggiornamento alla versione più recente

Per ulteriori informazioni sulla reinstallazione o sull'aggiornamento di DirectX, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
157730 Determinazione della versione di DirectX utilizzando lo strumento di diagnostica DirectX
179113 Istruzioni per scaricare e installare DirectX

Metodo 5: Verificare che sia in uso il codec corretto per il file multimediale

Per ulteriori informazioni sull'installazione, la verifica e la risoluzione dei problemi relativi ai codec multimediali, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
843509 Domande frequenti sulla risoluzione dei problemi in Windows Media Player
230687 Messaggio di errore: Impossibile scaricare il programma di decompressione appropriato
191533 Impossibile riprodurre un file .avi con Media Player utilizzando il codec Indeo 4.x
Informazioni
Per ulteriori informazioni su Windows Media Player, visitare il seguente sito Web Microsoft (informazioni in lingua inglese): Per una versione di questo articolo per Microsoft Windows XP, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
234019 Messaggio di errore di formato file non valido di Windows Media Player
Proprietà

ID articolo: 924073 - Ultima revisione: 01/05/2011 05:41:00 - Revisione: 2.0

Microsoft Windows Media Player 10, Microsoft Windows Media Player 11

  • kbexpertisebeginner kbtshoot kbprb KB924073
Feedback
>