Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore "Errore. Codice: 0x80240029" quando si tenta di aggiornare Windows Defender in un computer basato su Windows Vista

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Il supporto per Windows Server 2003 è terminato il 14 luglio 2015.

Microsoft ha sospeso il supporto per Windows Server 2003 in data 14 luglio 2015. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

-

Per continuare a ricevere gli aggiornamenti della protezione per Windows, assicurarsi di eseguire Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento a questa pagina Web Microsoft: Per alcune versioni di Windows il servizio di supporto non è più disponibile

Sintomi
Quando si tenta di aggiornare Microsoft Windows Defender in un computer basato su Windows Vista, viene visualizzato un messaggio di errore analogo al seguente:
Errore. Codice: 0x80240029
Cause
Questo problema si verifica se la cartella SoftwareDistribution è danneggiata.
Risoluzione
Per risolvere il problema, accedere al computer con un account utente dotato di privilegi amministrativi, quindi utilizzare uno dei seguenti metodi:

Metodo 1
  1. Uscire da tutti i programmi aperti. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, digitare Esegui nella casella Inizia ricerca, quindi premere INVIO.
    2. Digitare msconfig, quindi scegliere OK.

      Verrà visualizzata l'Utilità Configurazione di sistema.
    3. Nella scheda Avvio fare clic per selezionare la casella di controllo Modalità provvisoria e la casella di controllo Minima, quindi scegliere OK.
    4. Riavviare il computer quando richiesto.

      Nota Dopo avere completato il passaggio 2, avviare di nuovo l'Utilità Configurazione di sistema. Nella scheda Avvio deselezionare la casella di controllo Modalità provvisoria, quindi scegliere OK per riavviare il computer.
  2. Rinominare la cartella SoftwareDistribution. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, digitare %windir% nella casella Inizia ricerca, quindi premere INVIO.

      Nota In questo passaggio %windir% rappresenta il percorso della cartella di sistema di Windows. In genere, C:\Windows è il percorso della cartella di sistema di Windows.
    2. Individuare e fare clic con il pulsante destro del mouse sulla cartella SoftwareDistribution, quindi scegliere Rinomina.
    3. Digitare SoftwareDistribution.old, quindi premere INVIO.
    4. Riavviare il computer.
Metodo 2
  1. Uscire da tutti i programmi aperti. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante StartPulsante					 Start, quindi digitare Servizi nella casella Inizia ricerca.
    2. Fare doppio clic su Servizi.
    3. Nell'elenco Servizi individuare Strumentazione gestione Windows, quindi fare clic con il pulsante destro del mouse su Interrompi.

      Nota Non chiudere la finestra Servizi.
    4. Aprire Esplora risorse.
    5. Individuare ed eliminare la cartella Repository in C:\%windir%\System32\wbem.
    6. Tornare alla finestra Servizi, individuare Strumentazione gestione Windows, quindi fare clic con il pulsante destro del mouse su Riavvia.
    7. Chiudere tutti i programmi.
    8. Riavviare il computer.
Proprietà

ID articolo: 934562 - Ultima revisione: 09/25/2011 09:36:00 - Revisione: 5.0

Windows Vista Home Basic, Windows Vista Home Premium, Windows Vista Ultimate, Windows Vista Business, Windows Vista Enterprise, Microsoft Windows XP Professional, Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)

  • kbexpertisebeginner kbtshoot KB934562
Feedback
ext/javascript" src="https://c.microsoft.com/ms.js">