Al momento sei offline in attesa che la connessione Internet venga ristabilita

Come utilizzare i Report Writer in Microsoft Dynamics GP 9.0 per creare un campo calcolato per mascherare il numero di previdenza sociale nel report dipendente controlla e nel report "Diretto deposito rendiconto delle entrate"

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 935619
INTRODUZIONE
In questo articolo viene descritto come utilizzare Microsoft Dynamics GP 9.0 Report Writer per creare un campo calcolato per mascherare il numero di previdenza sociale nel report dipendente controlla e nel report "Diretto deposito rendiconto delle entrate".
Informazioni
Per creare un campo calcolato per mascherare il codice fiscale del report di verifica dipendente o nel report "Diretto deposito rendiconto delle entrate", attenersi alla seguente procedura.

Nota Nell'esempio seguente viene utilizzato lo stub di controllo dipendente nel report Top-D.

Passaggio 1: Aprire il report

  1. Dal menu Strumenti , fare clic su Personalizzae quindi fare clic su Report Writer.
  2. Fare clic su Microsoft Dynamics GPe quindi fare clic su OK.
  3. Fare clic su report.
  4. Nell'elenco Rapporti modificati , fare clic sul report e quindi fare clic su Apri.

    Note
    • Se il report non è presente nell'elenco Rapporti modificati , fare clic sul report nell'elenco Rapporti originale e quindi fare clic su Inserisci. Quindi, eseguire il passaggio 4.
    • È possibile eseguire la procedura seguente per modificare qualsiasi rapporto dipendente controlla che utilizza il campo numero di previdenza sociale .

Passaggio 2: Creare un campo calcolato

  1. Nella finestra di definizione del Report, fare clic su Layout.
  2. Nella finestra Casella degli strumenti, fare clic su Campi calcolatie quindi fare clic su Nuovo.
  3. Nella casella nome , digitare SSN.
  4. Nell'elenco Tipo di risultato , fare clic su stringa.
  5. Nell'area Tipo di espressione , fare clic su calcolato.
  6. Fare clic sulla scheda costanti e quindi fare clic su stringa nella casella tipo .
  7. Nel campo costante , digitare il testo che si desidera mascherare il numero di previdenza sociale. Ad esempio, digitare ***-**-, o tipo XXX-XX -.
  8. Fare clic su Aggiungi.
  9. Nell'area di operatori , fare clic su CAT.
  10. Fare clic sulla scheda funzioni .
  11. Fare clic su Definito dall'utentee quindi fare clic su sistema nell'elenco principale .
  12. Nell'elenco funzione , fare clic su RW_Substringe quindi fare clic su Aggiungi.
  13. Fare clic sulla scheda campi .
  14. Nell'elenco risorse , fare clic su Verifica lavoro retribuzioni.
  15. Nell'elenco dei campi fare clic sul numero di previdenza socialee quindi fare clic su Aggiungi.
  16. Impostare il primo carattere della sottostringa. Quindi, impostare la lunghezza della sottostringa. Quando si aggiunge il campo numero di previdenza sociale , utilizzare il costante integer 6 e il costante integer 4, rispettivamente. A tale scopo, attenersi alla seguente procedura.

    Nota È necessario aggiungere queste informazioni quando si utilizza la funzione RW_Substring .
    1. Fare clic sulla scheda costanti .
    2. Nell'elenco tipo , fare clic su intero.
    3. Nel campo costante , digitare 6, quindi fare clic su Aggiungi.
    4. Nel campo costante , digitare 4, quindi fare clic su Aggiungi.

      L'espressione calcolata creata è simile al seguente:
      "XXX - XX-" # funzione SCRIPT (RW_Substring UPR_WORK_Check.Social numero 4 di 6)
  17. Per salvare il campo calcolato, fare clic su OK.

Passaggio 3: Aggiungere il campo calcolato al report

  1. Nella sezione corpo del report, eliminare il campo numero di previdenza sociale .
  2. Nella finestra Casella degli strumenti, fare clic su SSN nell'elenco risorse .
  3. Per la sezione corpo del report, trascinare SSN .
  4. È possibile modificare la dimensione del carattere nel report. A tale scopo, fare clic su Opzioni disegno dal menu Strumenti .

Passaggio 4: Salvare il report modificato

  1. Chiudere il report.
  2. Quando viene chiesto di salvare le modifiche, fare clic su Salva.
  3. Nella finestra di definizione del Report, fare clic su OK.
  4. Dal menu File , fare clic su Microsoft Dynamics GP.

Passaggio 5: Assegnare le autorizzazioni di protezione per il report modificato

Metodo 1: utilizzando lo strumento di protezione avanzata

  1. Dal menu Strumenti , scegliere il programma di installazione, scegliere sistemae quindi fare clic su Protezione avanzata.
  2. Se richiesto, digitare la password di sistema.
  3. Fare clic su Visualizzae quindi per alternativo, modificato e personalizzato.
  4. Espandere Microsoft Dynamics GP.
  5. Espandere rapporti, espandere retribuzionie quindi fare clic su uno dei seguenti elementi:
    • Deposito diretto rendiconto dei ricavi
    • Controlli dipendente
  6. Fare clic su Microsoft Dynamics GP (modificato).
  7. Fare clic su Applicae quindi fare clic su OK.

    Nota Per impostazione predefinita, quando si avvia lo strumento di protezione avanzata, l'utente corrente e la società corrente vengono selezionati. Le modifiche apportate vengono applicate solo all'utente corrente e alla società corrente. Tuttavia, è possibile selezionare altri utenti nell'area utente della finestra di protezione avanzata. È inoltre possibile selezionare altre società nell'area della finestra di protezione avanzata della società .

Metodo 2: tramite la protezione di Microsoft Dynamics GP

  1. Dal menu Strumenti , scegliere il programma di installazione, scegliere sistemae quindi fare clic su protezione.
  2. Se richiesto, digitare la password di sistema.
  3. Nell'elenco di ID utente , fare clic sull'ID utente dell'utente che accederà al report.
  4. Nell'elenco tipo , fare clic su Modifica report.
  5. Nell'elenco serie , fare clic su retribuzioni.
  6. Nell'elenco Elenco di accesso , fare doppio clic su Diretta istruzione del deposito di profitti o Dipendente controlla. Quindi, fare clic su OK.

    Nota Dopo aver scelto OK, verrà visualizzato un asterisco accanto al nome del report.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 935619 - Ultima revisione: 12/14/2015 20:24:00 - Revisione: 0.1

Microsoft Dynamics GP 9.0, Payroll - U.S., Report Writer

  • kbnosurvey kbexpertiseinter kbinfo kbmbsmigrate kbhowto kbmt KB935619 KbMtit
Feedback