Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore o di utilizzo elevato della CPU quando si esegue un'applicazione basata su Windows Presentation Foundation WPF

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 937135
Sintomi
Quando si esegue un'applicazione basata su Windows Presentation Foundation WPF in di Microsoft.NET Framework 3.0, potrebbe essere visualizzato un errore FileFormatException o un errore ArgumentOutofRangeException. L'errore si verifica quando l'applicazione basata su WPF avvia l'elaborazione di testo. Ad esempio, riceverai un messaggio di errore FileFormatException analogo al seguente:
file:///FilePath/nome_file file non è conforme alle specifiche di formato file previste.
In questo messaggio di errore, nome_file è in genere il nome di file per un tipo di carattere. Inoltre, l'applicazione utilizza backup per il tempo della CPU al 100%.


Durante la ricerca in Task Manager o altri strumenti, PresentationFontCache.exe occupa più di 50% del tempo del processore disponibile.
Cause
Questo problema si verifica se il driver video di sovrascrivere i dati nella cache del tipo di carattere che viene memorizzato nella memoria.
Risoluzione
Per risolvere questo problema, attenersi alla seguente procedura:
  1. Chiudere tutte le applicazioni basate su WPF in eseguono sul computer.
  2. Arrestare il servizio Cache tipi di carattere di Windows Presentation Foundation 3.0.0.0. Per arrestare il servizio Windows Presentation Foundation Font Cache 3.0.0.0, utilizzare uno dei metodi descritti di seguito.

    Metodo 1: Utilizzare Microsoft Management Console
    1. Fare clic su Start, scegliere Esegui, tipo Services. msc, quindi scegliere OK.
    2. Cache tipi di carattere di Windows Presentation Foundation 3.0.0.0mouse e quindi fare clic su Interrompi.
    Metodo 2: Utilizzare il prompt dei comandi
    1. Fare clic su Start, scegliere Esegui, tipo cmd, quindi scegliere OK.
    2. Al prompt dei comandi, digitare net stop "Windows Presentation Foundation Cache tipi di carattere 3.0.0.0", quindi premere INVIO.
  3. Eliminare il vecchio file di Fontcache3.0.0.0.dat.

    Nota Per impostazione predefinita, il file Fontcache3.0.0.0.dat si trova nella cartella %windir%\ServiceProfiles\LocalService\AppData\Local in Windows Vista. Per impostazione predefinita, il file Fontcache3.0.0.0.dat si trova nella cartella Settings\LocalService\Local Settings\Application Data in Windows XP e nelle versioni precedenti di Windows %systemdrive%\Documents and.
  4. Aggiornare i driver di scheda video. A tale scopo, utilizzare uno dei metodi descritti di seguito.

    Metodo 1: Utilizzare catalogo di Windows Update

    Per aggiornare i driver di scheda video, controllare gli aggiornamenti nel catalogo di Windows Update. Per ulteriori informazioni su come scaricare i driver dal catalogo di Windows Update, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    323166 Come scaricare aggiornamenti e driver dal catalogo di Windows Update

    Metodo 2: Scaricare e installare i driver di scheda video più recenti

    Per scaricare e installare i driver di scheda video più recenti, contattare il computer o il produttore dell'hardware video.

    Per informazioni al produttore dell'hardware, visitare il seguente sito Web:
Informazioni
Se il driver della scheda video sovrascrive i dati nella cache del tipo di carattere che viene memorizzato nella memoria, possono salvare i dati danneggiati sul disco rigido come file di dati. Pertanto, si potrebbe verificarsi il problema descritto nella sezione "Sintomi" quando un'altra applicazione basata su WPF tenta di leggere il file di dati danneggiati.

Dopo che si aggiorna il driver della scheda video e dopo aver eliminato il file Fontcache3.0.0.0.dat, viene creato un nuovo file di dati della cache del tipo di carattere in base alla configurazione di computer nuovi. Questo nuovo file di dati della cache del tipo di carattere viene creato quando il servizio Cache tipi di carattere di Windows Presentation Foundation 3.0.0.0 viene arrestato. In genere, il nuovo file di dati della cache del tipo di carattere viene creato quando il computer viene arrestato o riavviato.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 937135 - Ultima revisione: 09/05/2015 07:14:00 - Revisione: 3.0

Microsoft .NET Framework 3.0

  • kbbug kbtshoot kbprb kbmt KB937135 KbMtit
Feedback