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Messaggio di errore quando si tenta di verificare l'accesso dal router di posta elettronica per Microsoft Dynamics CRM 4.0: "stato fax in ingresso: non riuscita - connessione sottostante chiusa: Impossibile stabilire la relazione di trust per il canale sicuro SSL/TLS"

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Sintomi
Configurare il router di posta elettronica Microsoft Dynamics CRM 4.0 per accedere a una cassetta postale che si trova su un server che esegue Exchange Server 2007. Quando si tenta di verificare l'accesso alla cassetta postale, viene visualizzato il seguente messaggio di errore:
Stato in ingresso: Non riuscita - connessione sottostante chiusa: Impossibile stabilire la relazione di trust per il canale sicuro SSL/TLS. Certificato remoto non valido in base alla procedura di convalida.
Questo problema si verifica se si utilizzano certificati autofirmati.
Cause
Questo problema si verifica per uno o più dei seguenti motivi:
Causa 1 Microsoft Dynamics CRM 4.0 router di posta elettronica utilizza le librerie di Microsoft .NET per la convalida dei certificati. Il router di posta elettronica di Microsoft Dynamics CRM 4.0 non supporta i certificati autofirmati.

Causa 2 L'URL specificato nel proprio profilo in ingresso nel router di posta elettronica CRM per Microsoft Dynamcis non corrisponde all'URL sono presenti i certificati del sito Web Microsoft Exchange.
Risoluzione
Risoluzione 1
Implementare un certificato firmato sul server che esegue Exchange Server 2007.

Risoluzione 2
Verificare l'URL specificato nel proprio profilo in ingresso nel router di posta elettronica Microsoft Dynamcis CRM corrispondente all'URL sono presenti i certificati del sito Web Microsoft Exchange.

Per verificare l'URL specificato per il profilo in ingresso per il router di posta elettronica Exchange per Microsoft Dynamics CRM, completare i seguenti passaggi sul computer in cui è installato il router di posta elettronica Exchange per Microsoft Dynamics CRM:
  1. Fare clic sul pulsante Start, scegliere tutti i programmi, fare clic su Router di posta elettronica di Microsoft Dynamics CRM e quindi fare clic su Microsoft CRM Email Router.exe.
  2. Fare clic sulla scheda Profili di configurazione, aprire il Profilo in ingresso e quindi annotare l'URL nel campo server.
Nota:Per verificare il certificato, copiare questo URL e incollarlo in un browser Internet Explorer. Il certificato è valido se non si ottengono eventuali errori o avvisi.

Per verificare quale URL sono presenti il certificato, attenersi alla seguente procedura in Windows 2008 Microsoft Exchange Server:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare Inetmgr e quindi fare clic su OK.
  2. Selezionare il server e quindi fare clic su Certificati Server nel Riquadro di anteprima.
  3. Aprire il certificato utilizzato per Microsoft Exchange Server.
  4. Annotare l'URL specificato nel certificato. Verificare che corrisponda all'URL specificato nel proprio profilo in ingresso nel router di posta elettronica Microsoft Dynamics CRM trovato nel passaggio 2 sopra indicato.


Per verificare quale URL sono presenti il certificato, attenersi alla seguente procedura in Windows 2003 Microsoft Exchange Server:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare Inetmgr e quindi fare clic su OK.
  2. Individuare il sito Web di Exchange.
  3. Fare clic con il pulsante destro del mouse sul sito Web di Exchange e quindi scegliere proprietà.
  4. Fare clic sulla scheda Protezione Directory, fare clic su Visualizza certificato e quindi annotare l'URL specificato nel certificato. Verificare che corrisponda all'URL specificato nel proprio profilo in ingresso nel router di posta elettronica Microsoft Dynamics CRM trovato nel passaggio 2 sopra indicato.
Informazioni
Esistono tre tipi principali di certificati digitali sono descritti di seguito:
  • I certificati autofirmati: un certificato autofirmato è firmato da un'applicazione. Il soggetto del certificato corrisponda al nome del certificato. L'autorità emittente e il soggetto vengono definiti nel certificato. Utilizzando un certificato autofirmato, alcuni protocolli client possono utilizzare SSL (Secure Socket Layer) per le comunicazioni.
  • I certificati generati dall'infrastruttura PKI di Windows: un'infrastruttura a chiave pubblica (PKI, Public Key INFRASTRUCTURE) è un sistema di certificati digitali, autorità di certificazione e Autorità di registrazione. L'infrastruttura a chiave pubblica utilizza la crittografia a chiave pubblica per verificare e autenticare la validità di tutte le parti viene utilizzata in una transazione elettronica. Quando si implementa un'autorità di certificazione in un'organizzazione che utilizza il servizio directory Active Directory, è necessario fornire un'infrastruttura per la gestione del ciclo di vita dei certificati, il rinnovo, gestione delle relazioni di trust e la revoca. Tuttavia, alcuni costi addizionali sono necessari per distribuire i server e l'infrastruttura per creare e gestire i certificati generati dall'infrastruttura PKI di Windows. Servizi certificati sono necessari per distribuire un'infrastruttura PKI di Windows. È possibile utilizzare l'elemento Installazione applicazioni nel Pannello di controllo per installare Servizi certificati su qualsiasi server nel dominio.

    Per ulteriori informazioni su PKI per Windows Server 2003, visitare il seguente sito Web Microsoft:Per ulteriori informazioni sulle procedure consigliate per l'implementazione di un'infrastruttura PKI di Windows, visitare il seguente sito Web Microsoft:Per ulteriori informazioni su come distribuire un'infrastruttura PKI basata su Windows, visitare il seguente sito Web Microsoft:
  • I certificati di terze parti: i certificati di terze parti o certificati commerciali sono certificati generati da un'autorità di certificazione di terze parti o da un'autorità di certificazione commerciale. Acquisto di questi certificati e quindi di utilizzare i certificati sui server. Client computer e dispositivi mobili non considerare automaticamente attendibili i certificati autofirmati e i certificati generati dall'infrastruttura PKI di Windows. Di conseguenza, è necessario importare i certificati nell'archivio dei certificati principali attendibili nei computer client e su dispositivi mobili. Tuttavia, la maggior parte dei certificati di terzi o certificati commerciali già esistono nell'archivio certificati principali attendibili. Di conseguenza, il processo di distribuzione viene semplificato dall'utilizzo di certificati di terze parti o certificati commerciali. Per le organizzazioni di grandi dimensioni o per le organizzazioni per il quale è necessario distribuire pubblicamente certificati utilizzando un certificato di terze parti o un certificato commerciale potrebbe essere una buona soluzione anche se si deve pagare per il certificato. Tuttavia, i certificati di terze parti o certificati commerciali non sia una buona soluzione per organizzazioni di piccole dimensioni o per organizzazioni di medie dimensioni. È possibile utilizzare altri tipi di certificati sono disponibili per le piccole organizzazioni e per le organizzazioni di medie dimensioni.
Riferimenti
Per ulteriori informazioni su come gestire SSL per un server di accesso client, visitare il seguente sito Web Microsoft:Per ulteriori informazioni su come configurare SSL certificati di utilizzare più nomi di client accesso server host, visitare il seguente sito Web Microsoft:Per ulteriori informazioni sull'installazione di SSL certificati su un dispositivo alimentato portatile Windows, visitare il seguente sito Web Microsoft:Per ulteriori informazioni su come configurare Outlook Web l'accesso alle directory virtuali per utilizzare SSL, visitare il seguente sito Web Microsoft:Per ulteriori informazioni sui certificati vengono utilizzati in Exchange Server 2007, visitare il seguente sito Web Microsoft:

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Proprietà

ID articolo: 954584 - Ultima revisione: 10/27/2009 14:32:37 - Revisione: 2.0

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