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Messaggio di errore quando si tenta di installare un certificato utilizzando Gestione IIS 7.0: "Impossibile trovare la richiesta di certificato associata al file di certificato"

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Clicca qui per visualizzare la versione originale in inglese dell’articolo: 959216
Sintomi
Quando si tenta di installare un certificato da un file PKCS #7 utilizzando Gestione Internet Information Services (IIS) 7.0, è possibile che venga visualizzato uno dei seguenti messaggi di errore:
Messaggio di errore 1
Impossibile trovare la richiesta di certificato associata al file di certificato. Nel computer in cui è stato creato, è necessario eseguire una richiesta di certificato.
Messaggio di errore 2
Si è verificato un errore durante l'esecuzione di questa operazione
Dettagli: CertEnroll::CX509Enrollment::p_InstallResponse: valore di tag non valido ASN1. 0X8009310B (ASN:276)
Nota.  Il certificato è installato correttamente nonostante il messaggio di errore.
Cause
Questo problema si verifica perché Gestione IIS esegue un'operazione di ricerca per cercare un nome descrittivo del certificato durante l'installazione. Tuttavia, il codice che esegue l'operazione di ricerca di accessi non riusciti in questo caso specifico e non sa come recuperare il nome descrittivo di un certificato in un file PKCS #7. Pertanto, l'operazione di ricerca non riesce e viene visualizzato il messaggio di errore.
Risoluzione
Per risolvere questo problema, aggiungere un nome descrittivo per il certificato. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic Inizio, fare clic su RUn, tipo Certmgr.MMC, quindi fare clic su OK.
  2. Fare clicFile, fare clic su Aggiungi/Rimuovi estensione ins.
  3. Selezionare Certificati, fare clic su Aggiungi e quindi fare clic su OK.
  4. Selezionare Account computer, quindi scegliereSuccessivo, quindi fare clic su Fine.
  5. Fare clicOK.
  6. Espandere Certificati (Computer locale), ePersonale, quindi Certificati.
  7. Il pulsante destro del certificato e quindi fare clic su Proprietà.
  8. Modifica il Nome descrittivo campo.
Informazioni
Questo problema verrà risolto in Windows Server 2008 service pack 3.
Proprietà

ID articolo: 959216 - Ultima revisione: 03/15/2013 06:33:00 - Revisione: 2.0

  • Microsoft Internet Information Services 7.0
  • kbsurveynew kbtshoot kbnomt kbmt KB959216 KbMtit
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