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Le informazioni di configurazione di protezione, quali l'ACL non viene copiate se un operatore di backup si utilizza l'utilità Robocopy con l'opzione /B per copiare un file su un computer che esegue Windows Vista o Windows Server 2008

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Sintomi
Si consideri il seguente scenario:
  • È possibile aggiungere un account utente al gruppo Backup Operators in un dominio.
  • È possibile utilizzare questo account per accedere a un computer che esegue Windows Vista o Windows Server 2008.
  • È possibile utilizzare il comando Robocopy con l'opzione /B per copiare alcuni file a cui non si dispone delle autorizzazioni o la proprietà.
In questo scenario, questi file vengono copiati correttamente. Tuttavia, le informazioni di configurazione di protezione, ad esempio un elenco di controllo di accesso (ACL) di un file non viene copiate. Gli ACL dei file copiati vengono ereditati dalla cartella di destinazione.

Inoltre, l'utilità Robocopy restituisce il seguente messaggio di errore:
ERRORE 5 (0x00000005) copia la protezione NTFS per File di destinazione <xxx>accesso negato.</xxx>
Nota Un membro del gruppo Backup Operators può accedere alle informazioni di configurazione di protezione di file in modalità di backup dell'utilità Robocopy. Il membro deve essere in grado di accedere a queste informazioni anche se il membro non dispone delle autorizzazioni o la proprietà del file.
Cause
L'utilità Robocopy non apre i file utilizzando il flag "intento di backup" quando si utilizza l'opzione/b . Questo comportamento impedisce l'accesso alle informazioni di configurazione di protezione per un utente che ha "Backup dei file e directory" privilegi (SE_BACKUP_PRIVILEGE).
Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato a correggere il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Questo hotfix vengano eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto usuali verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo di numeri di telefono di assistenza clienti Microsoft o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft: Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, il computer deve eseguire uno dei seguenti sistemi operativi:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Richiesta di riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni del Registro di sistema

Non si dispone di apportare qualsiasi modifica al Registro di sistema.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate nel tempo universale coordinato (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per trovare la differenza tra ora UTC e ora locale, utilizzare il Fuso orario scheda di Data e ora elemento nel Pannello di controllo.
Per tutte le versioni basate su x86 di Windows Vista e Windows Server 2008
Nome del fileVersione fileDimensione fileDataOraPiattaforma
Robocopy5.1.10.102789.08817-Lug-200912: 02x86
Robocopy5.1.10.102789.08817-Lug-200911: 46x86
Per tutte le versioni basate su x64 di Windows Vista e Windows Server 2008
Nome del fileVersione fileDimensione fileDataOraPiattaforma
Robocopy5.1.10.1027113,66417-Lug-200912: 21x64
Robocopy5.1.10.1027113,66417-Lug-200911: 53x64
Per tutte le versioni basate su Itanium di Windows Server 2008
Nome del fileVersione fileDimensione fileDataOraPiattaforma
Robocopy5.1.10.1027238,08017-Lug-200912: 08IA-64
Robocopy5.1.10.1027238,08017-Lug-200911: 44IA-64
Status
Microsoft ha confermato che questo è un problema nei prodotti Microsoft elencati nella sezione "Si applica a".
Informazioni
Per ulteriori informazioni sul comando Robocopy , visitare il seguente sito Web Microsoft: Per ulteriori informazioni su un altro problema con il comando Robocopy, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
950790Messaggio di errore quando si utilizza il comando Robocopy con l'opzione /ZB per copiare dati da un file server in un client basato su Windows Vista o Windows Server 2008: "errore 5: accesso negato"
Per ulteriori informazioni, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 973776 - Ultima revisione: 09/17/2012 06:03:00 - Revisione: 3.0

Windows Server 2008 for Itanium-Based Systems, Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 Standard

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