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AD RMS potrebbe smettere di funzionare quando si esegue una query in Active Directory i cataloghi globali in un computer che esegue Windows Server 2008 R2

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Sintomi
Si consideri il seguente scenario:
  • È possibile installare il ruolo del server Active Directory Rights Management Services (AD RMS) in un computer che esegue Windows Server 2008 R2.
  • AD RMS query cataloghi globali di Active Directory.
In questo scenario, il ruolo del server Active Directory Rights Management Service (AD RMS) potrebbe smettere di funzionare in modo casuale. Inoltre, questo comportamento potrebbe impedire alcuni client di apertura di contenuto protetto RMS.
Cause
AD RMS memorizza nella cache un pool di server di catalogo globale per migliorare le prestazioni delle query di Active Directory. Quando un server di catalogo globale non è disponibile, il server di catalogo globale deve essere rimosso dal pool.

Tuttavia, la rimozione di alcuni server di catalogo globale malfunzionante non funziona come previsto. Tali server di catalogo globale malfunzionante rimangono nel pool fino a quando non viene riavviato il server che esegue Internet Information Services (IIS). Di conseguenza, alcuni processi di RMS non riescano AD RMS interroga i server di catalogo globale. Questo comportamento causa AD RMS smettere di funzionare quando l'intero pool contiene server di catalogo globale malfunzionante.
Workaround
Per aggirare questo problema, è possibile utilizzare il comando "iisreset.exe" per riavviare il servizio IIS sul server che esegue IIS senza dover riavviare il server.
Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale aggiornamento rapido (hotfix).

Se l'aggiornamento rapido (hotfix) è disponibile per il download, è disponibile una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft: Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua desiderata, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), il computer esegua Windows Server 2008 R2. Inoltre, il computer necessario Active Directory Rights Management Services installata.

Necessità di riavvio

È necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri aggiornamenti rapidi (hotfix).

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi del file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertita in ora locale. Per calcolare la differenza tra ora UTC e quella locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nota le informazioni di file di Windows Server 2008 R2

I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono listed separately. MUM e MANIFEST dei file e i file di catalogo (CAT) protezione associati sono fondamentali per mantenere lo stato del componente aggiornato. I file di catalogo della protezione (attributi non in elenco) sono firmati con una firma digitale Microsoft.

Per tutte le versioni x 64 basati su versioni di Windows Server 2008 R2

Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Microsoft.rightsmanagementservices.Shared.dll6.1.7600.205062,166,78413-Ago-200906: 28x 86


Status
Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".
Riferimenti
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Informazioni

File aggiuntivi per tutte le versioni x 64 basati su versioni di Windows Server 2008 R2

Nome del fileVersione del fileFile
dimensione
DataOraPiattaforma
Msil_microsoft.rightsmanmentservices.shared_31bf3856ad364e35_6.1.7600.20506_none_68dacb1e747a3ee2.manifestNon applicabile2,00913-Ago-200907: 00Non applicabile
Package_for_kb974636_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNon applicabile1,45214-Ago-200901: 23Non applicabile
Autore: tejasp
Writer: v stxu
Tech Reviewer: seanba; tejasp
Editor: v lynan

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 974636 - Ultima revisione: 10/14/2009 09:50:09 - Revisione: 1.1

Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Standard

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