Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore quando si utilizza un'applicazione che monitora il log eventi per aprire un file di registro degli eventi in un computer che esegue Windows Server 2003 SP2: "il file di registro eventi è danneggiato"

Il supporto per Windows Server 2003 è terminato il 14 luglio 2015.

Microsoft ha sospeso il supporto per Windows Server 2003 in data 14 luglio 2015. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

975652
Sintomi
Quando si utilizza un'applicazione che monitora il log eventi, quali Visualizzatore eventi per aprire un file di registro degli eventi in un computer che esegue Windows Server 2003 Service Pack 2 (SP2), viene visualizzato il seguente messaggio di errore:
Il file di registro eventi è danneggiato.
Nota Danneggiamento del registro eventi possono verificarsi per molti motivi. Questo aggiornamento rapido (hotfix) consente di correggere il danneggiamento del registro eventi causato da solo il motivo specifico menzionato nella sezione "Cause".
Cause
Questo problema si verifica perché non è presente un valore per il campo "Nome computer" o per il campo "Source" nel file di log eventi una voce del registro eventi. Se un'applicazione chiama la funzione ReadEventLog per recuperare le voci del registro eventi, viene restituito un codice di errore STATUS_EVENTLOG_FILE_CORRUPT. Di conseguenza, l'applicazione viene visualizzato un messaggio di errore.

Molti fattori possono causare una voce del registro eventi essere un valore per il campo "Nome computer" o il campo "Source" mancante.

Ad esempio, un'applicazione chiama la funzione GetComputerName per recuperare il nome computer. Quindi, questa applicazione scrive il valore restituito direttamente in una voce del registro eventi appena creato senza verificare il valore. Tuttavia, poiché la memoria del computer è insufficiente, la funzione GetComputerName non ha esito positivo e restituisce un valore NULL. In questo esempio, la voce del log eventi è privo di un valore per il campo "Nome computer".

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale aggiornamento rapido (hotfix).

Se l'aggiornamento rapido (hotfix) è disponibile per il download, non vi è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft: Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua in uso, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), il computer deve essere in esecuzione Windows Server 2003 Service Pack 2 (SP2).

Necessità di riavvio

È necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Per ulteriori informazioni sull'installazione di Windows Server 2003 service pack, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
889100Come ottenere il service pack più recente per Windows Server 2003

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri aggiornamenti rapidi (hotfix).

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare scheda fuso orario nella Data e ora nel Pannello di controllo.
Nota le informazioni file di Windows Server 2003

Per tutte le versioni x 86 le versioni di Windows Server 2003

Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Advapi32.dll5.2.3790.4589619,00814-09-200917: 19x 86
Per tutte le versioni x 64 basati su versioni di Windows Server 2003
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SP
Advapi32.dll5.2.3790.45891,065,47215/09 200906: 03x 64SP2
Wadvapi32.dll5.2.3790.4589619,00815/09 200906: 03x 86SP2
Per tutte le versioni basate su Itanium di Windows Server 2003
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SP
Advapi32.dll5.2.3790.45891,483,77615/09 200906: 03IA-64SP2
Wadvapi32.dll5.2.3790.4589619,00815/09 200906: 03x 86SP2

Status
Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".
Riferimenti
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 975652 - Ultima revisione: 10/14/2009 09:42:46 - Revisione: 1.1

  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • kbmt kbexpertiseinter kbautohotfix kbqfe kbbug kbfix kbsurveynew kbhotfixserver KB975652 KbMtit
Feedback