Al momento sei offline in attesa che la connessione Internet venga ristabilita

Messaggio di errore quando si tenta di importare le personalizzazioni di Microsoft Dynamics CRM Online in un'organizzazione di Microsoft Dynamics CRM 4.0: "Eseguire il file potrebbe non essere caricato o non è un file di personalizzazione valido"

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 976978
Sintomi
Quando si tenta di importare le personalizzazioni di Microsoft Dynamics CRM Online in un'organizzazione di Microsoft Dynamics CRM 4.0, viene visualizzato il seguente messaggio di errore:
Impossibile caricare il file oppure non è un file di personalizzazione valido.
Cause
Questo problema si verifica perché il file di personalizzazione di Microsoft Dynamics CRM Online deve essere convertito in un file di personalizzazione di Microsoft Dynamics CRM 4.0 prima di importare il file.
Risoluzione
Questo problema è stato risolto nel più recente aggiornamento cumulativo per Microsoft Dynamics CRM 4.0.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
949256Microsoft Dynamics CRM 4.0 aggiornamenti e aggiornamenti rapidi

Dopo aver installato l'aggiornamento cumulativo più recente per Microsoft Dynamics CRM, è necessario convertire il file di personalizzazione in linea di CRM in un file di personalizzazione CRM 4.0. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Download aggiornamento cumulativo 7 per Microsoft Dynamics CRM 4.0. A tale scopo, visitare il seguente sito Web Microsoft: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=a4893988-7804-4e23-ab58-740441cc696e
  2. Salvare il file scaricato in una cartella.
  3. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd e quindi fare clic su OK.
  4. Passare alla cartella contenente il file di aggiornamento cumulativo 7 per Microsoft Dynamics CRM 4.0 directory, digitare CRMv4.0-KB971782-i386-server-ENU.exe /x e quindi premere INVIO.
  5. Quando viene chiesto di salvare i file estratti, fare clic su Salva.
  6. Modificare le directory nella directory Tools/Customizationmigrationprocessor. Trova la directory in cui sono stati salvati i file estratti nel passaggio 5.
  7. Al prompt dei comandi, eseguire il file Migrationprocessortool.exe si trova nella cartella Customizationmigrationprocessor. Per effettuare questa operazione, eseguire il comando riportato di seguito:
    migrationprocessortool Customizationfile

    Note
    • Il segnaposto Customizationfile rappresenta la posizione del file di personalizzazione in linea di Microsoft CRM che si desidera elaborare.
    • Quando si esegue il file Migrationprocessortool.exe, lo strumento elabora le personalizzazioni. Quindi, lo strumento Salva un nuovo file denominato "ProcessedCustomization.xml" nella cartella Customizationmigrationprocessor.
    • Il file ProcessedCustomization.xml contiene un nuovo insieme di personalizzazioni.
Dopo aver convertire il file di personalizzazione in linea di CRM in un file di personalizzazione CRM 4.0, utilizzare il file ProcessedCustomization.xml per importare le personalizzazioni di Microsoft Dynamics CRM Online in un'organizzazione di Microsoft Dynamics CRM 4.0.
Informazioni
Mentre lo strumento è in esecuzione, sono previsti i seguenti errori:
Errori di convalida nel processore InternetMarketingProcessor:
L'attributo 'GetStartedPanePath' non è dichiarato.
L'attributo 'GetStartedPanePathOutlook' non è dichiarato.
L'attributo 'GetStartedPanePathAdmin' non è dichiarato.
L'attributo 'GetStartedPanePathAdminOutlook' non è dichiarato.



Quando viene eseguito lo strumento di MigrationProcessor, vengono eseguiti vari processori configurati nel file config del processore. La versione corrente viene eseguito seguenti processori:
  • Processore di effetti grafici
  • Processore Marketing Internet
  • Processore di Helpvisor
  • Home page di processore

Tutti i processori, tranne l'ultimo processore dispongono di IgnoreValidationErrors impostata su true come il lavoro non è stata effettivamente completato e le convalide non vengono elaborati correttamente fino a quando non viene eseguito correttamente l'ultimo processore nell'elaborazione se tutti i processori affrontare aspetti diversi della pulitura nello stesso elemento. In questo caso quando il processore Internet Marketing viene completato il processo ha ancora sito againt di errori di convalida mapping xsd come operazioni di pulitura necessarie per essere completato da processore Visor di Guida in linea sono ancora presente e in modo da ottenere gli errori di convalida. Una volta impostato l'ultimo processore nell'esecuzione dei file config abbiamo non sono previsti altri errori di convalida, come tutti i processori set hanno completato il processo di pulitura.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 976978 - Ultima revisione: 01/11/2010 19:31:53 - Revisione: 2.0

Microsoft Dynamics CRM 4.0

  • kbmt kberrmsg kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB976978 KbMtit
Feedback