Al momento sei offline in attesa che la connessione Internet venga ristabilita

MS10-022: Descrizione dell'aggiornamento della protezione per VBScript 5.6 (Visual Basic Scripting): 13 aprile 2010

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l Ulteriori informazioni su come continuare a essere protetti.

Il supporto per Windows Server 2003 è terminato il 14 luglio 2015.

Microsoft ha sospeso il supporto per Windows Server 2003 in data 14 luglio 2015. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

INTRODUZIONE
È stato rilasciato il Bollettino Microsoft sulla sicurezza MS10-022. Per visualizzare il testo completo dei Bollettini Microsoft sulla sicurezza, visitare uno dei seguenti siti Web Microsoft:

Come ottenere assistenza e supporto tecnico per questo aggiornamento della protezione

Per gli utenti privati, il servizio di supporto tecnico gratuito è disponibile chiamando 1-866-PCSAFETY negli Stati Uniti e in Canada o contattando la filiale Microsoft locale. Per ulteriori informazioni su come contattare la filiale Microsoft locale per problemi relativi all'assistenza sugli aggiornamenti della protezione, visitare il sito Web del Supporto tecnico internazionale Microsoft: Per i clienti in Nord America, è inoltre possibile ottenere accesso istantaneo a supporto illimitato gratuito per posta elettronica o a supporto individuale illimitato via chat visitando il seguente sito Web Microsoft: Per gli utenti aziendali, il supporto per gli aggiornamenti della protezione è disponibile attraverso i normali contatti di supporto.
Informazioni

Ulteriori informazioni su questo aggiornamento della protezione

Problemi noti

È possibile risolvere una problematica che influisce un ambito limitato di computer in presenza di tutte le seguenti condizioni:
  • Windows XP Service Pack 3 è installato.
  • È stata installata manualmente una versione precedente di Windows Script Host 5.6.
Nota per impostazione predefinita, Windows XP Service Pack 3 installa Windows Script Host 5.7. Questo problema noto è limitato ai computer sui quali è stata installata manualmente una versione precedente di Windows Script Host, sebbene non necessario.

Sui computer non interessati da questo problema, questo aggiornamento della protezione potrebbe non installarsi in quanto è presente una versione inattesa di Vbscript.dll. Per installare questo aggiornamento di protezione su Windows XP Service Pack 3, la versione del file Vbscript.dll deve essere almeno la 5.7.

Per risolvere questo problema noto su un computer che esegue Windows XP Service Pack 3 e la versione del file Vbscript.dll è 5.6, utilizzare uno dei seguenti metodi a seconda della versione di Windows Internet Explorer in uso sul computer.

Per Internet Explorer 6
  1. Ripristinare Vbscript.dll a una versione prevista del file.

    Per ripristinare Vbscript.dll alla versione 5.7, eseguire una delle seguenti procedure:
    • Scaricare e installare l'aggiornamento del modulo di gestione di script KB951978 per Windows XP:
      951978 Gli output di script non vengono visualizzati come previsto quando si esegue VBScript o JScript in Windows Vista Service Pack 1, Windows Server 2008 o Windows XP Service Pack 3
      Nota Se sono stati abilitati gli aggiornamenti automatici, questo aggiornamento verrà offerto automaticamente.
    • Aggiornamento alla versione Internet Explorer 8. Per ulteriori informazioni su come ottenere Internet Explorer 8, visitare il seguente sito Web Microsoft:Nota Se sono stati attivati gli aggiornamenti automatici, questo aggiornamento verrà offerto automaticamente.
    • Aggiornamento alla versione Internet Explorer 7. Per ulteriori informazioni su come ottenere Internet Explorer 7, visitare il seguente sito Web Microsoft:
  2. Installare l'aggiornamento della protezione.

    Una volta ripristinato il Vbscript.dll a una versione prevista come qui indicato, installare l'aggiornamento della protezione VBScript 5.7 per Windows XP Service Pack 3 (KB981349) come descritto nel Bollettino sulla sicurezza MS10-022.

    Nota Se la versione Vbscript.dll è almeno la 5.7.0.0, questo aggiornamento della protezione viene offerto mediante gli aggiornamenti automatici.
Per Internet Explorer 7
  1. Ripristinare Vbscript.dll a una versione prevista del file.

    Per ripristinare Vbscript.dll alla versione 5.7, eseguire una delle seguenti procedure:
    • Scaricare e installare l'aggiornamento del modulo di gestione di script KB951978 per Windows XP:
      951978 Gli output di script non vengono visualizzati come previsto quando si esegue VBScript o JScript in Windows Vista Service Pack 1, Windows Server 2008 o Windows XP Service Pack 3
      Nota Se sono stati abilitati gli aggiornamenti automatici, questo aggiornamento verrà offerto automaticamente.
    • Aggiornamento alla versione Internet Explorer 8. Per ulteriori informazioni su come ottenere Internet Explorer 8, visitare il seguente sito Web Microsoft:Nota Se sono stati attivati gli aggiornamenti automatici, questo aggiornamento verrà offerto automaticamente.
    • Disinstallare Internet Explorer 7 e poi reinstallarlo.
  2. Installare l'aggiornamento della protezione.

    Una volta ripristinato il Vbscript.dll a una versione prevista come qui indicato, installare l'aggiornamento della protezione VBScript 5.7 per Windows XP Service Pack 3 (KB981349) come descritto nel Bollettino sulla sicurezza MS10-022.

    Nota Se sono stati abilitati gli aggiornamenti automatici, questo aggiornamento verrà offerto automaticamente.
Per Internet Explorer 8

Se è stato installato Internet Explorer 8 e gli aggiornamenti automatici sono abilitati, il corretto aggiornamento verrà automaticamente offerto e non saranno necessarie ulteriori procedure. Se questo aggiornamento automatico deve essere installato manualmente, scaricare e installare l'aggiornamento della protezione VBScript 5.8 per Windows XP Service Pack 3 (KB981349), come descritto nel Bollettino sulla sicurezza MS10-022.

Prerequisiti per applicare questo aggiornamento della protezione

Per installare questo aggiornamento della protezione, è necessario che sul computer sia installato Microsoft Visual Basic Scripting Edition (VBScript) 5.6.

VBScript 5.6 viene installato da:
  • Microsoft Internet Explorer 6
  • Windows Server 2003 (le versioni includono quanto segue: versioni SP2 basate su x86, SP2 basate su x64 e SP2 basate su Itanium)
  • Windows XP (le versioni includono quanto segue: SP2 basate su x86 e SP2 basate su x64)
  • Windows Script Host 5.6
Per determinare la versione di VBScript installata sul computer, attenersi alla procedura descritta di seguito:
  1. Aprire Windows Explorer.
  2. Individuare la seguente directory:
    %systemroot%\system32
  3. Fare clic con il pulsante destro del mouse sul file Vbscript.dll, quindi scegliere Proprietà.
  4. Fare clic sulla scheda Dettagli per visualizzare il campo Versione file.
Se la versione file inizia con 5.6 (ad esempio, 5.6.0.8825), nel computer è installato VBScript 5.6.

Informazioni sulla rimozione

Per rimuovere l'aggiornamento della protezione, seguire una delle seguenti procedure:
  • Utilizzare lo strumentoInstallazione applicazioni nel Pannello di controllo.
  • Utilizzare l'utilità Spuninst.exe posizionata nella cartella seguente:
    %Windir%\$NTUninstallKB981350$\Spuninst

Informazioni sul riavvio

Al termine dell'applicazione dell'aggiornamento della protezione potrebbe essere necessario riavviare il computer.

Informazioni sui file

La versione in lingua inglese di questo aggiornamento presenta gli attributi di file (o valori successivi) elencati nella tabella riportata di seguito. Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinated). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
Per tutte le versioni basate su x86 supportate di Windows 2000 SP4
File nameFile versionFile sizeDateTimePlatform
Vbscript.dll5.6.0.8838401,40812-Mar-201021:44x86
Per tutte le versioni x86 supportate di Windows XP SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838417,79210-Mar-201008:02x86SP2SP2GDR
Vbscript.dll5.6.0.8838417,79210-Mar-201008:07x86SP2SP2QFE
Per tutte le versioni x86 supportate di Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838401,40809-Mar-201005:20x86SP2SP2GDR
Vbscript.dll5.6.0.8838401,40809-Mar-201005:27x86SP2SP2QFE
Per tutte le versioni basate su x64 supportate di Windows Server 2003 SP2 e Windows XP Professional SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838663,04009-Mar-201004:43x64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:43x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.8838663,55209-Mar-201004:38x64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
Per tutte le versioni basate su Itanium supportate di Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.88381,116,67209-Mar-201004:41IA-64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:41x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.88381,117,69609-Mar-201004:38IA-64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service dos
Proprietà

ID articolo: 981350 - Ultima revisione: 04/21/2010 17:57:40 - Revisione: 1.1

  • Microsoft Internet Explorer 6.0
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows 2000 Service Pack 4
  • kbsurveynew kbfix kbbug kbsecvulnerability kbsecbulletin kbsecurity kbqfe kbexpertiseinter KB981350
Feedback