Aggiungere testo di Guida personalizzato a un modello di modulo

Si applica a
InfoPath 2010 InfoPath 2013

Importante

Il supporto per Microsoft InfoPath 2013 è terminato il 14 luglio 2026. È consigliabile eseguire la migrazione dei moduli e dei flussi di lavoro di InfoPath esistenti alle soluzioni Microsoft 365 supportate. Altre informazioni sul ritiro di InfoPath.

Per aiutare gli utenti a comprendere lo scopo del modulo e a compilarlo correttamente, è possibile aggiungere al modello di modulo un testo della Guida informativo.

Questo articolo spiega come determinare il tipo migliore di testo della Guida per il modello di modulo prendendo in considerazione fattori come il tipo di modello di modulo creato, il pubblico, l'estensione della distribuzione del modello di modulo e l'eventualità che gli utenti compilino moduli basati su tale modello utilizzando un Web browser.

Contenuto dell'articolo

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo in Microsoft Office InfoPath 2007, è possibile scegliere di progettare un modello di modulo compatibile con browser. Quando si progetta un modello di modulo compatibile con browser, alcune funzionalità non sono disponibili. Ad esempio, i riquadri attività personalizzati, che vengono spesso usati per visualizzare testo della Guida personalizzato, non sono supportati nei modelli di modulo compatibili con browser. Per aggiungere la Guida a un modello di modulo compatibile con browser, prendere in considerazione un modo alternativo per aggiungere la Guida, ad esempio usando la formattazione condizionale per visualizzare la Guida contestuale.

Inizio pagina

Tipi di assistenza

A seconda della complessità del modello di modulo e delle esigenze degli utenti, è possibile aggiungere diversi tipi di testo della Guida con procedure diverse. A seconda del modello di modulo, è possibile usare più tipi di testo della Guida nel modello di modulo. Di seguito è riportato un elenco dei modi più comuni per visualizzare il testo della Guida nel modello di modulo:

  • Visualizzazione Guida Creare una visualizzazione separata per visualizzare il testo della Guida quando si desidera fornire istruzioni dettagliate agli utenti. È possibile creare una visualizzazione della Guida contenente solo testo della Guida oppure duplicare i controlli aggiunti nella visualizzazione predefinita del modello di modulo e includere il testo della Guida associato. Aggiungendo controlli con testo della Guida, si fornisce una visualizzazione alternativa per la compilazione del modulo, ovvero una visualizzazione contenente la Guida contestuale per ogni sezione o controllo. Si tratta di un approccio utile quando il pubblico include sia nuovi utenti, che necessitano di ulteriore assistenza, sia utenti esperti, che sanno già come compilare il modulo.

    Suggerimento

    Poiché i modelli di modulo compatibili con browser non supportano i riquadri attività personalizzati, l'uso delle visualizzazioni della Guida per visualizzare il testo della Guida è una buona alternativa ai riquadri attività personalizzati.

  • Riquadro attività personalizzato Un riquadro attività personalizzato è un file HTML il cui contenuto viene visualizzato in un riquadro attività di InfoPath quando un utente compila un modulo. È possibile specificare un solo file HTML da aprire nel riquadro attività personalizzato predefinito per il modello di modulo, ma è possibile aggiungere altri file HTML al modello di modulo come file di risorse e quindi creare collegamenti ipertestuali tra di essi. Nei riquadri attività personalizzati è possibile visualizzare solo i file HTML. I riquadri attività personalizzati possono fornire comandi e contenuti della Guida specifici della maschera. È possibile aggiungere un file HTML direttamente al modello di modulo, in modo che gli utenti possano visualizzare la Guida del riquadro attività personalizzato anche mentre compilano il modulo offline oppure collegare il riquadro attività personalizzato a un file HTML archiviato in un'altra posizione. Ad esempio, se si prevede di aggiornare frequentemente il contenuto della Guida, ma non si vuole pubblicare il modello di modulo ogni volta che viene apportato un aggiornamento al file HTML della Guida, è consigliabile archiviare il file HTML in un'altra posizione e collegarlo dal riquadro attività personalizzato. Tenere presente che i modelli di modulo compatibili con browser non supportano i riquadri attività personalizzati, pertanto è consigliabile creare un riquadro attività personalizzato solo per i moduli che verranno compilati in InfoPath.

  • Formattazione condizionale È possibile usare la formattazione condizionale per specificare opzioni di formattazione diverse per un controllo basate su condizioni che si verificano nella maschera. Se le condizioni specificate sono vere, quando un utente compila un modulo, viene applicata la formattazione condizionale. Quando si aggiunge testo della Guida a una sezione del modello di modulo e si aggiunge la formattazione condizionale a tale sezione, si consente a un utente di visualizzare o nascondere il testo della Guida contestuale per una sezione o un controllo in base alle esigenze, senza cambiare visualizzazione. Si tratta di un metodo utile per fornire la Guida incorporata per sezioni o controlli specifici per gli utenti che desiderano accedere alla Guida.

  • Guida esterna È possibile aggiungere un collegamento a un file esterno, ad esempio un file HTML in un sito Web. Ad esempio, se il sito Web del supporto tecnico per l'organizzazione contiene una pagina Web per l'avvio di una sessione di chat dal vivo con un tecnico del supporto tecnico, è possibile aggiungere un collegamento ipertestuale al modello di modulo che consente agli utenti di aprire tale pagina nei Web browser. Questo approccio è utile quando si progetta un modello di modulo per un altro reparto dell'organizzazione e tale reparto è più qualificato per fornire agli utenti assistenza o supporto tecnico.

  • Guida di InfoPath per gli utenti che compilano moduli InfoPath contiene un sistema di Guida dedicato per gli utenti che compilano moduli. Richiedendo agli utenti di premere F1 mentre compilano un modulo, si consente loro di accedere a questi argomenti della Guida sulle funzionalità standard di InfoPath. Usare questo approccio per i moduli che gli utenti compilano solo usando InfoPath.

Inizio pagina

Creare una visualizzazione per visualizzare la Guida

Per creare una visualizzazione separata nel modello di modulo in cui gli utenti possono visualizzare la Guida per la compilazione del modulo, è necessario creare prima una visualizzazione della Guida per il modello di modulo e quindi aggiungere un pulsante alla visualizzazione predefinita della maschera su cui gli utenti possono fare clic per accedere alla visualizzazione della Guida.

Creare una visualizzazione della Guida

  1. Scegliere Gestisci viste dal menu Visualizza.
  2. In Azioni nel riquadro attività Visualizzazioni fare clic su Aggiungi una nuova visualizzazione.
  3. Nella casella Nome nuova visualizzazione digitare un nome per la visualizzazione della Guida e quindi fare clic su OK.
    Ad esempio, digitare Guida.
  4. Nel modello di modulo fare clic nella visualizzazione appena aggiunta e digitare o incollare il testo desiderato per la Guida.
  5. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.
  6. Nel riquadro attività Controlli fare clic su Pulsante.
  7. Fare clic con il pulsante destro del mouse sul pulsante aggiunto, quindi scegliere Proprietà pulsante dal menu di scelta rapida.
  8. Fare clic sulla scheda Generale.
  9. Nella casella Etichetta digitare un'etichetta per il pulsante. Ad esempio, digitare Torna alla maschera.
  10. Fare clic su Regole.
  11. Nella finestra di dialogo Regole , fare clic su Aggiungi.
  12. Fai clic su Aggiungi azione.
  13. Nella casella Azione (Action ), fate clic su Switch views (Switch views).
  14. Nella casella Visualizza fare clic sul nome della visualizzazione predefinita.
  15. Fare clic su OK quattro volte per tornare al modello di modulo.

Dopo aver creato la visualizzazione della Guida per il modello di modulo, è necessario aggiungere un pulsante alla visualizzazione predefinita, in modo che gli utenti possano accedervi facilmente quando compilano il modulo.

Aggiungere un pulsante alla visualizzazione predefinita

  1. Scegliere Gestisci viste dal menu Visualizza.
  2. Nel riquadro attività Visualizzazioni fare clic sul nome della visualizzazione predefinita.
  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.
  4. Nel riquadro attività Controlli fare clic su Pulsante.
  5. Fare clic con il pulsante destro del mouse sul pulsante aggiunto, quindi scegliere Proprietà pulsante dal menu di scelta rapida.
  6. Fare clic sulla scheda Generale.
  7. Nella casella Etichetta digitare un'etichetta per il pulsante. Ad esempio, digitare Guida.
  8. Fare clic su Regole.
  9. Nella finestra di dialogo Regole , fare clic su Aggiungi.
  10. Fai clic su Aggiungi azione.
  11. Nella casella Azione (Action ), fate clic su Switch views (Switch views).
  12. Nella casella Visualizza fare clic sul nome della visualizzazione della Guida aggiunta nella procedura precedente.
  13. Fare clic su OK quattro volte per tornare al modello di modulo.

Suggerimento

È possibile aggiungere alla visualizzazione della Guida gli stessi controlli contenuti nella visualizzazione predefinita. In questo modo gli utenti possono scegliere se compilare il modulo nella visualizzazione predefinita se non hanno bisogno di assistenza oppure utilizzare la visualizzazione della Guida per compilare il modulo se hanno bisogno di visualizzare le istruzioni del testo della Guida.

Inizio pagina

Creare un riquadro attività personalizzato per visualizzare la Guida

Nota

Prima di creare un riquadro attività personalizzato per visualizzare la Guida nel modello di modulo, considerare quanto segue:

  • I modelli di modulo compatibili con browser non supportano i riquadri attività personalizzati.
  • Prima di abilitare un riquadro attività personalizzato, è necessario creare un file HTML per il riquadro attività personalizzato usando un editor HTML, ad esempio Microsoft Office SharePoint Designer 2007.

Per creare e abilitare un riquadro attività personalizzato, eseguire le operazioni seguenti:

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. In Categoria, fai clic su Programmazione.

  3. Selezionare la casella di controllo Abilita riquadro attività personalizzato .

  4. Nella casella Nome riquadro attività digitare il nome da visualizzare nella parte superiore del riquadro attività personalizzato. Ad esempio, digitare Guida.

  5. Per aggiungere un file al modello di modulo, fare clic su File di risorse.

    Nota

    Per collegare un file al modello di modulo, nella casella Posizione del riquadro attività digitare il percorso assoluto per la posizione del file HTML e quindi fare clic su OK.

    Nota

    È consigliabile creare un collegamento a un file HTML che si trova nello stesso dominio del modello di modulo. In caso contrario, gli utenti che aprono un modulo basato sul modello di modulo visualizzeranno un avviso.

  6. Nella finestra di dialogo File di risorse fare clic su Aggiungi.

  7. Nella finestra di dialogo Aggiungi file individuare e selezionare il file HTML desiderato, quindi fare clic su OK.

  8. Se il file HTML aggiunto fa riferimento ad altri file, ad esempio fogli di stile Cascading, aggiungere anche questi file.

    Suggerimento

    È possibile specificare un solo file HTML da aprire nel riquadro attività personalizzato predefinito per il modello di modulo, ma è possibile aggiungere altri file HTML al modello di modulo come file di risorse e quindi creare collegamenti ipertestuali tra di essi.

  9. Nella finestra di dialogo Opzioni maschera fare clic sul nome del file HTML appena aggiunto nella casella Posizione riquadro attività .

  10. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B. Il riquadro attività personalizzato appena creato dovrebbe essere visualizzato per impostazione predefinita quando si visualizza l'anteprima del modello di modulo.

Inizio pagina

Usare la formattazione condizionale per visualizzare la Guida contestuale

La procedura seguente descrive come usare la formattazione condizionale per visualizzare o nascondere la Guida contestuale.

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Nel riquadro attività Controlli fare clic sulla casella di controllo e quindi su Sezione.

  3. Fare clic nella sezione appena aggiunta al modello di modulo e digitare il testo della Guida.

  4. Eliminare il testo dell'etichetta predefinito per la casella di controllo e quindi digitare Fare clic per visualizzare o nascondere la Guida.

  5. Fare clic sulla scheda della sezione del modello di modulo e quindi scegliere Formattazione condizionale dal menu Formato.

  6. Fare clic su Aggiungi.

  7. In Se questa condizione è vera, nella prima casella fare clic su Seleziona un campo o un gruppo.

  8. Nella finestra di dialogo Selezionare un campo o un gruppo selezionare il campo corrispondente al controllo casella di controllo aggiunto nel passaggio 2 e quindi fare clic su OK.

  9. Nella seconda casella, nella finestra di dialogo Formato condizionale , fare clic è uguale a.

  10. Nella terza casella fare clic su FALSO.

  11. In Applicare quindi questa formattazione selezionare la casella di controllo Nascondi controllo .

    Nota

    La condizione ora indica che se la casella di controllo è selezionata, la sezione verrà visualizzata.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Nella procedura seguente viene descritto come aggiungere un collegamento ipertestuale dal modello di modulo a un file della Guida esterno, ad esempio un file HTML o un file della Guida compilato (con estensione chm), o a un sito Web, ad esempio un sito Web del supporto tecnico.

Nota

  • Verificare che il file della Guida esterno o il sito Web a cui si crea un collegamento sia accessibile agli utenti. Se si vuole aggiungere un collegamento a un file HTML in un modello di modulo compatibile solo con InfoPath (in altre parole, gli utenti devono usare InfoPath per compilare moduli basati su tale modello di modulo), è possibile aggiungere file HTML al modello di modulo aggiungendoli come file di risorse da aprire in un riquadro attività personalizzato. Per i modelli di modulo compatibili con browser, è consigliabile pubblicare i file HTML in un sito accessibile agli utenti, preferibilmente lo stesso sito Web in cui si trova il modello di modulo, e creare un collegamento ipertestuale statico nel modello di modulo che punti al file HTML esterno.
  • Se si decide di utilizzare un altro formato per il file della Guida, ad esempio un file con estensione chm, verificare se il formato di file scelto è supportato dai sistemi operativi nei computer degli utenti.
  1. Nel modello di modulo fare clic nel punto in cui si vuole inserire un collegamento ipertestuale oppure selezionare il testo o l'immagine da trasformare in collegamento ipertestuale.

  2. Sulla barra degli strumenti Standard fare clic su Inserisci collegamento ipertestuale .

  3. Fare clic sulla scheda Generale.

  4. Nella casella Indirizzo digitare l'URL che si desidera collegare.

  5. Per modificare il testo del collegamento ipertestuale visualizzato nel modello di modulo, digitare il testo desiderato nella casella Testo .

    Nota

    Se è stata selezionata un'immagine nel passaggio 1, questa opzione non è disponibile.

  6. Per assegnare una descrizione comando che verrà visualizzata quando un utente sposta il puntatore sul collegamento ipertestuale, fare clic sulla scheda Avanzate e quindi nella casella Descrizione comando digitare il testo da visualizzare.

  7. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Aggiungere istruzioni per consentire agli utenti di visualizzare il sistema della Guida di InfoPath

InfoPath include un sistema di Guida dedicato che gli utenti possono usare quando compilano i moduli. Questo sistema della Guida contiene informazioni sulle attività comuni, come l'attivazione o la disattivazione di Completamento automatico e il controllo ortografico del testo in un modulo. I progettisti di moduli possono aprire la Guida di InfoPath per gli utenti dei moduli premendo F1 durante l'anteprima di un modulo nella finestra di anteprima.

La Guida per gli utenti dei moduli è limitata alle attività che si applicano a tutti i moduli, pertanto è consigliabile fornire una Guida personalizzata per i modelli di modulo progettati. Per consentire agli utenti di visualizzare la Guida di InfoPath quando compilano un modulo, è possibile aggiungere al modello di modulo istruzioni che spiegano come accedere al sistema di guide di InfoPath. Ad esempio, è possibile includere uno degli esempi seguenti nel modello di modulo:

  • Per aprire la Guida di InfoPath, premere F1.
  • Per aprire la Guida di InfoPath, scegliere Guida di Microsoft Office InfoPath dal menu Guida .

Inizio pagina