Come correggere un errore #VALORE! nella funzione MEDIA o SOMMA

Se la media o la somma si riferiscono alle celle contenenti #VALUE. errori, le formule comporteranno un #VALUE. .

Errore #VALORE! in MEDIA

Per ignorare i valori di errore, viene costruita una formula che ignora gli errori nell'intervallo riferimento durante il calcolo della media con i valori "normali" restanti.

Per risolvere questo scenario, viene usata una combinazione di MEDIA e SE più VAL.ERROREper determinare se è presente un errore nell'intervallo specificato. Questo specifico scenario richiede una formula di matrice:

=MEDIA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Questa è una formula in forma di matrice. Quindi devi premere invio (solo se usi Microsoft 365 ) o CTRL + MAIUSC + INVIO nella formula.

Nota: Se si ha una versione corrente di Microsoft 365, è possibile immettere semplicemente la formula nella cella di output, quindi premere invio per confermare la formula come formula di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando prima la cella di output, immettendo la formula nella cella di output e premendo CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Funzione matrice in media per risolvere la #VALUE. #NAME?

Nota: La funzione precedente non funziona solo per #VALORE!, ma anche per #N/D, #NULLO, #DIV/0! e altre funzioni.

È possibile usare SOMMA in modo analogo:

=SOMMA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Correggere un errore #VALORE! #NAME?

Funzione MEDIA

Funzione SOMMA

Panoramica delle formule in Excel

Rilevare gli errori nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×