Contare caratteri nelle celle

Quando devi contare i caratteri nelle celle, usa la funzione Len, che conta lettere, numeri, caratteri e tutti gli spazi. Ad esempio, la lunghezza del testo "Oggi ci sono 30 gradi, quindi vado al mare" (escluse le virgolette) è 42 caratteri, 32 lettere, 2 numeri, 8 spazi e una virgola.

Per usare la funzione, immettere = Len (cella) nella barra della formula, quindi premere INVIO sulla tastiera.

Più celle: Per applicare la stessa formula a più celle, immettere la formula nella prima cella e quindi trascinare il quadratino di riempimento verso il basso (o attraverso) l'intervallo di celle.

Immissione di più funzioni LUNGHEZZA in a foglio di lavoro

Per ottenere il conteggio totale di tutti i caratteri in più celle, è necessario usare le funzioni somma insieme a Len. In questo esempio la funzione LEN conta i caratteri in ogni cella e la funzione somma aggiunge i conteggi:

= Sum ((Len ( cell1 ), Len ( cell2 ), (Len ( cell3 ) ))).

Esercitazione

Ecco alcuni esempi che illustrano come usare la funzione LEN.

Copiare la tabella seguente e incollarla nella cella a1 in un foglio di lavoro di Excel. Trascinare la formula da B2 a B4 per visualizzare la lunghezza del testo in tutte le celle della colonna A.

Stringhe di testo

Formule

La volpe marrone veloce.

=LUNGHEZZA(A2)

La Volpe bruna veloce saltò.

Il tetto della casa crollò sul prato bagnato.

Contare i caratteri in una cella

  1. Fare clic sulla cella B2.

  2. Invio = Len (a2).

La formula conta i caratteri nella cella a2, che ammonta a 27, che include tutti gli spazi e il periodo alla fine della frase.

Nota: LEN conta eventuali spazi dopo l'ultimo carattere.
 

Contare i caratteri in più celle

  1. Fare clic sulla cella B2.

  2. Premere CTRL + C per copiare la cella B2, quindi selezionare le celle B3 e B4 e quindi premere CTRL + V per incollare la formula nelle celle B3: B4.

La formula viene copiata nelle celle B3 e B4 e la funzione conta i caratteri in ogni cella (20, 27 e 45).

Contare un numero totale di caratteri

  1. Nella cartella di lavoro di esempio fare clic sulla cella B6.

  2. Nella cella immettere =SOMMA(LUNGHEZZA(A2);LUNGHEZZA(A3);LUNGHEZZA(A4)) e premere INVIO.

Questo conta i caratteri in ognuna delle tre celle e li totali (92).

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×