Argomenti correlati
×
Tabelle pivot
Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.
Tabelle pivot

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Una tabella pivot è un efficace strumento di calcolo, riepilogo e analisi dei dati che consente di visualizzare confronti, schemi e tendenze nei dati. Le tabelle pivot funzionano in modo leggermente diverso a seconda della piattaforma usata per eseguire Excel.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

  1. Selezionare le celle con cui creare una tabella pivot.

    Nota:  I dati devono essere organizzati in colonne con una singola riga di intestazione. Per altre informazioni, vedere la sezione Suggerimenti e consigli sul formato dati.

  2. Selezionare Inserisci > Tabella pivot.

    Pulsante Tabella pivot

  3. In questo modo viene creata una tabella pivot basata su una tabella o un intervallo esistente.
    Tabella pivot da intervallo o tabella

    Nota: Se si seleziona Aggiungi questi dati al modello di dati, la tabella o l'intervallo usato per la tabella pivot viene aggiunto al modello di dati della cartella di lavoro. Ulteriori informazioni.

  4. Scegliere dove inserire il rapporto di tabella pivot. Selezionare Nuovo foglio di lavoro per inserire la tabella pivot in un nuovo foglio di lavoro o in Foglio di lavoro esistente e selezionare il punto in cui si vuole inserire la nuova tabella pivot. 

  5. Selezionare OK.

Facendo clic sulla freccia in giù sul pulsante, è possibile selezionare altre origini possibili per la tabella pivot.  Oltre a usare una tabella o un intervallo esistente, è possibile selezionare altre tre origini per popolare la tabella pivot.

Selezionare Origine tabella pivot

Nota: A seconda delle impostazioni IT dell'organizzazione, il nome dell'organizzazione potrebbe essere incluso nell'elenco. Ad esempio, "Da Power BI (Microsoft)".

Ottenere da un'origine dati esterna

Tabella pivot da origine esterna

Ottenere dal modello di dati

Usare questa opzione se la cartella di lavoro contiene un modello di dati e si vuole creare una tabella pivot da più tabelle, migliorare la tabella pivot con misure personalizzate o se si usano set di dati di dimensioni molto grandi. 
Tabella pivot da tabella dati

Ottenere da Power BI

Usare questa opzione se l'organizzazione usa Power BI e si vuole individuare e connettersi a set di dati cloud approvati a cui si ha accesso. 

Tabella pivot da Power BI

  1. Per aggiungere un campo alla tabella pivot, selezionare la casella di controllo relativa al nome del campo nel riquadro Campi tabella pivot.

    Nota: I campi selezionati vengono aggiunti alle aree predefinite: i campi non numerici vengono aggiunti a Righe, le gerarchie di data e ora vengono aggiunte alle colonne e i campi numerici a Valori.

    Tabella pivot

  2. Per spostare un campo da un'area a un'altra, trascinare il campo nell'area di destinazione.

Se si aggiungono nuovi dati all'origine dati della tabella pivot, sarà necessario aggiornare tutte le tabelle pivot basate su tale origine dati. Per aggiornare una sola tabella pivot, è possibile fare clic con il pulsante destro del mouse in un punto qualsiasi dell'intervallo della tabella pivot e quindi scegliere Aggiorna. Se si hanno più tabelle pivot, selezionare prima di tutto una cella qualsiasi in una tabella pivot, quindi sulla barra multifunzione passare a Analizza tabella pivot > selezionare la freccia sotto il pulsante Aggiorna e quindi aggiorna tutto.

Aggiornare una tabella pivot

Riepiloga valori per

Per impostazione predefinita, i campi della tabella pivot posizionati nell'area Valori vengono visualizzati come SOMMA. Se i dati vengono interpretati come testo, i dati vengono visualizzati come CONTEGGIO. Per questo motivo, è importante assicurarsi di non combinare tipi di dati diversi per i campi dei valori. È possibile modificare il calcolo predefinito selezionando prima la freccia a destra del nome del campo e quindi selezionando l'opzione Impostazioni campo valore .

Finestra di dialogo Impostazioni campo valore di Excel

Modificare quindi il calcolo nella sezione Riepiloga valori per. Quando si modifica il metodo di calcolo, Excel lo aggiunge automaticamente nella sezione Nome personalizzato , ad esempio "Somma di NomeCampo", ma è possibile modificarlo. Se si seleziona Formato numero, è possibile modificare il formato numerico per l'intero campo.

Suggerimento: Poiché modificando il calcolo nella sezione Riepiloga valori per viene modificato il nome del campo della tabella pivot, è consigliabile non rinominare i campi della tabella pivot finché non si completa la configurazione della tabella pivot. Un trucco consiste nell'usare Trova & Sostituisci (CTRL+H) >Trova ciò che > "Somma di" e quindi Sostituisci con > lasciare vuoto tutto in una volta per sostituire tutto invece di digitare di nuovo manualmente.

Finestra di dialogo Impostazioni campo valore di Excel con le opzioni Riepiloga valori per

Mostra valori come

Invece di usare un calcolo per riepilogare i dati, è anche possibile visualizzarli come percentuale di un campo. Nell'esempio seguente l'importo delle spese domestiche è stato modificato per essere visualizzato come % del totale complessivo invece che come somma dei valori.

Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo

Dopo aver aperto la finestra di dialogo Impostazione campo valore , è possibile effettuare le selezioni desiderate nella scheda Mostra valori come .

Visualizzare un valore sia come calcolo che come percentuale.

Trascinare semplicemente l'elemento nella sezione Valori due volte e quindi impostare le opzioni Riepiloga valori per e Mostra valori come per ognuna di esse.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

  1. Selezionare una tabella o un intervallo di dati nel foglio e selezionare Inserisci > tabella pivot per aprire il riquadro Inserisci tabella pivot .

  2. È possibile creare manualmente una tabella pivot personalizzata o scegliere una tabella pivot consigliata da creare. Eseguire una delle operazioni seguenti:

  • Nella scheda Crea una tabella pivot personalizzata selezionare Nuovo foglio o Foglio esistente per scegliere la destinazione della tabella pivot.

  • In una tabella pivot consigliata selezionare Nuovo foglio o Foglio esistente per scegliere la destinazione della tabella pivot.

Nota:  Le tabelle pivot consigliate sono disponibili solo per gli abbonati a Microsoft 365.

Il riquadro Inserisci tabella pivot consente di impostare l'origine, la destinazione e altri aspetti della tabella pivot.

È possibile modificare l'originedati per i dati della tabella pivot durante la creazione.

  1. Nel riquadro Inserisci tabella pivot selezionare la casella di testo in Origine. Durante la modifica dell'origine, le schede nel riquadro non saranno disponibili.

  2. Selezionare i dati nella griglia o immettere un intervallo nella casella di testo. 

  3. Premere INVIO sulla tastiera o il pulsante per confermare la selezione. Il riquadro viene aggiornato con le nuove tabelle pivot consigliate in base alla nuova origine dati.

Inserire il riquadro tabella pivot in cui viene chiesto di usare una tabella o un intervallo come origine e di modificare la destinazione.

Ottenere da Power BI

Usare questa opzione se l'organizzazione usa Power BI e si vuole individuare e connettersi a set di dati cloud approvati a cui si ha accesso. 

Tabella pivot da Power BI

Nel riquadro Campi tabella pivot selezionare la casella di controllo relativa a qualsiasi campo da aggiungere alla tabella pivot.

Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Righe, i campi di data e ora vengono aggiunti all'area Colonne e i campi numerici vengono aggiunti all'area Valori.

È anche possibile trascinare manualmente qualsiasi elemento disponibile in uno qualsiasi dei campi della tabella pivot oppure, se non si vuole più inserire un elemento nella tabella pivot, trascinarlo dall'elenco o deselezionarlo.

Campi tabella pivot in Excel per il web

Riepiloga valori per

Per impostazione predefinita, i campi della tabella pivot nell'area Valori vengono visualizzati come SOMMA. Se i dati vengono interpretati come testo, vengono visualizzati come CONTEGGIO. Per questo motivo, è importante assicurarsi di non combinare tipi di dati diversi per i campi dei valori.

Modificare il calcolo predefinito facendo clic con il pulsante destro del mouse su un valore qualsiasi nella riga e selezionando l'opzione Riepiloga valori per.

Riepiloga per in Excel per il web

Mostra valori come

Invece di usare un calcolo per riepilogare i dati, è anche possibile visualizzarli come percentuale di un campo. Nell'esempio seguente l'importo delle spese domestiche è stato modificato per essere visualizzato come % del totale complessivo invece che come somma dei valori.

Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo

Fare clic con il pulsante destro del mouse su un valore qualsiasi nella colonna per cui si vuole visualizzare il valore. Selezionare Mostra valori come nel menu. Viene visualizzato un elenco di valori disponibili.

Selezionare l'opzione desiderata nell'elenco.

Per visualizzare % del totale padre, passare il puntatore del mouse su tale elemento nell'elenco e selezionare il campo padre da usare come base del calcolo. 

Mostra come

Se si aggiungono nuovi dati all'origine dati della tabella pivot , tutte le tabelle pivot create su tale origine dati devono essere aggiornate. Fare clic con il pulsante destro del mouse in un punto qualsiasi dell'intervallo della tabella pivot e quindi scegliere Aggiorna.

Aggiorna tabella pivot

Se è stata creata una tabella pivot e si decide che non è più necessario, selezionare l'intero intervallo di tabelle pivot e premere CANC. Questa operazione non avrà alcun effetto su altri dati, tabelle pivot o grafici circostanti . Se la tabella pivot si trova in un foglio separato che non contiene altri dati da conservare, l'eliminazione del foglio è un modo rapido per rimuovere la tabella pivot.

  • I dati devono essere organizzati in formato tabulare e non devono esserci righe o colonne vuote. Idealmente, è possibile usare una tabella di Excel.

  • Le tabelle costituiscono un'origine dati eccellente per le tabelle pivot, perché le righe aggiunte a una tabella vengono incluse automaticamente nella tabella pivot quando si aggiornano i dati e le nuove colonne vengono incluse nell'elenco Campi tabella pivot. In caso contrario, è necessario modificare i dati di origine per una tabella pivot o usare una formula di intervallo denominato dinamico.

  • I tipi di dati nelle colonne devono corrispondere. Ad esempio, non si devono combinare date e testo nella stessa colonna.

  • Le tabelle pivot usano uno snapshot dei dati, detto cache, quindi i dati effettivi non vengono modificati in alcun modo.

Se non si ha molta esperienza nella creazione di tabelle pivot o non si sa esattamente come iniziare, è preferibile usare una delle Tabelle pivot consigliate. Quando si usa questa funzionalità, Excel determina un layout significativo stabilendo una corrispondenza tra i dati e le aree appropriate nella tabella pivot. La tabella così ottenuta costituisce una base di partenza per sperimentare le varie disposizioni possibili. Dopo aver creato una tabella pivot consigliata, è possibile esplorare diversi orientamenti e ridisporre i campi per ottenere i risultati desiderati. È anche possibile scaricare l'esercitazione interattiva Creare la prima tabella pivot.

  1. Selezionare una cella nei dati di origine o nell'intervallo di tabella.

  2. Selezionare Inserisci > Tabelle pivot consigliate.

    Passare a Inserisci > Tabelle pivot consigliate per fare in modo che Excel crei una tabella pivot

  3. Excel analizza i dati e presenta diverse opzioni, come in questo esempio con i dati delle spese domestiche.

    Finestra di dialogo Tabelle pivot consigliate di Excel

  4. Selezionare la tabella pivot preferita e premere OK. Excel crea una tabella pivot in un nuovo foglio e visualizza l'elenco Campi tabella pivot .

  1. Selezionare una cella nei dati di origine o nell'intervallo di tabella.

  2. Selezionare Inserisci > Tabella pivot.

    Scheda Dati, gruppo Analisi

  3. Excel visualizza la finestra di dialogo Crea tabella pivot con l'intervallo o il nome della tabella selezionato. In questo caso viene usata una tabella denominata "tbl_HouseholdExpenses".

  4. Nella sezione Specificare dove collocare il rapporto di tabella pivot selezionare Nuovo foglio di lavoro o Foglio di lavoro esistente. Per Foglio di lavoro esistente selezionare la cella in cui inserire la tabella pivot.

  5. Selezionare OK. Excel crea una tabella pivot vuota e visualizza l'elenco Campi tabella pivot .

Elenco Campi tabella pivot

Nell'area Nome campo nella parte superiore selezionare la casella di controllo di ogni campo da aggiungere a una tabella pivot. Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Riga, i campi di data e ora vengono aggiunti all'area Colonna e i campi numerici vengono aggiunti all'area Valori. È anche possibile trascinare manualmente gli elementi disponibili e rilasciarli in uno qualsiasi dei campi della tabella pivot oppure, se non si vuole più avere un elemento in una tabella pivot, è sufficiente trascinarlo fuori dall'elenco dei campi o deselezionarlo. La possibilità di ridisporre gli elementi dei campi è una delle caratteristiche della tabella pivot che ne semplifica l'aspetto.

Elenco Campi tabella pivot

Esempio di finestra di dialogo con l'elenco Campi tabella pivot di Excel

  • Riepiloga per

    Per impostazione predefinita, i campi della tabella pivot posizionati nell'area Valori vengono visualizzati come SOMMA. Se i dati vengono interpretati come testo, i dati vengono visualizzati come CONTEGGIO. Per questo motivo, è importante assicurarsi di non combinare tipi di dati diversi per i campi dei valori. È possibile modificare il calcolo predefinito selezionando prima la freccia a destra del nome del campo e quindi selezionando l'opzione Impostazioni campo .

    Modificare quindi il calcolo nella sezione Riepiloga per . Quando si modifica il metodo di calcolo, Excel lo aggiunge automaticamente nella sezione Nome personalizzato , ad esempio "Somma di NomeCampo", ma è possibile modificarlo. Se si seleziona Numero... , è possibile modificare il formato numerico per l'intero campo.

    Suggerimento: Poiché modificando il calcolo nella sezione Riepiloga per viene modificato il nome del campo della tabella pivot, è consigliabile non rinominare i campi della tabella pivot finché non si completa la configurazione della tabella pivot. Un trucco consiste nel selezionare Sostituisci (nel menu Modifica) >Trova ciò che > "Somma di", quindi sostituisci con > lasciare vuoto tutto in una volta per sostituire tutto invece di digitare di nuovo manualmente.

  • Mostra dati

    Invece di usare un calcolo per riepilogare i dati, è anche possibile visualizzarli come percentuale di un campo. Nell'esempio seguente l'importo delle spese domestiche è stato modificato per essere visualizzato come % del totale complessivo invece che come somma dei valori.

    Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo

    Dopo aver aperto la finestra di dialogo Impostazioni campo , è possibile effettuare le selezioni desiderate nella scheda Mostra dati come .

  • Visualizzare un valore sia come calcolo che come percentuale.

    Trascinare semplicemente l'elemento nella sezione Valori due volte, fare clic con il pulsante destro del mouse sul valore e scegliere Impostazioni campo, quindi impostare le opzioni Riepiloga per e Mostra dati come per ognuna di esse.

Se si aggiungono nuovi dati all'origine dati della tabella pivot, tutte le tabelle pivot compilate su tale origine dati devono essere aggiornate. Per aggiornare una sola tabella pivot, è possibile fare clic con il pulsante destro del mouse in un punto qualsiasi dell'intervallo della tabella pivot e quindi scegliere Aggiorna. Se si hanno più tabelle pivot, selezionare prima di tutto una cella in qualsiasi tabella pivot, quindi sulla barra multifunzione passare a Analizza tabella pivot > selezionare la freccia sotto il pulsante Aggiorna e quindi aggiorna tutto.

Se si è creata una tabella pivot e si decide che non è più necessario, è sufficiente selezionare l'intero intervallo di tabelle pivot e quindi premere CANC. Questo non influisce su altri dati, tabelle pivot o grafici circostanti. Se la tabella pivot si trova in un altro foglio che non contiene altri dati da conservare, è possibile rimuovere rapidamente la tabella pivot eliminando tale foglio. 

La tabella pivot nell'iPad viene distribuita gradualmente ai clienti che eseguono Excel su iPad versione 2.80.1203.0 e successive.

  1. Selezionare una cella nei dati di origine o nell'intervallo di tabella. 

  2. Passare a Inserisci > tabella pivot

    Inserire una tabella pivot in un iPad.

  3. Scegliere dove inserire la tabella pivot. Selezionare Inserisci nel nuovo foglio per inserire la tabella pivot in un nuovo foglio di lavoro oppure selezionare la cella in cui inserire la nuova tabella pivot nel campo Destinazione. 

  4. Selezionare Inserisci

In genere, i campi non numerici vengono aggiunti all'area Righe , i campi di data e ora vengono aggiunti all'area Colonne e i campi numerici vengono aggiunti all'area Valori . È anche possibile trascinare manualmente gli elementi disponibili e rilasciarli in uno qualsiasi dei campi della tabella pivot oppure, se non si vuole più avere un elemento in una tabella pivot, è sufficiente trascinarlo fuori dall'elenco dei campi o deselezionarlo. La possibilità di ridisporre gli elementi dei campi è una delle caratteristiche della tabella pivot che ne semplifica l'aspetto. 

Nota: Se l'elenco dei campi non è più visibile, passare alla scheda Tabella pivot , scorrere rapidamente verso sinistra e selezionare Elenco campi per visualizzare l'elenco dei campi. 

Tabella pivot nell'elenco dei campi dell'iPad

Se si aggiungono nuovi dati all'origine dati della tabella pivot, tutte le tabelle pivot compilate su tale origine dati devono essere aggiornate. Per aggiornare una sola tabella pivot, è possibile selezionare e tenere premuto su una cella in un punto qualsiasi dell'intervallo della tabella pivot e quindi selezionare Aggiorna. Se si dispone di più passare alla scheda Tabella pivot sulla barra multifunzione e selezionare Aggiorna

Screenshot dell'aggiornamento della tabella pivot in Excel per iPad

Se si è creata una tabella pivot e si decide che non è più necessario, è possibile selezionare le righe e le colonne che si estendono sull'intero intervallo di tabelle pivot e quindi premere CANC.   

Suggerimenti e consigli sul formato dei dati

  • Usare dati puliti e tabulari per risultati ottimali.

  • Organizzare i dati in colonne, non in righe.

  • Verificare che tutte le colonne abbiano intestazioni, con una singola riga di etichette univoche non vuote per ogni colonna. Evitare doppie righe di intestazioni o celle unite.

    Colonna 2 di Excel

  • Formattare i dati come tabella di Excel( selezionare un punto qualsiasi dei dati e quindi selezionare Inserisci > Tabella sulla barra multifunzione).

  • Se si hanno dati complessi o annidati, usare Power Query per trasformarli, ad esempio per trasformare i dati tramite UnPivot, in modo che siano organizzati in colonne con una singola riga di intestazione.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto della Tech Community di Excel o ottenere supporto nelle Community.

I suggerimenti per le tabelle pivot fanno parte dell'esperienza connessa in Microsoft 365 e analizza i dati con i servizi di intelligenza artificiale. Se si sceglie di rifiutare esplicitamente l'esperienza connessa in Microsoft 365, i dati non verranno inviati al servizio di intelligenza artificiale e non sarà possibile usare i suggerimenti per le tabelle pivot. Leggi l'informativa sulla privacy di Microsoft per maggiori dettagli.

Articoli correlati

Creare un grafico pivot

Usare i filtri dei dati per filtrare i dati di tabella pivot 

Creare la sequenza temporale di una tabella pivot per filtrare date

Creare una tabella pivot con il modello di dati per analizzare i dati di più tabelle

Creare una tabella pivot connessa ai set di dati Power BI

Usare l'Elenco campi per disporre i campi in una tabella pivot

Modificare l'origine dati di una tabella pivot

Calcolare i valori in una tabella pivot

Eliminare una tabella pivot

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×